Windows 8 64-bit vending machines blocking the entrance

Discussion in 'Bugs' started by Kyua, Jan 28, 2013.

  1. Kyua

    Kyua Member

    Hi, I've had this problem twice now on the last two floors I've cleared, there is a room with a lever, a weapon rack and some other random stuff with the entrance blocked by a vending machine. I read it's possible to move them, destroy them even but so far nothing worked. I've tried with concussion bombs, handy wands and attacking repeatedly with skills but to no avail. Since I've got no way to teleport with this build, should I just forget about it or is there something else I can do?
  2. Wolg

    Wolg Member

    If you can get to a position where you can see the lever and have the second rank of Paranormal Investigator... the lever removes the machine. Otherwise, teleporting is the only way to get in that I'm aware of, as by design the machine can't be pushed.
  3. Wootah

    Wootah Member

  4. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    It's a room from YHTNTEP (and ID before that). Back when it was first created, it was always pushable by anything with knockback. It was intended that at least a third of the skills in the game would allow you to get in there, so it would be a rare character that was totally unable to do so.

    Somewhere along the line a bug crept into the program. Because of that bug, when you save on any given floor, many terrain objects on that floor that were previously pushable stop being pushable. I believe this bug was introduced about the same time they changed the save game format to make copies of all your mods. I believe there was talk by the devs of fixing that in an upcoming build/patch of the game... but that conversation was nearly half a year ago so I may be mistaken.

    In the meantime, solutions include:
    • Teleport in any of it's many forms.
    • Digging abilities from Golemancy or Werediggle.
    • Paranormal Investigator's lever-pulling skill.
    Even if you lack the correct skills, there are a few main-game items that can get you into that room:
    • Instability Infusion
    • Bolt of Mass Destruction
    Once you're in the room, pulling the lever in there will destroy the vending machine, so you don't have to worry about getting stuck if you use your last instability infusion getting in.
    Kazeto likes this.
  5. Essence

    Essence Will Mod for Digglebucks

    I've actually come across a similar problem in 3 games in a row(!) now with the Pull Lever to Engage Dark Forces room. The level and the pedestal are in a row, and the third square on that platform, which you're supposed to be able to walk through, was blocked by a vending machine in all three games.

    I had to go downstairs and back up in order to explore the other side of the room in two of those cases. (Last one I was playing Elemental Warrior and just Winded across the gap.) But there should be a <noblockers> tag on that room, clearly.
    Kazeto likes this.
  6. Wootah

    Wootah Member

    I have had this problem too, although sometimes it is just a table. I have accidently pushed the blocking object into the corner, making it impossible to get past.
  7. Kyua

    Kyua Member

    Thanks everyone, I should have a bolt of mass destruction or two stashed up in the pocket dimension, guess I'll try with those (being a pack rat helps sometimes).