OS X Snow Leopard Vanishing armor absorption?

Discussion in 'Bugs' started by madcow, Apr 13, 2012.

  1. Kazeto

    Kazeto Member

    Actually, you can't really do it because what I wrote was right, only it wasn't a full description of what was happening (it didn't happen only when you levelled up, that is what I was missing, but then again I never wrote it doesn't happen at other times) - because really, you just quoted a post that is three months long (and one that you had pretty much replied to, only without quoting it).

    I don't know how did that bit of craziness happen, but I suggest getting some sleep.
  2. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    Sorry, no offense was intended. I don't think that there was anything wrong in me replying to your statement, other than the general thread necro taboo. BTW, it's only 7:00 pm here, so I wouldn't be able to sleep if I tried.

    I was relooking at the thread because the bug is back, despite having been reported as fixed. I saw that Nicholas seemed to think your explanation was correct and that it made this an easy fix. But now we're two versions later and the problem persists. So either he forgot to implement his easy fix, or that wasn't the cause of the problem after all. I'm guessing the later, but I could be wrong. Whatever the cause of the problem, getting Nicholas' attention back on this longstanding persistent game-wrecking bug is important.

    I suppose I could have phrased my previous post better ("it doesn't seem that way to me" instead of "I can disprove that theory"), or simply referenced your post in a way that let Nicholas know it might not be the same issue without actually quoting and thus sending you an alert in the process. I didn't think this would annoy you, and I'm sorry if it has.
    Kazeto likes this.
  3. Kazeto

    Kazeto Member

    Don't worry about it, I sometimes do things like that too, replying to ancient things in weird ways. And I only suggested getting more sleep because I usually do such things when I'm tired, so there was a chance that you were tired as well.

    So no offence taken, and I hope my reply didn't offend you either.

    And I reckon the problem is that the fix just got broken - it's not the first time something that had been fixed in the past would stop working again, and they can't really play-test the OS-X version as much as they play-test the Windows version.
  4. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    Don't get me started on that. :rolleyes: There's a lot of backstory in regards to the playtest and beta of the Mac version.
  5. Chris Whitman

    Chris Whitman Member

    OK, I've tried this on both PC and Mac with a variety of buffs and I can't reproduce it. We did make some changes to buffs and the buff apply/deapply stuff, so it's entirely possible that we fixed this by accident while fixing another bug. It's also possible that I'm just not doing whatever induces the bug. If you can get a save into a state where this is happening, send it my way. Until then I'm not sure there's a lot I can do.
  6. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    Attached to this post is a save game where the character's :melee_power: is much lower than it should be (completely zeroed out if I'm remembering correctly). One day it was fine, and I was clobbering diggle butt. The next day I loaded up the save game and my attacks seemed a little weaker than they had been. Then I watched my :melee_power: melt away entirely over the course of half an hour or so.

    It's never happened to me in the first couple floors. The earliest it's ever hit me was probably around the fourth floor or so, and I know that at least once I made it all the way down to floor 10 before it happened.

    It's also never happened on the first day of playing a given character. It's always struck after loading up a saved game from a previous day. Maybe it has something to do with saving while the proc-buffs are still active? Just a thought.

    Despite not setting in right away, it's certainly not rare. It's crippled quite a few characters for me. Every single character I've ever taken past the first floor the combo of Dual-Wield and Berserker has eventually lost too much :melee_power: to be playable. I've retired at least half a dozen warrior half way through the dungeon because of it.

    Attached Files:

  7. OmniaNigrum

    OmniaNigrum Member

    Any notable encrusting that could account for the drop over time by procing the debuffs? (I presume not.)
    Exile likes this.
  8. Doomicide

    Doomicide Member

    I just noticed this bug, armor absorption and melee are affected.
    Parabola GNU/Linux 64
    Version: 1.12

    Master of Arms: maxed
    Dual Wield: 1
    Smithing: maxed
    Berserker Rage: maxed
    Blood Magic: 2
    Viking Magic: 1
    Hammers: maxed

    Attached Files:

  9. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    This thread now has two buggered save games posted to it for you to peruse. Both save games are from versions contemporary to or released since your post. One Mac, one Linux. Both involved characters with Dual Wield, Master of Arms, and Berserker Rage. In both characters, :melee_power: and :armor_asorb: are much lower than they should be, which corresponds to things that get buffed by M-o-A and BR. My guess is still that DW somehow causes those buffs to be removed twice.

    In my experience, it doesn't hit until after you've saved, exited out of Dredmor, relaunched and reloaded, and I've never seen it happen before floor 5 or so. To see it happen yourself, you'll probably have to play a character down very far into the dungeon over a couple play sessions. I would not expect it to show up if you're just poking around for an hour or a couple floors. It's also possible that it requires having one of the buffs from M-o-A or BR active at the time you save and quit, but I'm not sure.

    Once it starts, though, you can usually see your stats fall during combat, every time a buff wears off, the linked stats are reduced permanently.

    Doomicide, thank you for posting your save game file. I figured if it was still hitting my machine, I couldn't be the only one.
    OmniaNigrum likes this.
  10. Nicholas

    Nicholas Technology Director Staff Member

    There's no good way to say this so this will come across as a bit harsh. The two save games we have are:

    - a save game from a Beta Dredmor from July 20th, which we can no longer load (Bergstrom)
    - an empty folder. (Doomicide.)

    So, yeah. Not the best things I've ever seen in terms of tracking bugs down. :D Chris is still trying, but if somebody has a save game made with the most recent Dredmor build that exhibits this, this is what we need. Doom, if you actually have a save game with, um... files in it? That'd be good. :)
    Exile, OmniaNigrum and Vitellozzo like this.
  11. Hi. I just encountered a similar problem. My character is supposed to have about 40-something counter chance out of combat, but instead it got reduced to 15 somehow and is now stuck there. None of my items or skills seem to be adding anything to counter any more. Wall of blades stance doesn't add anything (it's still adding block though), combat momentum doesn't add any, equipping a sword isn't adding any.

    I'm playing on 64 bit Linux, version 1.1.2, copied over from steam with all the expansions.

    Savegame uploaded, hope it helps.

    I did level up while clearing a monster zoo shortly before it happened, although I can't tell you whether it happened that exact instant or not - I didn't notice it until a bit later.

    Attached Files:

  12. Doomicide

    Doomicide Member

    Ouch, I'm sorry, I don't usually use zip to compress stuff and apparently I'm too stupid to read the man-page....
    This should be working now....

    Attached Files:

    OmniaNigrum likes this.
  13. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    No, it wasn't harsh at all. For my part, I deserved what little scolding you gave me.

    I'd forgotten how old my saved game was, and I hadn't realized doomicide's file was empty. So I imagine my whiny prodding was very frustrating. Sorry about that. Please extend my apologies to Chris as well.

    For what it's worth, I'm quite certain I've hit the bug more recently than that old save. Maybe not the latest patch, but certainly since Chris's post, and since CotW. Problem is the more-recent bugged games were while playtesting an early version of the swashbucklers mod that doesn't exist anymore, so even if it turns out I have the save files squirrelled away somewhere, they may be complicated by other miscellaneous mod-bugs that make it less-than-ideal for you to work with.

    I'll put a note on my todo list to see if I can personally replicate it with the current build. The bug has never kicked in until I had at least 5 or 6 hours of play on a character, and usually doesn't manifest till around floor 8. So it's not going to fit my schedule in the next couple days.

    In the meantime, have the two other files people have posted since your reply proven helpful?
    OmniaNigrum likes this.
  14. Doomicide

    Doomicide Member

    Second character with this problem, this time without berserker rage. Technical Details are the same. Skills:
    Battle Geology
    Master of Arms
    Clockwork Knight
    Dual Wield

    My best character on GRPD so far and now on DL12 the bug starts kicking in.... This is so frustrating, I really thought I'd get Dredmor this time. Oh well, let's try a mage build in the mean time. Save is attached.

    Attached Files:

  15. peko

    peko Member

    I'm having a problem with my dodge being reduced. I noticed that I was missing 30 or so points when I loaded my save the other day. I don't think the points were missing until I loaded the save that day but I can't say for sure.
    I've got one buff that increases dodge (second sight, +5 dodge amongst other things) however none of the other stats that are buffed don't seem to be affected.

    Skärmavbild 2012-10-05 kl. 08.36.26.png
    According to the dredmod wiki I should have ,5 dodge / nimbleness. Thats 38, not 10.

    Daggers 5
    Assassination 5
    Burglary 6
    Perception 4
    Rogue Scientist 7
    Dual Wielding 1

    I'm on OSX 10.8.2 running Dredmor with all expansions and no mods.

    I also noticed that at least two of my earlier saves have this problem, they´re quite old though so I don't know if they're of any use. I'll upload those two as well, can't hurt to have more data points.
    Kyrias is the new one that doesn't get to dodge.

    Edit: Just realized that Perception grants +10 dodge, so those could be the 10 points that are showing.

    Attached Files:

  16. Kazeto

    Kazeto Member

    That's the problem. They are supposedly working on it because the OS-X build has that problem, so feel free to pester Nicholas about the estimated patch date.
  17. peko

    peko Member

    So it works as intended on 10.6 or 10.7? Because I have room for an extra partition with an older OS.

    Edit: The dodge chance on my rogue has gotten back to were it should be somehow. Perhaps leveling without any active buffs fixes the problem.
  18. Kazeto

    Kazeto Member

    No, it does not work at all.

    To put it in an easy-to-understand form, there are three builds for "Dungeons of Dredmor":
    One build works for operating systems using a "Windows" core (Windows).
    One build works for operating systems using a "Mac" core (OS-X systems, all of them).
    One build works for operating systems using a "Linux" core (generally speaking all Linux-based systems, with possible exceptions).

    So if your operating system is an OS-X one, then it does not matter what system is it because all of them will have the same problem, caused not by the system but by something being wrong in that particular build of "Dungeons of Dredmor". The only way for it to start working is for GLG guys to fix that bug in that particular build.

    And yes, levelling up without any active buffs and saving the game without any active buffs is a way around it (the bug is being called "reverse buff integration" after all, even if it is not its official name).
    OmniaNigrum likes this.
  19. peko

    peko Member

    Heh. A little more easy-to-understand than necessary but thanks.
    Kazeto likes this.
  20. Kazeto

    Kazeto Member

    What can I say, I spend 8 hours every working day trying to communicate it to people of often sub-par comprehensive ability that if they want this they should get that thing, or if they want something to do another thing they should do that, etc. (I work in a store; and I often get customers of advanced age, meaning they really need step-by-step explanations and are asking weird question, because the folks think I'm nice and want me to help them; and I also get customers who know nothing about electronics but want to know sent to me too, because it's a "general" store and I'm the one who knows where goes what stuff with electronics) and before that I had a younger sibling at home (so a lot of experience dealing with really stupid people), and if I'm not required to actually say things in a way that would be understandable I tend to speak something that would shame lovecraftian gods when it comes to ease of understanding, so I tend to go overboard when I know it's supposed to be "easy".

    In any case, I hope the version they are testing now will have that bug fixed so that you'll be able to play without controlling what buffs you have like an old man controlling his pills.
    OmniaNigrum likes this.