OS X Snow Leopard Vanishing armor absorption?

Discussion in 'Bugs' started by madcow, Apr 13, 2012.

  1. Lobo

    Lobo Member

    You sound confident; are you sure this is the case? I would try to verify it, but I'll first need to work up the willpower to sink some hours into a sacrificial character...

    If the problem is as you say, I wonder why the bug seems to happen only with Necro (perhaps conjoined with Fleshmithing's Meatshield?) and with Dual Wield (perhaps conjoined with Berserker Rage and Master at Arms), and not with other buff-granting skills.
  2. Kazeto

    Kazeto Member

    Yes, it's something that was known to affect DoD a few versions ago regardless of the OS. It was coined with a name "Reverse buff integration", and I think it also happened when you loaded the game that you saved while having buffs active.

    Basically, the game included the buffs when calculating the new values when you levelled up (or when you loaded the game after saving it), and thus that +2 AA from a buff ended up decreasing your AA by 2 points when you gained a level. I'm not sure if it happened with every buff back then or just with some, but I know that the armour-related ones and the ones from Necronomiconomics had this problem.
    OmniNegro likes this.
  3. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    I kinda suspect these are two different bugs that just have similar symptoms. I've been playing a lot of necro lately, but thus far have never experienced the necro bug boosting any of my stats above what they should be. If I run a melee character with dual wield / berserker / master of arms, my armor bottoms out suddenly sometime between floors 8 and 10. That sure feels more consistent than luck, but I'll acknowledge that my sample group is small and most of the data anecdotal - it's not like I've played the same build to floor 10 a hundred times and kept logs of the results.
  4. Lobo

    Lobo Member

    Ah, I see. So that explains why the [Dual Wield / Master of Arms / Berserk, in whatever combination] bonuses eventually manifest as permanent stat reduction, whereas the Necro debuffs eventually manifest as permanent stat bonuses.

    I've been griping about both these problems for weeks now and yours seems the best description of the bug so far. Hopefully that will give Nicholas and Co. something more to work with. Thanks!

    What do you make of this hypothesis: the broken melee buff is probably one or more of the Berserker Rages, since they affect both melee power and armor absorption, both of which have been observed to suffer from the bug. And the broken Necro debuff is probably Curse of Weakness, or perhaps both Lingering Weakness and Blood Debt are at fault; all of these affect life points and/or health regen, both of which are bugged.

    So far as the Necro version of this bug goes, I fired up my save (which I had earlier posted to the separate Necro bug thread) and looked at melee power. The same Level 8 character that has 21 health regen has only 3 melee power, which seems appropriate given a Burliness of 16. This suggests that he didn't receive "Reverse Buff Integration" from Curse of Weakness, since that should have also boosted his melee power. Or if he did get Reverse-CoW'd, then for some reason only the life points and regen took effect.

    I wish I had your luck. I hadn't played Necro at all until 1.0.10 hit, and then I decided to give it a go. So far of my three Necro characters, none have made it past dungeon level 3 before becoming bugged.
  5. Nicholas

    Nicholas Technology Director Staff Member

    Is *that* when it happens? Gah, that's blindingly obvious.

    If this is the case, I can have it fixed for 1.0.11 no problem.
    Exile likes this.
  6. Nicholas

    Nicholas Technology Director Staff Member

    Okay, I think I figured it out.

    Essentially, what is happening is that a buff is being deapplied (as people note) - if not twice, then multiple times. Now in theory, this should never happen. Once a buff is deapplied, it should basically go in the recycle bin in the sky. The exception to this is if either a) it is deapplied and not deleted, or b) it is deapplied multiple times by accident before it is deleted.

    So there is *one* case where you might deapply a buff and not end up deleting it. If you have a buff that does not allow stacking (allowStacking="0" for the XML hounds), what happens when you recast the buff is simply that it kicks up the timer. Now if you deapply a buff, then somehow reacquire the unstackable buff, then it's deapplied but won't be deleted because you managed to kick the timer up again before the next buff garbage collection pass...

    Of course this happens during level up: you deapply all of your buffs, you gain the level, no GC pass happens at this point, and then you get the buff again during ApplyBuff(), but ApplyBuff() doesn't actually *re-apply* your buff w/o stacking because it thinks it's still there, it just resets the timer... and your secondary stats inc doesn't get incremented.

    So, ..... yeah, ugh. What a doozy. I think I have it figured out, and I will probably put up patch RC7 with a fix just to test that this bug is dead in the expansion tomorrow (and that the fix doesn't introduce more problems.) Essence, if I do get this fixed thanks to Kazeto's prompt clue reminder, then I nominate him for the Hall of Badasses.
  7. Lobo

    Lobo Member

    Excellent news!
  8. madcow

    madcow Member

    So I didn't specifically see it in the patch-release notes and haven't had any chance to play since all the awesomeness officially went live. Is this issue fixed now?
  9. FaxCelestis

    FaxCelestis Will Mod for Digglebucks

    AFAIK, yes.
  10. Nicholas

    Nicholas Technology Director Staff Member

    Yes, this was fixed.
    Exile, TheJadedMieu and r_b_bergstrom like this.
  11. madcow

    madcow Member

    Great to hear it!
  12. Sheika

    Sheika Member

    I had this problem in my last game, i realized it only before my death: my absorption dropped to 3 (from a value of 25-26 more or less) and my melee power to 1 (i was at level 20 with only 1 level of wizard, the other were all warrior's levels)

    My build was: Mace, Berserk, Master of Arms, Shield, Smithing, Assassination, Fleshsmithing and i was playing via steam on my macbook

    I don't have a screenshot nor a save (it was a permadeath run)
  13. Kazeto

    Kazeto Member

    What version?
    And what OS, too?
  14. Sheika

    Sheika Member

    Snow Leopard, version of the game 1.0.11
    I had also activated 4 mods: More Dred, Meltdown, Roguish Renovation, Leather Coat and Sabatons (but i didn't have equipped or in my inventory any of the new items added by the mods)
  15. Daynab

    Daynab Community Moderator Staff Member

    It sounds as if the fix didn't propagate to mac somehow. There was another report elsewhere and it was a mac user as well.

    We'll look into it.
  16. Sheika

    Sheika Member

    Thanks for the answers ;)
  17. Lobo

    Lobo Member

    Is it possible to confirm that this bug still exists in the Mac version? I'm a Mac player and I would love to play a necro build, but I'm fearful of losing yet another character to this bug. I'd rather wait for the next patch, if need be.
  18. ShallowGrave

    ShallowGrave Member

    I too am still experiencing this bug on OS X when I use buff-heavy builds. My most recent berserker had her melee power debuffed so low that it was constantly at 1. Even wearing melee power boosting gear and procing Berserker Rage multiple times couldn't boost it above 1.
  19. Lobo

    Lobo Member

    So, now that 1.1.1 is out, is anyone able to confirm that the fix for this longstanding, character-ruining bug has finally propagated to the Mac version? *crosses fingers*
  20. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    That's not my experience.

    I can confirm that as of this weekend, this is still not fixed in the Mac version.

    The character I was playing had around 10 :melee_power: on Saturday, but by Sunday morning had hit 0 :melee_power:. Actually, while it displayed 0, it was clearly behaving as if negative. A few rooms past where it bottomed out, I picked up an item with +3:melee_power:. Equipping or unequipping this item made no change to my 0 stat.

    I've still got the save game if you're interested, Nicholas.

    I can disprove that theory, at least in regards to my :melee_power: loss this weekend. I actually watched my last couple points of :melee_power: fade away, one at a time, as Berserker buffs triggered and wore off. It did not have any noticeable correlation to leveling up, and happened much more quickly than my level-ups did.