The Current Bugs Thread!

Discussion in 'Bugs' started by rydash, Aug 1, 2012.

  1. Daynab

    Daynab Community Moderator Staff Member

    Known, they just discovered it pretty late in the test period and had no time to fix it for the release.
  2. Duke

    Duke Member

    Achievement counters reset. -.- Bug or intended?
  3. rydash

    rydash Member

    Probably a bug, but a longstanding one. I'll point to the Steam Achievement Manager in one of the OPs for folks who'd like to reset such things.
  4. Borodin

    Borodin Member

    Opened a zoo, and midway got a level. Killed the last creature, got a reward, and a CTD. When I ran the autosave I had a few creatures left and got a reward, but after going back to my portal dimension, two useful objects were missing: the distiller and alchemy kit. Everything else appeared to be where I'd left it.
  5. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    IMHO, this is not a bug in the same way that "sometimes there's artifacts on little islands where I can't reach them unless I take certain skills" is not a bug. As near as I can tell, it's all intended behavior and function, designed to make your choices at character creation meaningful. Heck, the newest expansion even includes new skills that give you new ways to pick up items or open chests that you can't get adjacent to.

    The main-game room with the artifact in the upper right corner behind a lava moat, bars, and acid bolt trap is clearly intended to sometimes randomly be sealed off. The room is specifically coded to do this, and the code to do so actually added sometime after the room's initial debut to increase it's difficulty. IIRC, it was added in 1.0.8, and the extra code that was added did nothing except randomize which side you could enter that area and thus introduce the possibility of it being sealed off entirely.

    Something like 30% of the skills in the game (nearly anything with a teleport or knockback) provide a solution to this "bug", and even if you don't take any of those skills, there's a number of common items that can do the trick. Even if you lack any of the appropriate skills, and don't have concussion bombs or other knockback items, you can still frequently get around such obstacles by clever use of staircases.

    I believe these are not bugs, they are minor puzzles to be solved by careful character creation or thinking outside the box during play.

    While my previous statements were merely opinion, this one I can say definitively is not a bug. I designed that room to intentionally always spawn the fountain there. It serves as a sort of window into the room. Spells that require sight, but not line-of-sight can fire into the room, but attacks that are blocked by intervening terrain cannot. It's a tactical feature intended to help differentiate between build choices, and give wizards a very minor situational boost on floor one where they are traditionally squishy. The area is sealed off but can be opened by a single click, so you can also peak through the window to get a head count of the monsters and then decide whether or not you need to level up before setting them loose.
  6. Chompie

    Chompie Member

    Here's a couple I've noticed:
    - The third skill for polearms (the one that just gives a passive 5 melee power and -2 crit) gives twice the Melee Power it should. There's no other reason that picking it would suddenly jump my MP from 5 to 16.
    - You can still critically hit with 0 crit. Using the Swiss Defensive stance, and with the Polearm Melee Power skill, my crit chance on the character sheet shows up as 0 (and sometimes -2), but I still got a critical hit. Once.

    Finally, there's something weird going on with melee power and crossbows...
    My crossbow ended up dealing 4 Crushing, 2 Slashing, 2 Blasting, and a few Piercing damage in one shot to.. a potato, I think it was. Something low to no armor on the first floor, anyway.
    All I fired was:
    - Crossbow Mastery up to Crossbow Blast (1 Piercing damage, 2 EDR, 1 Crit)
    - The tiny, worst little toy crossbow (1 piercing damage)
    - Wooden Bolt (2? Crushing damage)
    - Exactly 2 Melee Power

    I know that Melee Power beefs up Crush/Slash/Blast for melee attacks if you have all of them (Like if I'm using a mace with only crushing, if I get pants with 1 Blasting Damage, my Melee Power will have some effect on that, and I will do more than 1 Blasting frequently)-- but this is double wrong. Melee Power should not be affecting crossbows, AND it should not be buffing up any of the Crush/Slash/Blast group if you don't already have a non-zero source of that damage. I dunno what to think about this!
  7. Aegho

    Aegho Member

    First thing with polearms: do you dual wield 2 polearms? All weapon skills give their passive bonuses per weapon equiped.
    Yes criting with 0 crit is possible. Intended, not bug.
    Melee power has no effect for crossbows. Have you checked your ranged damage bar in the character window? That's your crossbow damage(bolt not included).
  8. Nicholas

    Nicholas Technology Director Staff Member

    First crack at a bugfix round:

    This *should* fix the problems with saving for international users, and it should also fix the encrusting stuff and some other miscellaneous bugs (whatever Chris got to.) Hopefully it will fix some of the save game corruption issues as well, but we're still trying to track down what causes it all.

    Please give ita whirl, and let me know if it breaks anything else. Note that this is *EXPERIMENTAL* and used at your own risk.
    Exile and DragonDai like this.
  9. Chompie

    Chompie Member

    - Off-hand was empty- I can accept communist bankster vegan vampires, but dual-wielding polearms is far too unrealistic for me. (also I wasn't finding crap on that floor one)
    - Well that's baffling! XD
    - The ranged damage bar had only 2 Piercing in it at all- another floor 1 situation where I just wasn't finding crap for gear.
  10. Aegho

    Aegho Member

    Tried it. Also tried changing my language settings to english[canada}. Neither worked. Still cannot save.
  11. By "save game corruption" does this mean the random crashing when you enter the pocket dimension? Because that's been the main issue preventing me from doing much of anything right now (sorry if this should be an obvious question; I'm just trying to be clear which problems this is addressing >.<)

    (Of course pretty much anything would make the game more playable at this point so~)
  12. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    Two things that strike me as odd, but may or may not actually be bugs:
    1. Special="1" does not appear to be working correctly on rooms. When it misbehaves, you get a second copy on the floor of a room that's supposed to be restricted to once per floor. It used to misbehave rarely, maybe one floor in 10. Now I'm seeing it happen much more often, like every second floor or so. Could just be the RNG on a streak on my machine or some sort of gambler's fallacy / confirmation bias issue in my brain, but it might also be a sign of an underlying bug in the code.
    2. Is tourist supposed to be wizard skill? Several things make me wonder just a little if it got assigned the correct archetype: None of it's levels use mana, they're just cooldown abilities instead of spells. It provides :trap_level::trap_sense: :sight: and bonus money, all of which had previously been rogue abilities (though of course Mathemagic also provides money as a result of casting, and the new Egyptian magic includes the trap abilities for wizards, and smithing gives it to warriors, so they're not really rogue-exclusive I guess, but smithing did used to be a rogue skill once upon a time). Tourist also includes a cancel-able buff that has -25:sneakiness: as it's drawback which is totally a downside for a rogue, but will rarely be a reason for a wizard to turn it off. Generally, by the time a wizard regrets not having stealth, it's already too late, whereas a rogue might care about :sneakiness: from action to action as some rogue abilities scale off it . Overall, this feels more rogue than wizard to me... and if that were a copy-paste error, it'd be a really easy one to miss since nothing in-game directly identifies the skill archetype except trial-and-error colorbar observation when you level up. Anyhow, probably not a mistake, but possibly worth running by the devs just to be sure.
  13. Daynab

    Daynab Community Moderator Staff Member

    I'm not entirely sure, but it's worth a try. Just backup the files it replaces, just in case.
  14. I mean at this point I'm pretty consistantly getting crash errors and losing my saves before the end of the second floor so it can hardly make things worse :p

    (If these issues are related to savegames that might explain why I seem to be progressing much less than other people before everything breaks, since I tend to take breaks or switch characters a lot and don't play with permadeath >.<)
  15. Chompie

    Chompie Member

    Using the test hotfix, found an Amber Ring of Unending Time, and it hasn't crashed the game yet! Saving and entering Wizardlands seem to both be working for me so far as well.

    ... though I haven't had a crash since the expansion came out (and had never found the amber ring before now) so perhaps that data's not really useful.

    Also MAN that amber ring is frickin strong when you find it in a first floor fountain. This could be a long-lived run?!
  16. Nicholas

    Nicholas Technology Director Staff Member

    Okay, so we have confirmed for one person at least that this can fix your save games not saving. The catch - which we're still trying to sort out - is that you need to delete your Gaslamp Games folder. So go into My Documents, find the folder labelled Gaslamp Games, and delete it. (This may only apply to Windows XP users, I don't know yet.)

    This one also contains a bunch of other balance and expansion fixes from Chris and David. It should also *not* generate broken saves any more where you can no longer ascend or descend, but there are a litany of these things to work through and think about. So please try it out and report any feedback you have.
    Exile and DragonDai like this.
  17. I installed the hotfix and it seems that my achievements aren't displaying anymore? (except the "suddenly the dungeon collapses" one).

    ETA: OOOOHHHH wait I think that was because I zapped my Gaslamp Games folder.

    Also I'm having some sound issues but I'm pretty sure that's windows being silly. >.<
  18. Nicholas

    Nicholas Technology Director Staff Member

    This isn't built versus Steam, as that can cause hotfix issues; consequently, it's not talking to Steam to get your achievements.

    How's the saving and crashing, though? Is that better?
    Exile likes this.
  19. Daynab

    Daynab Community Moderator Staff Member

  20. Thanks for explaining that - that's actually quite nifty!