The Current Bugs Thread!

Discussion in 'Bugs' started by rydash, Aug 1, 2012.

  1. DragonDai

    DragonDai Member

    Okay, so, the last couple of days I did some GR:pD games with Rogue Scientist. Figured the skill had been around for forever, it was high time I tried this out. I had this happen many times, though not nearly even a majority. Probably tossed out 200-300 canisters over 3 games, and crashed maybe 1-2 dozen times. Every single time it was throwing the Canister into an active zoo. Every, single, crash. And after the first one or two, when I realized how the skill worked, I was very careful not to throw it at squares where a monster was or that a monster was blocking. However, it often landed on squares with corpses. And I am nearly positive this crash only happened when I threw the canister onto squares with lots of corpses (and again, 100% sure it only happened in active zoos).

    Sadly, I had no saves, cause PD and it not being a big issue, so I just kept playing, but now that I know it's an issue that needs more research, If it happens again, I'll get the save to someone. Hope that helps.
    Vitellozzo and OmniaNigrum like this.
  2. Alistaire

    Alistaire Member

    A question;

    Is <ai stealgold="1"> necessary for there to be a stealPercentage parameter in <ai>, Or are stealgold and stealPercentage not used for the same kind of stealing?
    I take it stealgold signifies the monster is able to steal your GOLD, and stealPercentage is the percentage chance an attack will steal your ITEMS, but to be honest I've never seen a monster steal my items (?).

    The Kleptoblobby has a stealPercentage="20" but no stealgold="1", while Lucky has both.

    Post Scriptum;

    After finding out about the <stats> tag's steal="1" and stealgold="1" settings I'm even more confused. Is this an optional setting for stealing gold or stealing items, which is different from the <ai> tag one?
    Some monsters have only an <ai> tag with stealgold="1" or stealPercentage, others only have a <stats> tag with steal="1" AND/OR stealgold="1"

    The Kleptoblobby has <ai stealPercentage="20"> <stats steal="1">, Lucky has <ai stealgold="1" stealPercentage="50"> <stats stealgold="1"> but no steal="1" (which I suppose is used for the stealPercentage).

    Even if the <stats> tag is supposed to have the boolean (steal and stealgold), the <ai> tag has a boolean AND a percentage (but only for steal, not for stealgold?).

    More madness;

    A Lastâ„¢ Question: does the <onhit> tag trigger when the monster attacks the player (a bad playerHitEffectBuff), or does it trigger when the monster is hit (targetHitEffectBuff)?
    Last edited: Jul 30, 2014
    OmniaNigrum likes this.
  3. Kaidelong

    Kaidelong Member

    Not a bug, ravens have necro resist which prevents the drain from affecting them unless it's very strong.

    This one is actually a crash bug, the game will eventually crash after this happens enough when it swaps out the background music. Recommend playing with music off.

    Anything I can do to remove the question marks off of these? I have encountered both.
    Last edited: Jul 31, 2014
  4. Vitellozzo

    Vitellozzo Member

    There is even an achievement for being robbed of a high stack of items, one time one of those stealing monsters had robbed me my stack of like 200+ mushrooms.
    I had mind it surely died in a painful way.
    But i dunno how it works in mechanics.
    Kazeto and OmniaNigrum like this.
  5. Alistaire

    Alistaire Member

    Placing --'s in your comments closes them. This means that;

    <!--Item   --   Some description on the item-->
    Will parse "Some description on the item -->" as code, even though it really shouldn't (?)


    Might be more of a heads up than a bug report
    OmniaNigrum likes this.
  6. Alistaire

    Alistaire Member

    Every artifact item has an extra linebreak between its quality and its description text elements; normal items don't have this. It looks like it's a product of having text appended to it (it's studded with gold and rose petals).

    It really messes with my mod's descriptions though, and it generally upsets lord Qa'ah Br-Cssdiv-\n\r, god of consistent description text alignment.
    Kazeto and OmniaNigrum like this.
  7. Fateofman

    Fateofman Member

    Is there any way I can get a link to the newest hotfix? I can't find any obvious place to get it
  8. Daynab

    Daynab Community Moderator Staff Member

    From your Steam library, right click the game and go in properties. Subscribe to it in the "betas" tab.
    Kazeto likes this.
  9. Fateofman

    Fateofman Member

    Done, thank you
  10. Vitellozzo

    Vitellozzo Member

    Are there actually hotfixes as beta?
    I thought there were no new patch until the end of time.
  11. Daynab

    Daynab Community Moderator Staff Member

    I uhhhh thought they were talking about Clockwork Empires since the thread has the same name as the CE one and I didn't see it was for Dredmor. :D

    Vitellozzo likes this.
  12. Kazeto

    Kazeto Member

    Well, even the broken clock is right twice a day ... in the same vein, despite replying to something else than you though you were replying to, you had actually given advice that helped the guy.
    Vitellozzo likes this.
  13. yuma_bill

    yuma_bill Member

    Entering the 5th floor from the 4th I "stepped into a mist." That's what the message said anyway. All the dungeon scenery was black. The only things visible were the HUD and items that could be interacted with like loot on the floor, doors, myself, my pet. Also I could see animated squiggles of mist vapor as if I'd stepped on some kind of trap, but they faded away and the blackness remained. I saw no status icon for, say, blindness or the like. Going back to the 4th floor everything was normal. I tried another entrance and it was the same problem, blackness everywhere, then my game crashed.