Windows Vista/7 64-bit Teleport Bug

Discussion in 'Bugs' started by fiddler, Dec 22, 2011.

  1. fiddler

    fiddler Member

    This morning I leveled up and put a point into the Dodge skill netting me Transdimensional Dodge. I dodged a few attacks, all was right in the world, then I logged off for work. When I booted the game up and tried to continue on with my adventure, I took one step and teleported back to my starting square. Moved a different direction, and snapped back to the original square. If I use a skill, I teleport and do not move at all. If I take any damage, I teleport, and again do not move squares. I tried dropping a wall on myself to shove me over and maybe break the hold on that square. Instead, I teleported back to the same damn square but now inside that wall.

    I wouldn't normally care, because the game is all about starting over. BUT, I'm on level 9, never been anywhere close to that far before, and do not want to start over again because of a bug I can't get around. If anyone knows anything I can do to maybe get out of this infinite teleport, please help.
  2. telebug

    telebug Member

    I'm having the same problem, except in a completely different context. Level 7, no kind of teleport skill whatsoever, and I keep getting netted back to the same square no matter what I do on my turn. I'm right at the opening to a doorway if it can be used to find some commonground here. Windows XP, normal mode no respawn w/ DLC.. not sure what else I can list as I don't remember what happened just before I got stuck.
  3. Zaxorian

    Zaxorian Member

    I'm having the exact same problem on the autosave file and the "normal" save file even though they are not located at the same spot or level.
    Running Win7 64-bit with the DLC.
  4. Moglok

    Moglok Member

    I'm having this issue too. I went from floor 5 back to floor 4, took one step and now i teleport between a bunch of rooms.

    My character is effectively lost unless this can be fixed for this save.. It seems EVERY character I make is killed by bugs/crashes rather than the game. They need to sort this sh#t out before releasing games/expansions, what's the point in playing if they game is going to crash/bug atleast 9 times out of 10 at some point.
  5. elimis

    elimis Member

    Similar issue. I loaded my save, and now when I take any action, move or right click, I teleport twice. Always to the same locations which are not where I was. I don't have a teleport skill.
  6. mongrel222

    mongrel222 Member

    Same issue here. I loaded my save from 1.0.8 in 1.0.9, and every move causes a teleport. If I use the Froda's Jump Discontinuity skill, I teleport twice. My level 14 character savegame is now unplayable. :(
  7. CarbonDrake

    CarbonDrake Member

    Alrighty, going to add some details I spotted on my one. When I teleport, there's an animation that looks like either snapping fingers or flipping a coin, and there's a secondary teleport ring a few squares away in the wall. I always get teleported to the same spot every time, an "Express Post" room
    Side notes, my character can in no way teleport normally, and there also seems to be a bug where the last monster in the monster zoo has vanished somewhere. My last manual save was just after I'd given up trying to find it.
  8. Moglok

    Moglok Member

    I am getting teleported between an express post & a square away (in the doorway) from a mass pitting room.
  9. CarbonDrake

    CarbonDrake Member

    Moglok, are you getting teleported to on-top of an open evil chest in the express post? I'm thinking it might be something linked to whatever puts the evil chests there.
  10. Muraz

    Muraz Member

    If it helps, that's exactly what happened to me. I loaded up my character who was on floor 3 and kept getting teleported straight to an evil chest which I'd opened with the "lever that drops three evil chests" thingamajig.
  11. Kojiero

    Kojiero Member

    Huh, that's the same situation with me. I keep teleporting onto the evil chest and back. In addition to this, I had the skills Broadside and Flames of the Heckforge assigned to the quick use slots 1&2 respectively even though I didn't even have those skills. They were useable as well.
  12. Velorien

    Velorien Member

    I went down the stairs to autosave before finding out if the portal bugs had been fixed (after the update that still had the 1.08 splash screen). I loaded the savegame, but the teleporting only started when I walked back up the stairs (if I stayed on the same floor, I was fine), and it was to a random bit of corridor nearby. No evil chests involved in any way (I never even found any such room, and I'd explored most of the level).
  13. fiddler

    fiddler Member

    There were no evil chests with mine either. It was just the random room I happened to start in when I reloaded the game. Teleport after one step, finger snap and teleport, back to where I started from. Glad to know I'm not the only one, though, I wish I belonged to a better group. Crappy thing to have in common with people.

    I did some looking elsewhere on the Gaslamp forums and saw that there was a similar post under the Bugs section of the Diggle Gods forum. Everyone has the same problem, but it seems to be completely random as to what causes it.
  14. Aquaman

    Aquaman Member

    Also am having the teleporting issue. On top of that I also just purchased the DLC.Two things ive noticed is that:
    1. My skills were changed, when i loaded my person on floor two, I had the heckforgeor heckfire skill added to my hotbar...but i did not choose that skill/profession upon creation.
    Second I am not teleporting to a evil chest like people in previous posts seem to be doing.

    I am/was playing on going rouge with perma-death enabled. Female character. And issue occurred after save&quit.

    It has been a disappointment because this has been my favorite character thus far.
  15. Lorrelian

    Lorrelian Member

    I have experienced this bug too. Same general symptoms: Loaded a save and wound up teleporting whenever I tried to take a step. Wasn't near any noteworthy landmarks, except a pool of lava was nearby. Tried reloading my last quick save slot and had the same problem. Like some others, I had the Heckforge ability on my spellbar, although I did not have Demonology as a skill, but only when I loaded the quick save.

    Also, whenever I tried to save and quite, the game crashed. Out of curiosity, I tried the Just Quit option. The game did not crash, which is good. But I have no save file anymore, which is bad.

    Oh well, such are the sacrifices we make for science.
  16. Jeremy

    Jeremy Member

    I just died because of this bug. I was on Vista 32-bit.
    I loaded my save on the 5th floor and everything was working normally. I stepped on a red teleporter and ended up in a room with a lot of monsters. When I tried to move, it showed the trans-dimensional fingersnap and teleported me to a stairway outside of that room. The fingersnap animation played again, and I teleported back to the initial square. After every action, move or cast, the same thing happened. Sadly, my near-immortal Demonologist could do nothing since this teleport was also removing demonic circle every turn. R.I.P..

    The square that I was standing on (due to the red teleporter) had at least one monster on it and may have had an evil chest or something else that was hidden from view.
  17. Daynab

    Daynab Community Moderator Staff Member

    We're resolving this *sigh*
    Sorry for the inconvenience, it somehow slipped through all the savegames we tested.

    We have a hotfix which works so far, so don't delete your old saves if you don't mind waiting.
  18. Itsatrap

    Itsatrap Member

    Bleah, already reverted to an older save.

    Interestingly, this happened to me when I physically opened a door into the next room.
  19. ololo666

    ololo666 Member

    Guess which issue I'm having? That's right,this one!
    Also happened when I opened a door and I also had wrong skill available shortly before that (the cannon skill,though i had no piracy (whatever)).
  20. Eucori

    Eucori Member

    I'm having this issue also. I'm on Mac, OS X 10.6.8. Is there a way to fix the save file?

    Edit: Now, the game crashes every time I load the game. Sigh...had a level 24 character, floor 10 on GR difficulty. Can't believe +10 hours went to waste.