Stuck in tiny mysterious dimension

Discussion in 'Conquest of the Wizardlands' started by Morgan Terra, Mar 26, 2016.

  1. Morgan Terra

    Morgan Terra Member

    Hey guys,

    I entered a mysterious portal a while back, and got myself stuck in this thing. Has anyone ever seen this before? If so, how did you get out? I don't have an appropriate autosave anymore, unless i can go several saves back. I've tried to see if any of the walls were destroyablea lready, and walked over each tile several times. The lamp in the top right corner occupies the floor tile underneath it, meaning i can't walk there, but i can't seem to interact with it. I've never seen anything like this before.

    Attached Files:

  2. Wolg

    Wolg Member

    Which skills do you have available?
  3. Morgan Terra

    Morgan Terra Member

    If you mean usable skills, i have some of the clockwork knight and master at arms skills available, as well as the first one from paranormal investigator. I've already tried using the rocket fist wherever i could, but i didn't accomplish anything.

    I should mention that when i entered the room there were three weapons lying on the floor, including something called a microfilament sword (i think). Would that be of any use?

    Looking at the minimap offers no clues regarding any kind of room that might exist beyond the one i'm stuck in. I do have some explosive projectiles though.
  4. Wolg

    Wolg Member

    Without a teleport skill, such as the one in Tourist (or the mod skill Gangnam Style) your options are pretty limited. If none of the walls nearby are destructible and walking around you don't hear any clicks from avoided traps, you may have just reached a dead end.

    My understanding is that, unfortunately, the game doesn't necessarily guarantee that any given dimension can always be escaped. If you don't want to lose the save, perhaps look into starting the game in debug mode, you might be able to force a level change and recover.
  5. Morgan Terra

    Morgan Terra Member

    It's so weird though. I've played the game for a while now, and while sometimes unfair, it always gave you the option of getting yourself out of the mess you got yourself into. Why not now? Why put items in there if you can't leave the room afterwards? The tourist skill seems like an awfully specific solution.

    EDIT: actually, what i haven't tried is using my spatial instability potions. Maybe there's a room next to it.

    EDIT2: Hah! that actually did the trick. There's a room directly beneath it, like this:

    Attached Files:

  6. Wolg

    Wolg Member

    I always forget about instability potions, they're a tad unreliable for my tastes. ;)

    I don't think the game takes your capabilities into account during floor generation, but just puts rooms together randomly based on how they are defined as being joinable. You might have just got a starting room for that level that was declared with a non-contiguous section but a door elsewhere to join with.

    Are you using any mods on this run?
  7. Morgan Terra

    Morgan Terra Member

    I always have a bit of a dwarf fortress attitude with this game. If it has potential for hilarious horrible mishaps, i'll go for it. Hence the potions. Damn things once teleported me out of a random fight with low health straight into a monster zoo. I survived.

    It seems to be a rare 'bug' at any rate. I've only seen one other person on the entire internet mention it, so they either solved the problem like i did, or it's very rare.

    Nope, no mods. Just the stock game with all the DLC. I should also mention this was a portal from just a random level, not from the ones you need the access codes for.
  8. Bohandas

    Bohandas Member

    That's odd, because I don't recall a non-contiguous room like that in the base game.

    It must have indeed actually glitched and failed to spawn a door somewhere, or elae broken a script