Windows Vista/7 64-bit Steam Workshop mods re-download every time the launcher is run

Discussion in 'Bugs' started by DragonDai, Jun 8, 2012.

  1. DragonDai

    DragonDai Member

    Title says it all really. It is in no way a crucial or game breaking bug, just any mod you download via the Workshop has to be re-downloaded each time the launcher starts.

    To be honest, I am not really sure they are re-downloading. But if you load the launcher and immediately press play, you'll load without your Workshop mods (but with mods you installed manually). If you flip to the mod loader section of the launcher immediatly, you'll see it's only populated with manually installed mods, and the Workshop mods take a few moments (occasionally a decent amount longer, although I have never had it take more than a minute or so) to populate the screen.

    And if you loaded the game before this process is complete (and had to exit because a mod was required for the save you wanted to play or what not), the mods will be unchecked (aka set to not load), where as manually installed mods are always checked (aka set to load). However, if you go to the mod screen and wait for all the mods to load in, then the next time you start the game, for whatever reason, all the Workshop mods are still checked (aka set to load), so long as you give them time to load into the launcher again.

    I also (and why I say that the mods are re-downloaded) if you restart Steam in Offline Mode, or if you disconnect your computer from the internet connection, all your Workshop mods will be unavailable (The mod loader section of the launcher just displays the message "Steam Workshop: Getting Subscription List" for a while, then...nothing). Again, manually installed mods appear, are checked ( aka set to load), and work just fine even in these situations.

    Really, it's more just a very strange thing than anything else. I use the Workshop for Skyrim mods as well, and this situation does not happen there. You can play using your Workshop mods in Offline Mode or while not connected to the internet, and the mods don't need time to load before you start the game from the launcher.

    Anyway, hope that info is useful. Nothing to get too worked up over, obviously, but I thought it was something that should be here, since no one else has reported it yet (that I could find), and it does make saves using Steam Workshop mods unplayable while not connected to the internet. :)
  2. N490

    N490 Member

    I'll chime in, just to add that this also happens on the Mac version, OS X 10.7.4.
  3. FaxCelestis

    FaxCelestis Will Mod for Digglebucks

    Wondering if this is part of the mod fragility problem.
  4. DragonDai

    DragonDai Member

    It definitely seems like it could be. It's odd to start the game and have it tell you that such-and-such mod is needed but not installed when you were just playing with the mod installed a few moments ago (crash or what not). So you exit, restart the launcher, go in, and it takes like 30 seconds for your Steam Workshop mods to populate the mod window, and when they do, they are unchecked. Just strange behavior.
  5. Callum

    Callum Member

    Is there any way to fix the save-game problem with the mods? All my saves complain of missing mods and I'm not sure how to fix it (save perhaps downloading all the mods manually - havent tried that yet though)
  6. Daynab

    Daynab Community Moderator Staff Member

    Maybe the mods are disabling themselves? Have you checked the mod launcher?
  7. DragonDai

    DragonDai Member

    The only way to make SURE your saves don't get broken, at the moment, is to not use the Workshop. However, like my post would indicate and like Daynab suggested, double check the mod launcher every single time you start the launcher before you start the game. The mods often take a while before they show up, and if you launch the game before the mods show up in the loader, they won't be activated for that play session (cause save issues) and they will be uncheck for future play sessions. So yeah, just double check to make sure that isn't the issue (cause if it is, it's as easy to fix and just taking an extra 30 second in the mod loader part of the launcher before starting the game).
  8. Haldurson

    Haldurson Member

    I have a suggestion based on my experience with the Skyrim workshop, because there were issues there as well (they were mostly fixed for Skyrm, but not immediately).
    1. There should be a date associated with the mod, and a new version should only download if the date is different from that which is installed.
    2. The game really ought to save the mod state for each save game (eg. if the save uses mod A, B, and D, then that the game should force those mods to be enabled on load).
    3. When I go into the mod screen and check/uncheck mods, those settings need to be saved. Currently, it acts really bizarrely. I have two different versions of a couple of mods installed, and I constantly have to uncheck the old version. I'm not sure exactly how to uninstall the correct (ie. incorrect) version, but shouldn't the workshop replace those old versions? Alternatively, how about having a way of uninstalling straight from the mod screen itself so that those mods no longer show up. I get really odd behaviors like duplicate skills, duped items in my inventory at the start of the game sometimes, etc.
  9. Daynab

    Daynab Community Moderator Staff Member

    Re: 3, do you have two versions of the workshop mod or one workshop and one downloaded? Because I heard that was what causes issue for remembering, as well as issues for skill duplication.
  10. Callum

    Callum Member

    Hey guys - think I might have a (temporary) fix - just need some folks to confirm it :p

    I've copied the downloaded .dat files from the "subscribed" folder across to the "mods" folder - and I run them from there using the bog-standard mod loader.

    so far, my save hasn't died - can anybody else have a go and see if this works?
    OmniNegro and FaxCelestis like this.
  11. @Callum I did the same and it worked nicely. :)