Windows Vista/7 64-bit Steam version of game, Steam Workshop mods no longer visible in the mod launcher

Discussion in 'Bugs' started by Narcio, May 23, 2014.

  1. Narcio

    Narcio Member

    I have been playing the game with mods for a while and sometime in the last several days mods will no longer show up in the launcher for me to checkmark to enable.

    I have the steam version of the game and I'm using the steam workshop to install mods by clicking "subscribe" on them. In the past when I subbed to a mod, it would automatically show up in my launcher and allow me to put a checkmark beside it to enable it. At some recent point in just the past few days all of those mods no longer show up in the launcher. I have tried unsubbing and resubbing. I have tried checking integrity of the game cache. I have tried fully uninstalling the game and reinstalling it. I have tried fully uninstalling the game and deleting the Gaslamp Games directory in my user folder and then reinstalling it, all to no avail.

    I have noticed that previously mods installed from the workshop would put a .dat file under my user \Gaslamp Games\Dungeons of Dredmor\steam_workshop\subscribed directory, but they no longer show up there. The one small workaround I've found (suggested by someone from the steamworkshop discussion area who is having the same problem as me) is that if the game's launcher is currently running and I unsub and resub to a mod, it will show up in the launcher and the .dat file for the mod will also again show up in my subscribed folder, like it used to. However, each time I restart the game, I have to do the whole thing over again, ie unsub and resub each mod while the launcher is currently running. This is obviously painfully tedious.

    Are there any troubleshooting steps I can try to solve this, or is this just a bug that the devs need to fix?

  2. Haldurson

    Haldurson Member

    I'm wondering if this is another symptom of the Steam cloud issues. Do a search on these forums on Steam Cloud, and you should find step by step instructions on how to disable the Steam Cloud (assuming you haven't already done that).
  3. Narcio

    Narcio Member

    Well, I have the cloud disabled for this game, and most games in Steam. I do not have it generically disabled because I actually have a bug in some other stupid game such that when I universally disable the Steam Cloud (which I'd like to do) the game always crashes when trying to load. So yes, I already have the steam cloud disabled in DoD, but I don't have it universally disabled (ie the option in your steam account settings.)