Windows XP Spell Hotbar Broken

Discussion in 'Bugs' started by FurryMIG, Aug 25, 2012.

  1. FurryMIG

    FurryMIG Member

    EDIT: "Bug" Resolved; Found to be user error

    So after taking a break from this game for about a month, I come back to it; all my save files are corrupted, and spells no longer appear in the lower-right hotbar. After deleting all save data and uninstalling and reinstalling, the corruption is gone, but skills still no longer appear in the hotbar. the belt hotbar still works fine, but the spell hotbar does not work at all, It appears blank, and I cannot place spells in it using the little "+" Icon.

    Supposing it's related to the corrupted save files, and the only two workshop mods I am subscribed to is Meltdown and Dungeons of Equestria, which worked fine before I took a month-long break.

    Yes, I use the STEAM version of DoD, And the Corrupt save files are deleted, all that remains is to get the spell hotbar working again.
  2. Daynab

    Daynab Community Moderator Staff Member

    This is happening on new saves too?
  3. FurryMIG

    FurryMIG Member

    Yes, it is. Starting a new game, my spell hotbar is blank, even after saveing, exiting, and returning to the game. Re-installing the game has no effect.
  4. OmniaNigrum

    OmniaNigrum Member

    Fullscreen? If so, please try a window mode with a lower resolution just to see if the problem persists.
    Exile likes this.
  5. FurryMIG

    FurryMIG Member

    Windowed. Changing resolution had no effect, Full-screen and Windowed, neither had any effect. Spell hotbar is still blank.
  6. Nicholas

    Nicholas Technology Director Staff Member

    Steam must have eaten something. Have you tried uninstalling and reinstalling?
    Exile likes this.
  7. FurryMIG

    FurryMIG Member

    Indeed, uninstalled DoD and deleted the Gaslamp data folder in "my documents". Although the only way to uninstall from STEAM is "Delete local content". But I'll try it again. I even unsubscribed from the mods from the STEAM workshop.

    No good. Still no spells in the spell hotbar.
  8. FurryMIG

    FurryMIG Member

    Guess no more DoD for me for now...
  9. FurryMIG

    FurryMIG Member

    After some experimenting, I find that when I start a new game, with skills that let you START with some spells, Said spells show up in the spell hotbar. but when I gain a level and place a skillpoint in a new spell, the new spell does NOT show up in the spell hotbar.
  10. OmniaNigrum

    OmniaNigrum Member

    Unsubscribe from ALL mods. Then delete your Gaslamp Games directory in the Documents directory of your user. Then uninstall, reinstall, and try the base game without mods. It will generate everything it needs to run again. (Meaning it will make the stuff you just deleted, except hopefully it will now work.)

    For the future, do not bother with Steam to get/use mods. Use these forums and do it the manual way. That will not betray you. Steam absolutely will.
    Exile likes this.
  11. FurryMIG

    FurryMIG Member

    No effect. I even deleted the Dungeons of Dreadmor folder out of my STEAM directory.
  12. OmniaNigrum

    OmniaNigrum Member

    I am drawing a blank on the cause. I wish I had an idea. :(
    Exile likes this.
  13. FurryMIG

    FurryMIG Member

    This is the kind of luck I have. I'm fairly certain the whole trouble started with the latest patch... I doubt it, but is there any way to revert to an older patch?
  14. OmniaNigrum

    OmniaNigrum Member

    No. Sadly there is not. Steam does not have a means to do this.
    Exile likes this.
  15. FurryMIG

    FurryMIG Member

    Then it looks like I have to suffer the DoD Nuzlocke challenge: Beat the game without using learnable spells!

    Maybe the next patch/addon pack will fix it.
    Vitellozzo likes this.
  16. Vitellozzo

    Vitellozzo Member

    Maybe some strange symbol in your username?
    OmniaNigrum likes this.
  17. OmniaNigrum

    OmniaNigrum Member

    Good point. DoD has issues with any non-English charactersets. So long as your Username in Windows contains no special characters like ... I do not honestly know what those symbols languages like French use. But people from around the world have trouble still. Mostly because Gaslamp is primarily using only English as a resource. (So they never see the results first-hand.)

    Sadly there is no current fix besides making another user account only using common English letters and numbers. That should allow you to use the game. But they have been working to resolve this for a while. If this is your problem too, please, I beg of you, provide details on what language and what your path to your username looks like. For example, if my username were Omni, I would have this:
    "C:\Users\Omni\Documents\Gaslamp Games\Dungeons of Dredmor\" as my path to where it stores my user data for the game. If I included a French whatevertheheckthatsymbolis it would not be able to make the files past "C:\Users\Omni\Documents\" as it would not know how to parse the path.
    Exile and Vitellozzo like this.
  18. Nikolai

    Nikolai Member

    Have you tried disabling Steam Cloud? Two ways to do this. First, go to Steam Settings, Downloads + Cloud Tab, and at the bottom uncheck "Enable Steam Cloud synchronization." Then, go to your My Documents folder and open up config.xml. Edit the line "<setting name="enableSteamCloud" value="0"/>" like so, making sure value="0". Do both, just to be safe. You can try changing the Workshop line, too.

    After you've done that, try a full reinstall and delete the My Documents folder.

    If that hasn't fixed it, ensure your video card's drivers are fully updated. Or, if the problem started after an update, try rolling back.

    Finally, just to be sure... have you actually tried manually adding a spell to your hotbar after learning it? Maybe it's just not placing it in the hotbar, but if you could do it manually...

    I hope this helps!
  19. FurryMIG

    FurryMIG Member

    There's a way to manually add spells to the hotbar? the only way I found was to click the little [+] Icon in the hotbar, then selecting it from the list that appears.

    And my Username contains only English letters, no foreign letters.

    Gonna try disabling STEAM cloud right now.
    also, where is "Config.xml" in My Documents?
  20. FurryMIG

    FurryMIG Member

    That's weird, my high scores and saved games still show up, despite the fact I deleted the Gaslamp games folder in My Documents....

    Are they related to Steam Cloud? Which I DISABLED!?