Pocket Dimension bugs and Paranormal Investigator bug

Discussion in 'Bugs' started by Bohandas, Aug 1, 2012.

  1. Bohandas

    Bohandas Member

    I've experienced two major errors (or three, depending on how you parse them) so far in Conquest of the Wizardlands:

    1.) Pressing the button to enter the pocket dimension sometimes crashes the game

    1b.) Returning from the pocket dimension can cause problems as well. At one point it returned me to the level inside of a solid wall. Reentering the pocket dimension and going back to the level again did not help and as I had no digging or teleporting abilities I was stuck (I was able to get unstuck by loading the game in debug mode, going down one level, and then taking the stairs back up to the original level (the debug command to go up a level didn't work from where I was stuck, and going up through debug from the same impassible wall)). It should be clarified that I was not in one of the hidden empty spaces; I was actually in the wall; The character was not visible on the screen and I was only able to determine her position by casting a spell and noting the location of the spell animation.

    2.) The third level ability of the Paranormal Investigator skill tree crashes the game about half of the time when it is used
  2. Daynab

    Daynab Community Moderator Staff Member

    If you've got any saves where these weird things happen, please upload them.

    -We'll check out the PI skill.
  3. Bohandas

    Bohandas Member

    The autosave in this zipped file contains a game which, when I load it, exhibits the return from pocket dimension bug (bug "1b") that I described earlier. In addition, both saves seem to have somehow been rolled back to earlier points in my game than I was at when I stopped playing last night; I know that my progress after these points had previously been saved because the game crashed several times after that and I was able to reload to a later point.

    Attached Files:

  4. wiki

    wiki Member

    Hey, I've got a file where trying to access the pocket dimension is awlays crashing the game. Hope this helps? Also, the game crashed when I tried to enter my first wizardland (and flagged it as already done, after I reloaded) so maybe those two are connected?

    Attached Files:

  5. DM789

    DM789 Member

    i've also experienced this issue, but there's more with mine

    1. entering pocket dimension = inventory became empty
    2. exiting pocket dimension after that = stuck in the wall
    3. if the game autosaves inside pocket dimension, then the game will crash, and loading the auto saves also didn't help at all.

    ps : what is this debug mode ? how to use it ? (tried right clicking on dungeons of dredmor on my steam library didn't show debug mode)

    Attached Files:

  6. Bohandas

    Bohandas Member

    You have to create a shortcut to Dungeons of Dredmor and add a bunch of command-line flags at the end of the Target Program dialog box. Its simpler than I just made it sound; here's an article that explains it better:

  7. DM789

    DM789 Member

    thx for the info on debug mode, and i've tried the hotfix, so far no crash or other issue when entering or exiting pocket dimension
  8. Bohandas

    Bohandas Member

    I just noticed another thing about this bug. It seems to make you respawn in the center of the map. Furthermore, if the center of the map is actually a space where you can move, then saving after that point seems to cause the game to crash. See the affixed save

    Attached Files:

Share This Page