Mods does not appear in launcher

Discussion in 'Modding' started by BenjiB128, Feb 15, 2012.

  1. BenjiB128

    BenjiB128 Member


    Sorry if this kind of threads already have been posted, but I read them and it didn't work.

    I'm on Windows 7, I purchased DoD and the expansion with steam, and I have the latest update. I downloaded a few mods, and tried to put them into C:\Users\Blahblahblah\Documents\Gaslamp Games\Dungeons of Dredmor\mods, and in C:\Program Files (x86)\Steam\SteamApps\common\dungeons of dredmor\mods. I tried putting directly the .zip file without unzipping, with unzipping in a folder that led directly to mod and other folders in the .zip, and putting directly the multiples folder in \mods\, but none of them worked, with every mod I tried to install. Have I done something wrong or is it a bug?
    The Mod Launcher is empty, nothing appears in it :/

    Thanks a lot!
  2. Essence

    Essence Will Mod for Digglebucks

    Wow, it sounds like you have some serious problem somewhere.

    First off, what version of DoD do you have? 1.09 REV B? Or something earlier?

    When you look at your Blahblahblah\Documents\Dungeons of Dredmor folder, is it full of savegame files? (If not, you're probably looking under the wrong Blahblahblah)

    If it is, when you create the \mods folder within Dungeons of Dredmor and paste the attached file (exactly as is) into the mods folder, does it still not show up in your mod loader?

    If not, then yes, there's a serious problem somewhere.

    Attached Files:

  3. BenjiB128

    BenjiB128 Member

    mmmmmh yeah I heve a lot of save data in the DoD folder, and the attachment didn't worked :/
    my version of the game is 1.0.9 REV B, guess it's the earliest because steam does automatic updates.
  4. BenjiB128

    BenjiB128 Member

    made a screenshot, if it can give you any clue
  5. Essence

    Essence Will Mod for Digglebucks

    Nope, I'm stumped. :( Anyone smarter than me have an idea?
  6. badboy80

    badboy80 Member

    I would possibly ty re-iinstalling the game, and see if that works. if not, it might be due to the mods themselves not having the right placement of folders or clashing
  7. Daynab

    Daynab Community Moderator Staff Member

    Yeah that should definitely be working, per your screenshots. I'd try a reinstall as well.
  8. Loswaith

    Loswaith Member

    Try putting it in your "C:\Users\<username>\My Documents\Gaslamp Games\Dungeons of Dredmor\" folder directly if you didnt

    I have found while occasionaly that Windows 7 may list stuff in the library its linking more like a shortcut than the folder structure itself (due to the indexing of libraries), so if you happen to paste into the library it isnt actually being used in the directory the program itself is looking at. Even though it should be.

    Doesnt happen most of the time though.
  9. BenjiB128

    BenjiB128 Member

    Nope, I tried both reinstalling and putting the mods directly in DoD folder, none worked D':
  10. Daynab

    Daynab Community Moderator Staff Member

    Oh waaaaait. Is your windows user name with non-english characters? I remember there was a similar bug with someone from Russia.
    Blind Piper and Loswaith like this.
  11. BenjiB128

    BenjiB128 Member

    hum yeah, it got a "ü"... Don't tell me it's because of that? xD
  12. BenjiB128

    BenjiB128 Member

    I tried changing the username, but the folder still has a "ü", and I can't rename it because it's protected
  13. Daynab

    Daynab Community Moderator Staff Member

    ...Yeah. I'm going to see if Nicholas can't fix this for the next patch.
  14. GoingJuffoWup

    GoingJuffoWup Member

    Hey there BenjiB128!

    Well, you do seem to be in a pickle, but sometimes the greatest solutions are the most ridiculous.

    As a person who constantly fiddles with files to Mods, Sprays for Various source games etc etc.
    Can I perhaps ask you to rename that "mods" folder that you have there to "Mods" with a capital "M"?

    A lot of people in the Team Fortress 2 universe have problems when trying to import their sprays to their game files and it seems that no matter how much they try, it simply will not work. When they upload their screenshots it shows that their folder names are never spelt right, for example, for Team Fortress 2, they don't have the folder spelt as "VGUI" and instead have it spelt like "Vgui" or "vgui".
    Of course, this may not always be the case as the file is often changed to be compatible with Source games.

    Of course, this sounds absolutely ridiculous, but it's little things like this that can be perhaps be the problem to all of this.

    If all else fails: Right click on Dungeons of Dredmor and select Properties and make sure your running the game as Administrator.
  15. BenjiB128

    BenjiB128 Member

    I created another user, and it worked! thanks a lot everyone for helping me :)
    Essence likes this.
  16. Essence

    Essence Will Mod for Digglebucks

    Good memory, Daynab. Well done. :)
    Loswaith likes this.
  17. wRAR

    wRAR Member

    Is it still impossible to get mods working if you have a non-English path to the save folder?
  18. yamiluigi

    yamiluigi Member

    That's kinda strange because the problem doesn't appear about saving the game but just for the mods.
  19. wRAR

    wRAR Member

    Also, if this bug still exists (and my experience suggests that it does) this topic apparently belongs to the Bugs forum.
  20. Frelus

    Frelus Member

    I guess I know what it is:
    Look into the .zip file
    If there are files like mod, skills and sprites, ok, it should work with the .zip
    If there is another folder with the modname, extract this folder into the /mod in the dredmor folder.
    Found it out the hard way when half of my non-workshop mods weren't working.
    Hope it helps,
    Edit: To clarify:
    If the path is /mods/ (and so on), ok.
    If it is /mods/ (and so on), extract "modname" into the main /dungeons of dredmor/mod folder.
    OmniNegro likes this.