If you are having Save Game Problems w/1.1.1

Discussion in 'Dungeons of Dredmor General' started by Nicholas, Aug 1, 2012.

Thread Status:
Not open for further replies.
  1. Nicholas

    Nicholas Technology Director Staff Member

    Okay, so somebody renamed a dagger last night without telling me and it broke everything.

    If you're having Save Game Problems, grab this:


    Extract it over your Steam install:

    c:\program files (x86)\steam\steamapps\common\Dungeons of Dredmor

    It should overwrite the EXE in question, and hopefully it will fix your save games. If you still have save games that do not work after this, and that do *not* have mods, post them here.

    We'll have a full version of this propagated to Steam later this evening after we knock out any more day-0 problems. I guess our streak of 100% save game compatibility from the last patch was not destined to be a very long streak; I'm very sorry about this.
    banjo2E, Danridar and bobend like this.
  2. Reibello

    Reibello Member

    Thank you Nicholas. That seemed to fix my save game issue.
  3. wRAR

    wRAR Member

    Still doesn't load, I gave you a link in the private converssation some minutes ago.
  4. Nicholas

    Nicholas Technology Director Staff Member

    Okay, taking a nother look.
  5. kafiend

    kafiend Member

    No workee here on the save game fix. No expansion either. I like to give you guys my money on day one so steamupandtakemymoney.gif??
  6. Worked! Thank you very much for fixing this so quickly! I feel kinda bad for being one of the people to bring it up, when you must all be so busy.
  7. Danridar

    Danridar Member

    Awesome! It worked for me on my furthest along character!
  8. Kablooie

    Kablooie Member

    The link you posted, the .exe, worked for me. The game would just CTD otherwise.

    I was initially a bit worried as it's size was a good deal smaller (899kb versus the broke version's 2052kb), so I saved a copy of of the latter, but looks like it boots fine.
  9. Shaz

    Shaz Member

    All my saves got wiped.

    I have backup saves, but with the new save system, I see no way to use them.

    It was my own stupidity; I was so excited about the new expansion that I loaded the game with Steam... and Steam does as Steam always does and wiped my saves folder clean.

    I'm too disheartened to play now... and I was so very excited moments ago. That'll teach me let my excitement get the better of me with regards to Steam. But is there any chance to prevent this if I do let my excitement get the better of me in the future? Some way to prevent Steam from erasing everything, again?
  10. Nicholas

    Nicholas Technology Director Staff Member

    Huh. I wonder why that EXE is so large. Possibly Steam's doing some kind of Injection Thing that's new for them. I'll ask my contact.

    Shaz: Run -nukesteamcloud; that tends to ensure things are synchronized. (Steam is... yeah, Steam.) Still! Think of it as a good time to start a new character; 1.1.1 features won't show up in old save games, so you get the consolation prize of a Lot of Good Stuff.
    renatoakamur likes this.
  11. Shaz

    Shaz Member

    Will do that, thanks.

    And, I know. It's just... I've never beaten Dredmor. I've never gotten really close. And I was on floor 14 kicking Diggle like I'd never kicked Diggle before...so it's still disheartening. I don't mind dying (I've done it PLENTY, and I only play Permadeath), but when I lose my characters this way? I just want to rage and cry and sit in a corner staring at a wall for a while.
  12. Nicholas

    Nicholas Technology Director Staff Member

    Diggle Buddha says: attachment is the root of all suffering.

    Diggle Buddha also hates you so much.
    Robsbot, shaken, mining and 1 other person like this.
  13. renatoakamur

    renatoakamur Member

    nice idea, i will go back to my saved games later, i was almost beaten Dredmor too but i mainly interested in check the new changes
  14. Kablooie

    Kablooie Member

    Doublechecked the old exe's size, verified it's 2052KB.
    . . .and now, the one I copied in (from the link above) is also 2052KB.
  15. Catbread

    Catbread Member

    Whenever I start a new 1.1.1 game and save and quit, the saves do not appear in the load game menu, even after unzipping the hotfix into the DoD folder as instructed.

    Edit: Oh. Disabling the one mod I had on seemed to do the trick.
    Now I just have to figure out how to not have my mod do that.
  16. gerunding

    gerunding Member

    All my old saves don't work: I just pop back to main menu. Had Compleat mod, unsubscribed, then used .exe above, but the saves still don't work. New games load fine, though.

    In the Dredmor save folder, the old games are all .sav files, whereas the new (functioning) saves are file folders with .bmp and .dat files inside. Is something amiss, there?
  17. Daynab

    Daynab Community Moderator Staff Member

    The whole save stuff has changed which is why they're different. Amongst other things, saves now include their mods inside the saves.
  18. Aegho

    Aegho Member

    One thing that is very noticable now that saving saves entire mods... it's a lot slower, and autosave is getting very annoying.
  19. Nicholas

    Nicholas Technology Director Staff Member

    We should only be saving mods once in an autosave, and then that's only if they have changed since the last autosave.

    I'll ask Ryan to investigate.
  20. Demiin

    Demiin Member

    How about a patch for Linux?
Thread Status:
Not open for further replies.