For those of you where saving doesn't create a save file!

Discussion in 'Bugs' started by Daynab, Aug 3, 2012.

  1. Daynab

    Daynab Community Moderator Staff Member

    We appear to have found a solution (according to a couple people who have tried it so far) and we'd like you to try it out.

    1: Right click the game in your Steam library, properties, then click Verify Game Integrity.

    2: Delete the entire Documents/Gaslamp Games/ folder. If you have mods you would like to keep, move the folders elsewhere for now, we just need the folder to disappear completely.

    3: Save a new character and see if it works.

    4: If it doesn't, try applying this hotfix:

    If it works, you should be fine with moving the mods back in also.

    Please let us know the results (in this thread if possible).
  2. Vengefully

    Vengefully Member

    Yeah, the hotfix work for me. Dunno if it's necessary but I was running Windows Vista 32 bits and a Portuguese keyboard layout.

    And yes I registered just for this reply. It's how I roll (but secretly wish I didn't. :D )
    Daynab likes this.
  3. Daynab

    Daynab Community Moderator Staff Member

    Glad to hear it.
  4. Nicholas

    Nicholas Technology Director Staff Member

    Excellent. That's two successful cures!
  5. Elric

    Elric Member

    Tried the hotfix, now save games are working - I can save and load new games without problems. But old save still donĀ“t appear (I mean any save before the hotfix),

    Note: windows - portuguese (brazil).
  6. No one

    No one Member

    Yeah, the hotfix works for me too. (Spanish keyboard in my case)
  7. Sitheral

    Sitheral Member

    The hotfix works for me as well, thanks!
  8. Tahau

    Tahau Member

    Deleting the folder didn't help, but hotfix solved the problem. Moreover, it somehow fixed the "last choice" function in character creation menu - the game was never able to remember my last character build before (I'm playing since 1.0.8). But for some mysterious reason after applying bugfix every new character spawns in a room with mysterious portal on the floor (though the rest part of map seems to be generated randomly). Screenshot included.
    Windows XP SP3 x86, Russian locale.

    Attached Files:

  9. ghost#13

    ghost#13 Member

    It worked for me, thanks. (Russian Locale, Windows XP SP3 x86)
    Also the following was noticed:
    • Every character starts in a room with mysterious portal;
    • The last choice option is finally fixed for me (playing since 1.0.6. and it always was broken in Windows version);
    • The highscores are finally showing once I click the button in main menu (the same as with last choice);
    Everything's the same as Tahau mentioned. Now I'm looking into what also has changed.
    Edited: Achievements seem to be broken after this fix is applied.
  10. ZorMonkey

    ZorMonkey Member

    I might have a different situation. I played for a while last night and saved a few times, but this morning I only see my old saves. I didn't verify that the new saves actually worked last night though. This was while running the fix here: I started using an "old" save file.

    So then I found this thread, and went to testing... I did NOT apply the hotfix, and I'm still running the savegame fix version Started the game, created a new character, saved, and save file exists. Hm. Loaded "old" game, saved, and "new" save file exists. Double hm. Both new files work fine.

    So not sure if I got hit with this bug, that was maybe worked around by created a new style save first, or maybe I hit a cloud glitch? Dunno. But there you have it. :) Let me know if you need anything else.
  11. P74Y3R707

    P74Y3R707 Member

    It does not work. Windows SP3 Russian
  12. P74Y3R707

    P74Y3R707 Member

    Hotfix led to a crash the game. "Couldnt load PNG file (name of file(many squares)). The game will now crash."

    Russian Windows SP3 32
  13. P74Y3R707

    P74Y3R707 Member

    It works! You do not need to extract the game folder file "expansion3" and it works! Am I right?
  14. rydash

    rydash Member

    Oh, yeah, um, if you DON'T possess the RotDG, YHtNtEP, or CotW, don't copy over the expansion, expansion2, or expansion3 folders, respectively. So, if I was playing with only YHtNtEP, I'd only copy the executable, game folder, and the expansion2 folder.

    I hope this thought presented in this way makes sense. :p
    GhostChili likes this.
  15. Daynab

    Daynab Community Moderator Staff Member

    Yeah it really looks like a Steamcloud glitch at this point.
  16. eijin

    eijin Member

    For those of you with a mac, the folder you need to delete is ~/Library/Application Support/Dungeons of Dredmor. In Lion you can't actually see the Library, so while you're in finder press Command + Shift + g to bring up the jump to folder option, and then enter ~/Library/Application Support/ . Once you're there just drag the Dungeons of Dredmor folder to the trash and delete it.

    That's what I did and everything's alright now. I'm running Mac OS 10.7.4.
    rydash likes this.
  17. GhostChili

    GhostChili Member

    Got same results, system is same.
  18. Daynab

    Daynab Community Moderator Staff Member

    Remove the expansion folders for the expansions you do not have. "expansion" is diggle gods, "expansion2" is the free dlc, "expansion3" is wizardlands.
    GhostChili likes this.
  19. GhostChili

    GhostChili Member

    Thanks, it worked! Deleted and reinstalled the game, copied only the exe file from the hotfix, game is now saving!
  20. Shining

    Shining Member

    The fix worked for me. Thanks!
    For the record, I have Windows 7 32-bit and a Portuguese keyboard layout.