Dredmor Patch 1.1.2 Feedback Thread

Discussion in 'Dungeons of Dredmor General' started by Nicholas, Aug 23, 2012.

  1. Daynab

    Daynab Community Moderator Staff Member

    Try deleting your documents/gaslamp games/ folder and let it recreate. Move mods elsewhere temporarily if you have some.
    Puce Moose likes this.
  2. After the game patched up to 1.1.2, I lost an entire savegame that I made using the hotfix. Another one of my saves made using the hotfix was not lost. I double-checked the location of the save files and it was completely deleted and no traces of its existence were left (number of monsters killed, pocket dimension themes for those floors, etc). Kind of disappointed as I was on the 9th floor, but oh well.
  3. JabberSnatch

    JabberSnatch Member

    On a less buggy note, I'm enjoying the new Wizardlands geography. They now look less like another dungeon and more like a place where dead drunk wizards used to live. And the new extremely stubborn trap is pretty cool. If I didn't have an improbable amount of :resist_conflagratory: I might have died.
  4. Puce Moose

    Puce Moose Member

    Hey, thanks! That seems to have taken care of it. I'm able to save/load properly now.
  5. Dynamod

    Dynamod Member

    oh yeah, the new wizardlands are much more wizardly now. very nice!
  6. analogline

    analogline Member

    I'm not sure this counts as a 1.1.2 bug. If not I can post it elsewhere. After seeing that the Steam overlay had been fixed "in -opengl" I noticed that it wasn't showing up for me still. I tried adding "-opengl" to the launch options, and behold, the overlay. However, when I went and died straight away, my list of deaths only had the first two times I played the game (back before YHTNTEP). The list of saved games IS correct, however. Not that this is a super scary, game breaking thing, but it certainly seems quite odd. When I removed -opengl they're still all gone, so it appears they all got erased somehow.
  7. Rizik6

    Rizik6 Member

    I seem to have reverted to a save that was made before using the hotfix.
  8. 0x517A5D

    0x517A5D Member

    These all sound to me like the Steam Cloud sync problem I hit in 1.1.1, when I started the game from the Steam Client instead of my normal way of running it directly. Any chance you guys were in that boat?
  9. Jacq

    Jacq Member

    This may be intended behaviour...
    My Vegan animal friends are really stupid. If there are 4-5 monsters in a room, it's like they will target one and ignor the others (even if those others are blocking it from its target).

    This is probably not intended behaviour...
    My vegan animal friend can occupy the same space as a monster. I'm not sure if they get stuck there or if they're just not moving intentionally.
  10. LionsDen

    LionsDen Member

    I have had this happen to me as well.
  11. Jacq

    Jacq Member

    Could it be vegan buddies are nerfed? I can no longer use them as shields (enemies just walk through them).
    (these are huge pictures, sorry)
    This space occupied.

    I also had a bug where I gave the item to the shrine and no monster appeared.
    I might have seen a "!" somewhere in the blackness but I'm not 100% sure if the monster appeared in the wall or not.
  12. Stryke

    Stryke Member

    Has anyone else noticed monsters regenerating health since the new patch? Had an unfriendly AI that was borderline unkillable on level 3.
  13. ineffablebob

    ineffablebob Member

    The only issue I've noticed since the patch is that the autosave is much slower. There is a noticeable pause every time the autosave kicks in. Before the patch, the only time I got pauses like that were when opening a crowded new area (i.e. zoos).
  14. LionsDen

    LionsDen Member

    I have noticed that the Bankster skill High Interest Load gives exactly 0 zorkmids whenever I use it in a wizardland. I am running on Windows XP with the Steam version and the 1.1.12 patch with all of the DLC, even the free one, and the only mod I am running is my Needful Things mod.

    The skill will pop up a zorkmids pile, the small graphic one, but it will say 0 zorkmids. I have tried it in 2 different wizardlands a couple of times in each.
  15. Kazeto

    Kazeto Member

    That is because it has to spawn something (it's a fail-safe, put there not to crash the game by referencing a null value), but both wizardlands and "mysterious floors" count as floor 0 (and thus give you nothing).

    If it makes you feel better, try to imagine that whenever you use it in a wizardland, it spawns some caps instead of money.
    OmniNegro and Warlock like this.
  16. OmniaNigrum

    OmniaNigrum Member

    Yeah. If the game did give you Zorkmids when using the Bankster skills in Wizardlands, you could find a nice, relatively safe one and do exactly what caused the nerf to lucky pick. (I do not consider that a nerf though. But some do simply because it currently does not work on chests.)

    Or worse still, you could go to your pocket dimension and abuse that for infinite Zorkmids. Lame, but people would certainly do it. So while in Wizardlands or your PD, it multiplies by the floor like anywhere else. And those floors are level zero. :)
  17. SkyMuffin

    SkyMuffin Member

    I've noticed that since 1.1.11, the trap variety (at least on Going Rogue) is more diverse-- I'm seeing DL 2 and very rarely, DL 3 traps on DL 1, and so on. It's a good change of pace and makes things more challenging.
    I haven't been in a Mysterious Portal yet, but in 1.1.11, Bankster would scale on Mysterious Portal floors as if you were on DL 16. :eek: Hope that is changed.
  18. tcjsavannah

    tcjsavannah Member

    Count me among the unhappy at the Lucky Pick change. Not in getting rid of lockpicks, but in the skill not working on chests. Your ability to pick chests now exists SOLELY on RNG granting you enough lockpicks, else you're as impotent as berserkers smashing chests.
  19. Warlock

    Warlock Member

    Abuse wizardlands, where you get no XP for lockpicking anyway. Acquire all the lockpicks = profit! :p I do agree that it has to be fixed though.
  20. OmniaNigrum

    OmniaNigrum Member

    There are mods that allow easy crafting of lockpicks though. Actually, there are a half dozen or more such mods. And it will be fixed next patch. (I suspect. But that is not written in stone. That is just an opinion.)