OS X Snow Leopard Dredmor doesn't play nicely with Steam

Discussion in 'Bugs' started by r_b_bergstrom, Aug 14, 2012.

  1. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    This has been ongoing for me since at least the day YHTNTEP came out, and probably before that, but because I've been involved in various beta programs, I haven't been using Steam that often for most of this time frame, so it's only recently been a big enough pain in the butt to make me complain here.

    It seems likely that the lion's share of this problem is valve's, not gaslamps, but I figured I should mention at least let you guys know it's happening, in case there's anything you can do on your end.

    Here's the symptoms:
    • When I launch DoD via Steam, it takes FOREVER to load past the launcher and get to the title screen. Like, I can get up and make myself a sandwich, and when I come back sometimes it's still not quite ready to play. But if I run DoD without Steam, it loads up in maybe 30 seconds, and usually less. It takes at least 6x as long to load via Steam, and I wouldn't be surprised if it's 10x as long.
    • The bit where it redownloads every mod each time I log in takes so long, I've unsubscribed to all mods. To be fair, part of why I unsubscribed had to do with how mod updates used to kill games in progress, but it was still painfully long waiting for them to download and refresh each time.
    • If I'm using DoD via Steam, after I quit out of DoD, Steam crashes within 30 seconds. Every single time. I'm not playing very many other games via Steam currently so I don't really know if there's other games that cause this same issue or if it's purely a Dredmor problem.
    • Steam frequently tells me the game is unavailable, and I should try again later. This happens a lot. Far more often than you put out updates. It seems to especially love to be unavailable if I set the -publisher flag.
    • My game data via Steam keeps getting corrupted. About every 10 hours of Steam play I have to verify or delete local content, -nukesteamcloud, or something along those lines. Prior to the release of YHTNTEP this had never happened. In this past week I had to reinstall on Friday, Sunday, and today.
    These are all particularly annoying when I'm trying to edit or playtest mods. Because it takes more than 5 minutes to launch the game, i can't really make use of -testroom and it's related flags. Instead to test a room I wait till I have half a dozen rooms ready to go, then put in half a dozen copies of each set to early floors instead of the floors their intended for. While that sometimes means I have to "p" down a few floors to find examples of them all, it's still much much faster than -testroom for me. At least via Steam.

    And if I try to use -testroom etc via Terminal, some of the flags that are supposed to work return errors saying that it can't find a local copy of Steam .dlls. -testroom itself works from Terminal, but the flags for setting difficulty level and permadeath both cause CTDs with steam-related error messages exported to Terminal.

    EDIT: New wrinkle: I was using -testroom via Terminal, and suddenly the mod starts crashing. Not just in that room, but any time I use the mod. So I turn on steam, verify local content, and there's 15 files in need of restoring. It does so, I exit steam, and half an hour later try to launch Dredmor via Terminal again.
    Now Terminal won't launch Dredmor at all, giving back a "-bash: ./dredmor: Permission denied" to my ./dredmor -debug-flag command that worked prior to the restore.
  2. Isc4riot

    Isc4riot Member

    Uhm, I'm not sure whether it could help but DoD, when installed using Steam, can be turned on even without using Steam at all. Only the workshop and Steam cloud too I guess is disabled. Since you're not subscirbed to any mod anyway it shouldn't be a problem.
  3. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    Thank you, but I'm actually aware of that. I realize I made a huge wall of text in my initial post, so it's not surprising you missed the part where I talked about how it's faster when I launch DoD without Steam.

    Problem is using the -debug-flag on a Mac outside of the Steam environment is tricky, and doesn't give access to all the command line options that you have when using Steam. With all the modding I do, I really need access to -debug-flag, -testroom and -publisher. But if and when I use Steam for those features, it loads painfully slowly, crashes steam when I exit, etc. Not the end of the world since I can still play the game normally without Steam, but very frustrating when trying to mod.
  4. eskr

    eskr Member

    Out of curiosity, what OS and kind of comp are you using?
    Until the recent hotfixes I've exclusively used DoD via Steam and haven't had any of the problems listed above. (I think once, recently, it took a long time to start up, but that's once out of many score times.)
  5. Kazeto

    Kazeto Member

    He's using OS X Snow Leopard.
  6. eskr

    eskr Member

    Ah, Win 7 64-bit here, perhaps the cause of differences.
  7. SkyMuffin

    SkyMuffin Member

    I haven't experienced the other problems (Windows 7 here), but in 1.0.9 (before steam was messed up in 1.10) I had this exact same problem. Steam overlay on, Dredmor takes ages to load. Steam overlay off, it's almost instant.