OS X Lion Crash on going down stairs; no save present

Discussion in 'Bugs' started by curious nu, Aug 27, 2012.

  1. curious nu

    curious nu Member

    Tehcnically this is on Mountain Lion, but the prefixes haven't been updated.

    Permadeath character goes down from DL 2 to 3, crash immediately on stepping onto the stairs. Come back to see if there's an autosave, and... no.

    Due to the "no saves kept" issue - which had NO hotfix for OSX players - I was basically prevented from playing the game I purchased n any meaningful way until the 23rd when the patch hit. And now this.

    I am pretty frustrated, guys! I am pretty damned sick of this at this point! It also makes all the "hey we're got a countdown going" nonsense pretty irksome, when I've got one game that can't seem to get out in a working state and you're trying to hype up this other thing.
  2. Daynab

    Daynab Community Moderator Staff Member

    Is this with a brand new character? can you check the game folder to see if there's a .dmp file with the corresponding save crash?
  3. curious nu

    curious nu Member

    Yes, brand new character.

    I don't see any .dmp in Library/Application Support/Dungeons of Dredmor. Is there somewhere else it'd be?
  4. Daynab

    Daynab Community Moderator Staff Member

    I'm not sure if dmp files are a windows-only thing, actually.

    Uh, so autosave didn't appear, but you still have your previous save, don't you?
  5. curious nu

    curious nu Member

    No, because permadeath character.
  6. Nicholas

    Nicholas Technology Director Staff Member

    There's something funky going on on OS X Lion. I'm on it.
  7. curious nu

    curious nu Member

    I want to re-emphasize that this is in Mountain Lion, in case that makes a difference.
  8. nxcho

    nxcho Member

    I also got this problem. But in my case, the automatic save seemed to work, tried the same stairs again and it crashed again. The OSX stack trace that popped up said it failed in a function called Graffiti::Graffiti(). I have the whole crash log if it would be of any help.
    edit: It worked when I walked down another staircase.
  9. I've got the same thing going on. Fine for the first five (?) dungeon levels, now I can't go down the stairs. The OSX crash log does address teh graffiti bit again.

    No stairs work going down, going up, fine. Going down? No.
  10. cactus friend

    cactus friend Member

    This happens for me, too. Twice, in rapid succession, and once just now. I only play permadeath characters.

    Here's a link to a crash log if it will help at all - will also be glad to follow any debug instructions you guys might have to get some more information about this jarring bug. Thanks!


    Edit: luckily, in my case, an autosave got me nearly to where I had been. I have no clue about the supposed (auto)save problem but I guess i'll knock on wood.
  11. Nicholas

    Nicholas Technology Director Staff Member

    Also on OS X?
  12. Yes for me, and looking at his crashlog, yes for cactus as well
  13. cactus friend

    cactus friend Member

    Yes, sorry, I'm on Lion 10.7.4. I can also test on Mountain Lion if it helps at all.
  14. lawpocket

    lawpocket Member

    happens to me on PC when I go down floors 4 and below, have to minimize the game right as I walk down so it doesnt crash. Im on windows 7.
  15. Nicholas

    Nicholas Technology Director Staff Member

    Fixed, and will be pushed out with the next patch post-PAX.
  16. Awesome, Nicholas. Thanks!
  17. Is there an ETA on this patch? I can't even make a new character to avoid this... Kind of a showstopper...
  18. Nicholas

    Nicholas Technology Director Staff Member

    .... Er. Chris? You wanna field this one?
  19. Zalrus

    Zalrus Member

    Hey, I just ran into that problem too. I am currently running OSX 10.7.5, and this too crashes sometimes. Sometimes it even crashes from the first to the second, which just happened. If you guys can fix it, that would be fantastic!

    Best of wishes,