OS X Snow Leopard Can not load saved games without crashing.

Discussion in 'Bugs' started by Taylor Ligay, Dec 22, 2011.

  1. alamar

    alamar Member

    Here's the stacktrace of crashing Desmor on Linux x64

    Program received signal SIGSEGV, Segmentation fault.
    0x0000000000463187 in Level::Load(_IO_FILE*) ()
    #0  0x0000000000463187 in Level::Load(_IO_FILE*) ()
    #1  0x00000000004784b8 in LoadGame(char const*) ()
    #2  0x00000000004a03b0 in PlayGameWithLoadFilename(std::basic_string<char, std::char_traits<char>, std::allocator<char> >) ()
    #3  0x00000000004a317f in main ()
    Hope it helps!
  2. loolool2

    loolool2 Member

    Same problem, in addition I seem to crash on the 3rd floor very often. have yet to make it past that floor due to the save corrupting + crashes.
  3. Jeremy

    Jeremy Member

    If you guys need a way to play your saves in the interim and have access to a windows environment, you can use the same save game files on it. If you have Dungeons of Dredmor on Steam, you automatically have access to the windows version.

    The saves are in ~/library/application support/Dungeons of Dredmor in the mac os
    and ~\Documents\Gaslamp games\Dungeons of Dredmor in the windows environment
    You will also need to modify loadsave.dat with a text editor to point to the file name of your newly-inserted save.
    It looks like the number at the top is the # of saves. I incremented this by 1 and then copied the format of the other save files, and it seems to be working just fine.
  4. Eucori

    Eucori Member

    Same problem here.
  5. Mona Pizza

    Mona Pizza Member

    Same problem but on Windows Vista. Sometimes the game just crashes when changing floors. I lost one character this way.

    Got another character stuck in limbo thanks to the teleport bug.

    Finally my third character is a crashing save file, but this was caused well beyond Floor 1/2. I saved on Floor 6 and it just crashes when I try to load it now.
  6. FiveTwo

    FiveTwo Member

    I would like to add my name to the list, ROTDG, OSX Lion, Can't load saved games.
  7. Zelphin

    Zelphin Member

    I have the same problem...trying to wait patiently for the fix. I keep making new characters every time I play (because can't continue once they are past lvl 1 in dungeon). Sort of a new super hard core.
  8. Luiginono

    Luiginono Member

    I am going to add my name to the list. I run 10.6.8 OSX and save files crash the game. I'm really sad because for some reason I have owned this game for a few months but just over the break I really got into it. Hopefully it can get fixed.
  9. petrawiggin

    petrawiggin Member

    Same problem here. I'm probably going to give up on the game pretty soon since there's really no point in playing it if you can't save ever.
    Here's the error I get:

    Attached Files:

  10. EpicEraser

    EpicEraser Member

    This also happens here on Linux 64 bits (1.0.9).
    Just segfaults when loading a save (second floor I think).

    I don't know whether this is related, but the game also crashes after about 5 minutes in-game using my old (first floor) save file. No longer able to fiddle around with it though, because all my saves are now second floor -_-'.
  11. oohhboy

    oohhboy Member

    Head here for a fix on the issue. It should be going out officially anyway at the time of this post. It also appears to fix non-spawning monsters breaking quests.
  12. elby

    elby Member

    The workaround doesn't seem to work for me with the Steam version. There is no "Dredmor" file to replace inside the .app file.
  13. oohhboy

    oohhboy Member

    In Steam the app is in /Users/YOURUSERNAME/Library/Application Support/Steam/SteamApps/common/dungeons of dredmor.

    There are 2 items inside that folder the dungeons of dredmor app and a folder called expansion. Don't worry about the later if it's not there. Right click the app and select "show package contents". Open contents, then MacOS. Place file in there and if it's the correct location, it will ask for permission to replace. The final path should look like this.

    /Users/YOURUSERNAME/Library/Application Support/Steam/SteamApps/common/dungeons of dredmor/Dungeons of Dredmor.app/Contents/MacOS
  14. FiveTwo

    FiveTwo Member

    Wow, thanks a lot. just started a new game, went to the second floor, quit and reloaded and it loaded perfectly.

    I would never have been able to find where to replace that file on my own, thanks again.
  15. elby

    elby Member

    That did it for me too, thank you!
  16. Zelphin

    Zelphin Member

    Ah happy again!
  17. EpicEraser

    EpicEraser Member

    There does not seem to be a Linux hotfix, so I suppose I will have to wait for the next HIB version.

    It is kind of annoying that I seem to keep corrupting my save files if I save on the second floor. :/
  18. nebre8

    nebre8 Member

    It's baaack. Used manual hotfix and everything worked fine, now Steam pushes out revision B of 9.01 and save games crash on load. (OSX Lion) Apologies if I am in the wrong thread. I would expect to see more traffic on this issue, but perhaps Mac users have given up ...
  19. Friedmutant

    Friedmutant Member

    I wonder if the OSX hotfix is not compatible with the 1.09 version I downloaded from HIB? I get a crash after I press "Start Game" on the launcher. Here's what I get on the console:

    user@host:~$ /Applications/Games/Dungeons\ of\ Dredmor.app/Contents/MacOS/dredmor ; exit;
    dungeons of dredmor: version 1.0.9
    argv[i]: /Applications/Games/Dungeons of Dredmor.app/Contents/MacOS/dredmor
    /Applications/Games/Dungeons of Dredmor.app/Contents/MacOSSDL version 1.2.14
    Opened audio at 44100 Hz 16 bit stereo, 4096 bytes audio buffer
    Jan  8 09:57:55 valinor.wackyfunsters.org dredmor[4899] <Warning>: CGDisplayBaseAddress is obsolete and returning NULL for display 0x7bd8d23f
    dredmor(4899,0xac5b42c0) malloc: *** mmap(size=971145216) failed (error code=12)
    *** error: can't allocate region
    *** set a breakpoint in malloc_error_break to debug
    dredmor(4899,0xac5b42c0) malloc: *** mmap(size=971145216) failed (error code=12)
    *** error: can't allocate region
    *** set a breakpoint in malloc_error_break to debug
    <This error is repeated 19 more times, so I snipped them out for your viewing comfort.>
    Could not load resource '' with filename ''
    Bus error: 10
  20. nebre8

    nebre8 Member

    yup, still crashing on load

    Attached Files: