Discussion in 'Bugs' started by Skyblade799, Jul 13, 2011.

  1. Skyblade799

    Skyblade799 Member

    Whenever I load back into a save, the mini-fridges and barbeques are restocked. This could be exploited for endless items :/. (BTW, once they are opened, I can keep clicking them and it will still play the sound and show a message)
  2. Skyblade799

    Skyblade799 Member

    I've noticed that when enemies are standing in a tile that is on fire or filled with poison, they won't take damage, but when they walk into the tile, they will. Is that how it's supposed to work?
  3. Funreaver

    Funreaver Member

    The bug which is my biggest issue right now is with the kleptoblobs (turquoise colour). They stole all items in my belt (quickbar) and after killing them they just dropped the last item they stole. For me it means a break for this game lost good stuff this way...

    Make them not steal more than one item or at least let them drop ALL stolen stuff...
  4. Augury

    Augury Member

    Since it seems the thread I created about this was pushed to the 2nd page, I might as well post this here.

    The (now removed) Burglary skill between Ninja Vanish and Move in Mysterious Ways, previously used to steal from Vending Machines (I assume that is the case because I could never get it to work), has not been completely removed from the game. I had this skill on my hotbar before the update that removed it, and because of that, the game does not recognize it as anything in the game and whenever I mouse over the skill, the game crashes. I tested this to make sure it wasn't just my hotbar in general or something I was doing at the time, so I stood still and moused over each individual skill. The only one that crashes for me was the removed skill. I was able to switch the skill out by only moving my mouse to the bottom right of the image so the + showed up rather than it counting as moving onto the skill, but I am wondering if there is any way to fix this in the future if/when another skill is removed from the game other than simply changing skills. I would like to think that a skill removed from play is completely removed, including its image in the hotbar.

    FFFFFF Member

    I've encountered some, one particularly annoying.

    I had been playing 3-4 hours on my swordsman, i go back up to level 1 to hand in some lutefish, and when i click the stairs to level 2 my game flat out crashes. No error report, no nothing, the application was closed down. I tried to reboot the game, and my savefile was gone...

    Also with the horadric lutefish cube, if you put in, say 10 lutefish, it transform them into 2-3 lutefish, which is annoying since i wanted to stash my lutefish in the cube for convinience, might not be a bug tho.

    When you pick up alchemy as one of your 7 skills, there are some problems (that might also be present within the other crafting skills).
    If you have, say 5 apples, and you want to make apple cider out of them, you can doubleclick the apple ---> apple cider recipe and then make the game put in the reagents itself. The problem is, if you click on the "autofill"-button twice in a row (or several times), without pressing CRAFT in between pressing the autofill button, it will make mats for the wanted item disappear. This is annoying! :/

    I can't walk through my golems with golemancy, causing me to get stuck unless i kill my golems

    When using the alchemy "transmutationer" ability on a stack of gems, it will convert the whole stack into a single gem, annoying! I cannot find a way to split stacks, which there should be imo =)

    Also, please let us rebind the keybindings in the game, please!

    FFFFFF Member

    Right, i also had a single issue where one of the kong's anvil or whatever they are called was placed straight on top of some blue spacefiller, and since there was this doodad or w/e on top of the anvil i was unable to drop any item on the anvil ---> i couldn't use it :(
  7. Bhruic

    Bhruic Member

    Cruelly Barbed Iron Bolt uses items/bolt_craft_iron1.png instead of items/bolt_craft_iron2.png
    and Cruelly Barbed Steel Bolt has the same issue (uses steel1 instead of steel2)

    also for the Steel Bolt series, the Barbed and Cruelly Barbed bolts both use the description from the Iron Bolt series (ie, they specifically use the term "iron bolt")

    and another... The Noxious Brimstone Cloud has a description of "Put it on your salad for a delicious dish, or dump it on your enemies for firey vengence" - should be "vengeance".

    (minor I know, but just pointing out ;))
  8. Zyzone

    Zyzone Member

    The Burglar ability Lucky Pick allows you to have infinite money via selling to a merchant. I imagine they could also be used for infinite Lutefisk but never tried it.
  9. murlock

    murlock Member

    Minor bug with a door misplaced : http://murlock.org/tmp/dungeon-door-bug.jpg
  10. IanExMachina

    IanExMachina Member

    I had something similar to that door as well.
  11. Snicker

    Snicker Member

    I think the disappearing Brax is possibly related to when he moves during the "check for shoplifting" step. I noticed I had a level with three Braxes and all three disappeared at the same time - but the next level's Brax was still there. I went back to check, and the original Braxes are still gone.
  12. Snicker

    Snicker Member

    Stacking container objects (ie, any of the crafting tools) does not work so well - in the shops it can cause you to get accused of theft even if you set the item down. Once you've stacked two crafting objects, then can no longer be separated, even by trying to drop them into another crafting container.
  13. Strygalldwir

    Strygalldwir Member

    I've encountered quite a few minor issues here and there, but have just found a couple of big ones and thought I should come and report them.

    First off, I defeated Lord Dredmor a couple of nights ago with one of my characters and was treated to the "level up" animation and then the game automatically ending when I clicked, rather than giving any option to continue or at least a box saying "well done" with an "OK" prompt. After this, I found that my highscore for that character hadn't been submitted to the Steam servers. Since then, I get a Steam cloud sync message every time I close the Steam application. My old highscore of 316,652 on the "Elvishly Easy + Permadeath" leaderboards is hence out of date, as I scored 373,432 with the winner, which is still reported as my highest score on my local copy of the game. The achievement for defeating Lord Dredmor on easy did update successfully, however.

    Secondly, I just lost one of my characters, when the game hung. I was using the pet wyrmling and had just cast explosive runes next to an enemy. The enemy walked onto the rune and it exploded, as I walked a couple of spaces away by way of clicking. Then everything stopped working. All the animations for my character walking and the enemies doing whatever they were doing were still going on, but the game stopped responding to all input. Nothing on the keyboard or mouse would do anything, not even the escape key or alt+F4, and I had to resort to shutting it down via task manager, which seems to have resulted in me losing my save for that character.

    *edit*: I just beat the game on Dwarven Moderation and that highscore wasn't submitted to the Steam servers either. It seems that only dying submits the scores successfully, and winning isn't dying enough, although I do appear to have a random cause of death in the highscore table.
  14. swanee

    swanee Member

    Obscured in this post means the squares you can't see do to 3d to 2d, it does not refer to line of sight fog.

    Obscured Spaces that you can ASDF to , you can't click to. For example, after levering open a hidden spot, neither clicking on the revealed loot, nor clicking on obscured spot next to you works.

    Bug, seed a corpse, Pick up spore stack from belt, just prior to the exact turn that mushroom appears, seed the corpse again. Mushoom appears on your tooltip, and whole spore stack gets lost.

    Bug, reloaded saved game will remember locations of Zoos discovered after save on mini Map.

    Probably bug, Obscured created corpes do not twinkle. Obscured spawned mushrooms do not twinkle. Dropped items into obscured area's also don't twinkle.

    Not sure if bug, patches of dirt don't go away after spore spawns.

    Not sure if bug, but some uberchests not opening. One opened prior to my death, and said locked in reload of save game. Another one, after first discovering , always just kept saying locked, but I might have died before discovering, and triggering the ability for it to be opened. I don't know how they are able to be opened.

    Not an exploit, but its real easy to make money just collecting mushrooms spawned from seeded corpses.
  15. dbsmith

    dbsmith Member

    Couple of bugs (I think):
    1. I had 2 eels occupying the same space in the water. This should be easy to repro and debug.

    2. A bit trickier to explain, but I think I sometimes get a "free move". If my fire summon wrymling is next to a monster, and i am next to the wrymling (like an L shape), if i left mouse click on the monster as if to attack it (although i am out of range), i get a "free" move closer to the monster and no one else attacks or does anything.
  16. kbe

    kbe Member

    Not really sure if this is a bug or intended but I had two really nice swords I was using for like two floors that had all good upgrades from the Anvil of Krong but notice that the mods that were on the swords for at least two floors are now gone and replace with different ones, negative effects ones, wondering if this is normal like a side effect of using the anvil or some kind of bug, the swords are now ruined.

    *edit* Someone mentioned to me that traps might cause permanent downgrades, could someone confirm this as possible? I'm just trying to figure out why this is happening.
  17. Aftermath

    Aftermath Member

    dbsmith - I think #2 is intended, it clears up the hassle of deciding what to do when you're one space away from an enemy. Although sometimes I'll click to do that and get attacked anyway.

    kbe - Your weapons are getting corrupted. There are corruption fluid traps and a few enemies (magick golems, magic dragons, corruption blobs) that will give you a permanent debuff on your weapon. There's no way to reverse this, just have to prioritize those enemies and stay the hell away from those traps.
  18. Abominog

    Abominog Member

    Leavers that open Secret areas are not Accessible after they are revealed.
    I used the leaver on the left to show lockpicks on the right - I am not able to get the lockpicks unless I leave the level or quit and save and reload save file
  19. swanee

    swanee Member

    Dropping item into portrait when inventory full will usually move character south.

    The quest popup, does not close when "X" in upper right is clicked on.

    Keys "I", "Q",K", and "C" properly toggle window open/closed. But key "M" doesn't follow this pattern, it acts differently depending what other windows are open. For example, "M" will close the I, Q, C windows if they are open, then when they are closed it will then open up the Menu. Slightly different "M" action with "K" window.
  20. Bhruic

    Bhruic Member

    The two rings: "Thick Copper Ring" and "Hexagonal Silver Ring" both use the items/ring_spiral.png graphic instead of their own.