Discussion in 'Bugs' started by Skyblade799, Jul 13, 2011.

  1. Abominog

    Abominog Member

    Excellent Game guys having a blast here :)

    Path finding or AI for pets needs to be better as on many occasions I've had to kill my pet to move past it.

    You can have more than 1 pet - if you leave a level and reenter it and cast pet again and have 2

    Crafting Recipes are being shown as having all items but in fact you don't

    keep up the great work :)
  2. Lord Blade

    Lord Blade Member

    Don't have any screenshots handy, but I've had a few item spawning problems.
    Like items spawning in the same tile as Mellow Shrines and such. So I couldn't click on them, because it makes me activate whatever they're under.
  3. Mepe ruse

    Mepe ruse Member

    when im ingame if i try to turn the volume down by using the volume control button on my keyboard it toggles the character panel on/off
  4. Abominog

    Abominog Member

    Game shuts down when using stairs - had it happen 5 times so far - also are the "2011-07-15_20-54-48.dmp" files crash logs
  5. tiptoes

    tiptoes Member

    Very minor bug-
    If you complete one of the later tutorials and scroll the tutorial window up and down, the gold star will appear in the background as the completed tutorial scrolls.

    Not a priority but wanted to mention it.

  6. TopHatCat

    TopHatCat Member

    I went into a Teleporter and came out stuck inside a Monolith and, well, that was game over
  7. Nicholas

    Nicholas Technology Director Staff Member

    Abominog: Yes. Please send us those.
  8. Skyblade799

    Skyblade799 Member

    The midas touch buff is supposed to make enemies drop money when you hit them right? It isn't for me.
  9. Greymark

    Greymark Member

    Not sure if this has been posted ... but I added items to anvil, could not do recipe (not enough experience), so then I noticed that the items stayed in anvil so I thought, "cool four more slots" ... think cube in Diablo II.

    But when I saved and returned, items gone.

    I am fine with not being able to use as extra inventory but maybe not let cube close with items in it?
  10. Timrod

    Timrod Member

    The "Not Drizzt" skill in the Dual-Wielding line reduces your counter chance by 5 points instead of adding 5 points.
  11. Skyblade799

    Skyblade799 Member

    Acid ampoule bolts have the icon for the acid bottle bolt.
    Opened uber chests will show the closed animation after loading back into the save.
  12. Memo

    Memo Member

    Using a weapon with the quality 'It blasts away everything in front of you," I moved a displacement glyph 3 spaces down and 1 space left. Walking over the glyph at its new location teleports me to the corresponding glyph, but when I walk back on the second glyph it teleports me to the original location of the first glyph. (I wind up 1 space right and 3 spaces up from the glyph.)
  13. Aftermath

    Aftermath Member

    Some small things I noticed.

    1. If you activate the Power of Magic Steel (first viking skill) it will buff crossbow bolts, but they won't count as a hit. I'm not sure if that's how it's supposed to function, but it's a bit of free damage for archers.

    2. When casting the wall spell from Golemancy, if you cast it on the same place you have a wall already, the wall will deflect to a random place, but it will be the old one that moves. Also not sure if this is intended, it's nice to be able to renew the wall once you see the second one disappear. [Edit: After learning more about the wall spell. this seems to be the intended behavior, I didn't realize that you could attack with the wall and how that worked. Awesome spell now that I know that.]

    3. When the game lags (Monster Zoos or sound changes) the game will sometimes confuse a right click for a left click. A few times now it's caused me to walk into a giant stack of Thaumites and nearly die.

    4. Stacking Haywires? Not sure if this is supposed to happen, but I often will hit and get two Haywire messages (http://i.imgur.com/XjWuQ.png). You can also see that there are a ridiculous amount of numbers.

    5. I don't know how Vampirism is supposed to work, or if it's related to the Haywire thing, but the hp refill I'm getting on attacks is crazy. The highest I've seen is 46HP from one hit (or turn) and I can usually count on getting about 10-13hp from each hit. This character I'm using is on level 8 and I've only been at low health 2-3 times.
  14. Obsidian

    Obsidian Member

    I'm not sure if it's been posted, but I found a bug where the active skill of one character is set as the active for all characters. For example, on my rogue I had "Lucky Pick" set as my active skill. I went on my warrior that didn't have the burglary skill and he can use it just fine.
  15. Snicker

    Snicker Member

    Similar to the active skill carryover, if you have an item as your active item, then sell or drop it, the skill that the item gave you carries over until you select a new one. I sold a stack of bolts to Brax and was able to continue firing the bolts that I had sold to him
  16. swanee

    swanee Member

    Autopath steps on known teleportals instead of avoiding them.
    Obilisk, loot dropped on it /(behind it?), and can't pick up.
  17. DTC

    DTC Member

    I placed a trap in Brax's shop, then picked it up again. This caused him to block the door until I paid for my own trap!

    I only tried this once because I didn't want to waste all my money, so not sure if it was a one time thing...
  18. Tekvorian

    Tekvorian Member

    At crafting:
    If you have e.g. 2 apples and you want to create hard cider:
    Clicking on autofill puts one apple in the slot. Then, clicking again autofill, instead of having 2 apples in there, it deletes the previous one -> loss of item.
  19. Nicholas

    Nicholas Technology Director Staff Member

    I have a fix in place for the Stairs crash.
  20. Sarioya

    Sarioya Member

    I'm sometimes accused of theft when I haven't stolen anything. Even when just walking into the shop area and right back out. Also, I can't seem to craft the steeled robe or get the recipe to show up when I choose it from the menu.