Bugs and issues still present in 1.03

Discussion in 'Bugs' started by Pecka, Jul 19, 2011.

  1. ManofPeace

    ManofPeace Member

    @Pecka Regarding;
    Also a question for more experienced players, i got burned by Krong enough times so i didn't try it myself, but what happens if you enchant a crafted item like a rough sword and then craft it into a normal sword, can you do that ?, do the enchantments carry over ?

    From my own experience, if you enchant a crafted item (say tier 1), it becomes a named item which can NOT be used to craft the tier 2. The recipe(s) call for the previous tier item + other mats. If you want to use the Krong, best to make up to the last tier and then start using anvils.
  2. Gray0

    Gray0 Member

    I read some of the bugs and didn't found this one. Sorry if it has already been said.
    When walking into a monster with keyboard movement control and this monster is on the tile where you should click to close an open door. It will try to close the door instead of attacking the monster. Killed me once because I was bashing the key without paying attention (sure I was going to win this fight).
  3. Butch

    Butch Member

    Things I found (don't know if they were mentioned already):

    - If you come to the shop or leave it the game stops for a second. I guess it's because another music is loaded

    - If you kill alot of enemies the game performance goes rapidly down. I think it's because of the sprites of the corpses. Maybe don't draw sprites of stacking corpses, I guess that would help already.

    - Those stealing slime things sometimes make the item apear in your hand. I managed by klicking wildy (as I was in the middle of a fight) to lose about 32 health potions which wasn't really funny at all.

    - When I got the Steam news popup (which shows you new games, new deals etc.) the game crashed without any error message. It just exited.

    - Sometimes (better to say most of the time) items of the same type don't stack. They form two seperate stacks, only quitting and reloading fixes this bug and let's you stack them again. I experience this for example when crafting Aqua Vitae.
  4. dE

    dE Member

    The slowdown when you kill a lot of enemies is mainly because of this bug ->

    Guess I better link it here, since the thread got spammed down rather quickly.
  5. deahamlet

    deahamlet Member

    I can attest to the fact that current (out) version of Dungeons of Dredmor does not load on Lion. After you press START GAME it just hangs and does nothing.
  6. daq

    daq Member

    I found a bug with the "move as use/combat" feature in regards to doors. If an enemy is standing in either of the non-center tiles of a doorway and you press the wasd keys in his direction to attack, the character will attempt to close the door instead of attacking the enemy, thus wasting your turn entirely and letting the enemy attack again.

    Edit: Only tested with horizontal doors so far, will test vertical as soon as I can.
    Edit 2: Same bug exists with vertical doors. Also, walking against a crate/barrel etc does not break them either with the option enabled.
  7. Countmore

    Countmore Member

    "@Pecka Regarding;
    Also a question for more experienced players, i got burned by Krong enough times so i didn't try it myself, but what happens if you enchant a crafted item like a rough sword and then craft it into a normal sword, can you do that ?, do the enchantments carry over ?

    From my own experience, if you enchant a crafted item (say tier 1), it becomes a named item which can NOT be used to craft the tier 2. The recipe(s) call for the previous tier item + other mats. If you want to use the Krong, best to make up to the last tier and then start using anvils."

    Not true, I got a named artifact Iron Skjoldr, and I was wondering if I could upgrade it to an artifact Runed Iron Skjoldr, so I tried smithing it. Although the recipe shows a red cross, if you manually place the artifact into the smithing kit, you will end up with a plain ordinary Runed Iron Skjoldr.

    In short: Yes, you can use named items in crafting, but they end up being a plain vanilla crafted item.
  8. Pecka

    Pecka Member

    @Countmore, yes, Ria mentioned this too, thanks for the input. This could prove useful tho (aka. exploitable) since i usually take smithing up to lvl. 4, then max it last if i find good recipies (can't be bothered to look up recipies online) and/or ingredients. Since i could just enchant my lvl 4 craftables then if i get a debuff use them to make a lvl 5 craftable ala knightly sword. Good to know.

    @Nicholas, well you know, when things fall down, people look up....
    Nah seriously tho, knowing you looked at this thread makes me feel good already :D

    Also in relation to all the people reporting that using wasd to attack enemies at the edges of doors closes doors instead of hits the enemy, mouse clicking does the same, so it's more like a general issue with the game, but it's manageble, you just need to discipline yourself to never attack near the edges... i almost died to that a few times as well.
  9. pmuschi

    pmuschi Member

    Didn't see this bug listed so...

    I killed two diggles (side-by-side) and went up some stairs immediately next to them. I decided I didn't want to be on the next level quite yet, so I turned around and went back down. On getting back to the original level, the dead diggles were shown using the alive diggle sprite (both shown facing south, but that's not the direction they were facing when killed). I attacked them until I realized the tooltip said they were dead. I then walked away so they moved offscreen, then immediately walked back, and the bad sprites were replaced by blood stains.
  10. xrogaan

    xrogaan Member

    I just had this issue : http://cloud.steampowered.com/ugc/577803239987938816/5FFEE32828DA3025F63EC1CE3B815D7B6280C0FA/

    The monster should normaly be in water.

    Also, once you explored a whole level, it's hard to see where you are with the minimap. The icon for the hero should be brighter.
  11. EvilCanadian

    EvilCanadian Member

    An update to my bug:

    "Permadeath saves not deleting on load: Not technically a bug I suppose because it is working as intended"

    Permadeath saves (or at least those from pre-1.0.3, haven't tried it with new saves) don't delete on death either.
  12. Lactose

    Lactose Member

    I had an issue earlier where certain kinds of fungus were showing the smaller ui versions on the map. Its happened twice now with 2 different types.
  13. RosenbergAtom

    RosenbergAtom Member

    I encountered a Monster Zoo, but decided I did not have time to deal with it right away, so I closed the door immediately, backed away, and then saved and quit. Later on, I loaded the game again, opened the door, and killed all of the monsters -- but beneath my minimap, it still says I have all 52 monsters to kill.
  14. LordHavoc

    LordHavoc Member

    A few annoyances I've observed:
    Monsters somewhat often spawn in walls beside water, they are hard to engage in combat as a result (mostly just looks stupid).

    The inability to unstack items makes it impossible to save up my lutefisk effectively - I seem to always get a reward if I drop 100 lutefisk on the statue, so it annoys me when I end up with 200+ lutefisk in my inventory and can't unstack and save some for the next statue. This isn't about skimming stacked items for conversion to lutefisk, this is about unstacking the lutefisk itself. As a workaround I avoid using the Sort button in my inventory, and make multiple stacks of 100 lutefisk to drop off at any statues I encounter... This is tedious.

    Another bug related to lutefisk - back in patch 1.0.1 when I first played, I dropped a stack of 22 lutefisk into the cube (not knowing the purpose of the cube at the time) and it became 1 lutefisk, since then I have carefully avoided putting more than one lutefisk into the cube at a time (occasionally I find one in the dungeon and want to put it in my stack of lutefisk in the cube), so I don't know if this still occurs in 1.0.3, but the cube conversion sound plays when I drop one lutefisk into the cube so it seems likely this is still the case.

    I agree about being able to unstack tinkerer parts and other things to sell some but not all of them - when I find myself with 3 tinkerer parts (and I have tinkerer skill) I don't really want to sell the whole stack to Brax, I want to keep one... same goes for converting some of them to lutefisk of course. I'd go as far as saying the crafting kits should not be part of the inventory, this would make things a lot simpler.

    On another note, acid bolt traps are severely overpowered, and acid resistance seems hard to come by (but that may just be my luck), pretty much any other kind of trap I can trigger without major consequence (alternatively this may mean the others are underpowered), keeping in mind this character is on Easy without permadeath.

    If I leave the game idle for an hour or so, usually it will crash when I go and open a door or up/down stairs, my best guess would be sound engine related but I am not sure.
  15. Dr_Tasslehoff

    Dr_Tasslehoff Member


    Equipping armor with rightclick will spend a turn, while dragging it onto the character screen will not.
  16. blacksan

    blacksan Member

    Hand of Belimawr from Viking Wizardry skill buffs both melee and ranged attack for a limited number of strikes, but ranged attack has no affect on the remaining number (meaning it's possible to range attack under the effect of the buff infinitely).
  17. Ratha

    Ratha Member

    Bugs ive found in Dredmor 1.03 + hotfix (windows xp pro sp3)

    1: Launcher causes more CPU usage than actually running the game. http://www.gaslampgames.com/forum/discussion/602/launcher-causes-high-cpu-usage.-1.03-hotfix for more details.

    2: Pressing the Z key causes the player to move to where the mouse cursor is. (This either needs to be removed, or needs to be re-bindable (preferably the latter.) Same thing goes for the + and - speedup/slowdown keys. (Hidden keys are not good.) After binding the skill menu to the Z key, whenever the skill menu is closed by clicking on the close button, or pressing Z again, it causes the character to move to the current cursor position.

    3: When you click on the plus sign to add a copy of the skill Radiant Aura to the skill bar, the mouse over popup shows that the skill also gives you +1 aetheral resistance. Should it show this? (The aetheral resist is a passive from taking the astrology skill tree, and is granted by simply having the radiant aura and above spells.) As far as i understand, these should show in the skill tree, but not on the mouse over text for add a new skill to the quick skill bar. This 'problem' does other skills. (Its not really a problem at all, but seems somewhat inconsistent and may warrant a look at in the future. Very low priority.) http://img508.imageshack.us/img508/4928/radiantaurashowspassive.jpg

    4: This issue may or may not have been fixed in a previous patch, not sure what version its from: Buying bolts (or maybe any stack of items) from Brax lists the cost per individual item, and not the cost per the stack. Since theres no option to buy individual bolts, (i dont think?) it should list the stack cost, or give you an option of how many you want to purchase, and then calculate that price. Person buys some bolts which have a low cost, ends up costing way more than expected. Skip to 4:25 to see. (Cruelly Barbed Copper Bolt(7) (246 Zorkmids) Clicking buy charges the player 1722 Zorkmids)