[Bug] Pocket Dimension black screen

Discussion in 'Bugs' started by DM789, Aug 6, 2012.

  1. DM789

    DM789 Member

    after my pocket dimension crash bug is fixed by the latest hotfix,

    half a day later (realtime, not gametime), when i entered pocket dimension i suddenly got black screen, i can still see the description for item that i drop in there, but no way i can see where my char is, or where can i drop another item, so my pocket dimension now suddenly got a black out, with no way to fix it, i've tried everything, excluding starting a new game, and my pocket dimension still black screen.

    and another bug, my autosave seems not to save correctly, because when i try to load my auto save, the content is a very old, i meant i've passed that a long time ago, so auto save is not working.

    so there is 2 bug right now, this is with hotfix 3 and 7 installed.

    1. pocket dimension is very dark (gaslamp games probably forgot to pay the electric bill again :p )

    2, auto save content is not newer than my manual save, and i can swear that i saw game auto save notification a few times after i manual save my game (gaslamp games probably forgot to pay the coder for autosave, so he put the bug in there :p )

    please fix this ASAP, because i don't know why i'm in the mood for some dredmor, but i can't play it with all this bugs.

    Edit : i forgot to mention that i can enter and exit pocket dimension just fine, its just that pocket dimension got no light at all, can't see anything in there, except when i try to highlight the ground, i can see item description of item that i put there.
  2. alkaris

    alkaris Member

    there is another thread like this.
    the method of fixing described there:
    create non-permadeath character, save and quit, then load your normal save. PD should be normal, worked for me at least.

    This is temporary solution until bug will be fixed.
  3. DM789

    DM789 Member

    thx, just try this temp solution, and it works, hopefully no other bugs, because a chain of bugs attacking me almost turn me off from this game, and turning me off from this game = i wont recommend this game to my local friends, and wont ever touch this game again, and put this game on the trash can in my library along with dungeon defender (dungeon defender is there now, because of the dev focusing only on making new dlc and the game is very unbalanced for solo play).

    Edit : just noticed (i was AFK), that doing this, and then entering pocket dimension = inventory empty, i guess i'll skip dredmor till the bugs is fixed, even tough right now i'm really in the mood for dredmor.

    Edit 2 : i tried killing the process from the taskmanager, since dredmor doesn't have the option of just quit without saving, and after that i tried exiting, and the entering dredmor again, and tried loading my save game, and it seems my whole inventory is gone, except the lockpick.

  4. The temp solution offered by alkaris is not working for me. Any update/hotfix on this issue would be much appreciated!
  5. Daynab

    Daynab Community Moderator Staff Member

    Use the tileset switching machine in the center of the floor and change tilesets with it.
    That fixes it.
    OnyxAlchemyst likes this.
  6. Confirmed! Thanks a bunch!
  7. Hi,

    After installing Hotfix 10b/c my pocket dimension shows no item / character graphics, even though I can still hover over items to see their descriptions, similar to the others. I also do not have a switch in the middle of my pocket dimension, nor the portal to the wizardlands ( even though that is what I expected since I started this game before CotW came out. I didn't even HAVE a pocket dimension until after 10b was released ). Save game is included below.

    Windows 7 64-bit

    Edit: Just so I'm clear, there is no tileset switching machine in the middle of my pocket dimension, nor is there a "machine" to enter wizardland codes, or the portal box to wizardlands. There hasn't been one in my pocket dimension since I got my Lost Wizard Keys on level 7 of the dungeon. I expect this to be because I started the game before the release of CotW. All new save games that I create have both the tileset switching machine and the wizardlands portal, along with the decorative pillars. I have tried to walk into the tileset switching machine, but its just not there for me to walk into, click on, or otherwise.

    Attached Files:

  8. Daynab

    Daynab Community Moderator Staff Member

    Go to the center of the room and activate the tileset switching machine.
  9. Nicholas

    Nicholas Technology Director Staff Member

    (We'll have it set so that you don't need to use the tile-switching machine in a bit.)