Discussion in 'Clockwork Empires General' started by Nicholas, May 13, 2016.

Thread Status:
Not open for further replies.
  1. Selly1

    Selly1 Member


    Attached Files:

  2. dbaumgart

    dbaumgart Art Director Staff Member

    Thanks for the report, fixed for 50E.
  3. Nicholas

    Nicholas Technology Director Staff Member

    Selly1: Okay, the reason the modules aren't workign in that workshop any more is because the game thinks they are locked, so that they're being used by some other job. Do you remember if any workshop jobs aborted, or anybody interrupted an attack or something? It's unclear what the culprit is in the save game.
  4. Selly1

    Selly1 Member

    This was a fresh game just to try out the idea that it may be the second module, so I was keeping an eye on it. The jobs seemed to stop straight after adding the second power saw. There was a bandit attack, but only after I noticed they'd stopped work.

    Edit: Have tested again on another clean game, and couldn't reproduce it this time.
    Last edited: May 16, 2016
  5. Nicholas

    Nicholas Technology Director Staff Member

    Drat. Well, you definitely hit something. Were you changing or cancelling jobs, or moving modules around, or something?
  6. Rentahamster

    Rentahamster Member

    While I'm pretty sure that is a thing, I'm also pretty sure that a lot of times the player doesn't realize that the work crew doesn't have the necessary materials available to produce the work order. Maybe a helpful info tooltip or something that tells the player when they don't have enough materials would be good?
  7. Selly1

    Selly1 Member

    Not moving any modules, but I did shuffle the work jobs around within the carpentry, and I did cancel a lot of Clear Terrain jobs... may have accidentally cancelled a different job by mistake.
  8. Manamoo

    Manamoo Member

    Possible bug? Built a didn't show up. Shortly after the screen blacked out. I clicked on the mini map and things were good...but it blacked out again, with some white flickers. I tried to take a screen shot, the main menu is what I caught.

    Also, I think a few of my overseers died, but they didn't get removed from the Workcrew menu. I am not sure if that's intentional or not. Confusing...yes. I remember losing my NCO to a fish people attack. I tried to give her a decent burial, I think that went automated?

    One last was extremely laggy. Usually it's seamless, I over meet the requirements...only thing that is different is I'm using Windows 10.
  9. Rahbek23

    Rahbek23 Member

    The problem I see is that you might run into a situation where you see this all the time, because lacking one resource or another is a fairly frequent thing - however if you limit it to some arbitrary time it might be rather unclear and lead the players to believe that their production is running full steam when it's actually running very intermittent. I'm all for the principle though.
  10. Rentahamster

    Rentahamster Member

    I'm getting a lot too. I stopped playing for now because of it.
  11. Jacq

    Jacq Member

    I just had a really weird game that crashed without crashing. The bandits destroyed my Carpentry workshop (on day 5, without a "bandit attack" countdown timer.) I don't believe I was given an opportunity to make a deal with them, but I did get a pop-up saying I didn't respond to them. (This has been mentioned before?)

    Anyways, after they destroyed my workshop everything "froze", like when you pause the game - animations still looping, menus and buttons still clickable (though nothing actually happened if I said to, e.g. mark someone for frontier justice or destroy a stockpile. Here's the screenie:

    This game was also kind of bizarre in that I landed right on the corner of the map, meaning everything along the outer edge was in the "white zone" and therefore invisible/unclickable. But I somehow also managed to set a forage job for the entire world, which was maybe cause by making the selection box end outside of the actual map?

    Since it didn't technically "crash" I don't think it generated a crash report (at least, I can't find a .dmp). Selecting "Save and Quit" didn't work, and selecting "Quit without saving" just ... turned the music off? but didn't quit the game. (Neither did trying to kill it with alt+f4 or from the taskbar, but I was able to kill it from task manager). I've attached the console.txt

    edit: Trying to load the last autosave caused it to crash without a notification (program not responding...)

    Attached Files:

    Last edited: May 17, 2016
  12. Nicholas

    Nicholas Technology Director Staff Member

    Yeah, 50D has a bad crash bug when workshops are destroyed. Fortunately, 50E will be out soon enough.
    Jacq and Rentahamster like this.
  13. Selly1

    Selly1 Member

  14. Teutomatos

    Teutomatos Member

    Pretty cause ... It s happen if we delete it, ourselves too ....
  15. Cyjack

    Cyjack Member

    Came here looking for the spicerack, but it seems that's been covered already.

    So instead I'll just mention that it bothers me I can't just click on a portrait in the crew list to bring up that persons stats anymore.
    Last edited: May 17, 2016
  16. Cyjack

    Cyjack Member

    Is this why I can no longer get my workshop quality up past "uncomfortable" with window spam anymore? I'm late to the 50x party. How do I increase the quality?

    Never mind, I see the upgrade button for some workshops with their item requirements. It's not present in all buildings though--for instance, my barracks doesn't have one. Is that just a temporary absence, or is there some other trick to get their quality up?

    [edit 2]
    Oh, ok. I see a very few module items that have positive quality values. Most of these take up too much floor space to be economical, though. Looks like Ill be spamming large clotheslines now whenever I figure out what the heck bricabrak is.
    Last edited: May 17, 2016
  17. Cyjack

    Cyjack Member

    I could also use some tutoring in how the military promotion thing works now.

    I got hit with a large bandit party early on and my overseer got popped. Iit appears as if someone was promoted to the squad leader, but then they all ran away and I was unable to assign that squad to a barracks. So I had to remove all of the squad members and assign them to a new overseer, thereby losing all my redcoats anyway, and now I have a bugged overseer in the former squad leader that cant be assigned.

    What gives?
    Last edited: May 17, 2016
  18. Rentahamster

    Rentahamster Member

    Wall shrines are basically the same as what windows used to be. Rugs are a little more space-efficient though. +4 quality, and they don't get in the way of anything.
    Cyjack likes this.
  19. Cyjack

    Cyjack Member

    Nice. Thanks for the tip!
  20. Alavaria

    Alavaria Member

    Rugs, the new spammable. Admittedly, it does take a good bit of bricabrac (still 1 per quality) but I think the trade value is still very low.

    An issue with wall shrines is that (sometimes) you need to make a bit of room for them. However, you can cram two in a corner and then even add a square to your building and cram 3 in it... (but rugs are better anyway)
    Last edited: May 17, 2016
Thread Status:
Not open for further replies.