Windows Vista/7 64-bit 1.0.8 Bug reports, will edit frequently

Discussion in 'Bugs' started by Neviskio, Dec 12, 2011.

  1. Neviskio

    Neviskio Member

    didn't know that, I will flag it then, but feels kinda awkward to say the least <.<
  2. Copycat Zero

    Copycat Zero Member

    When you use the hotkey (Alt+# by default) to open a crafting tool menu, the game says in the chatbox "You take out the [insert name of tool]". However, when you use the same hotkey to close said menu, it STILL says "You take out the [tool]". I imagine that it has something to do with the new interface, as it used to say (for the period between when the hotkeys were put in and the change in the crafting system) "You put away the [tool]" when you closed the menu with the hotkey.

    And, speaking of closing the crafting menu, the ESC key doesn't.

    Also, on the key binding menu, the list of crafting tool hotkeys is broken up by the two animation speed hotkeys, and there is no hotkey for the wandcrafting tool. (On that note, due to the change in the crafting interface, can we just have one hotkey for opening the crafting menu that's independent of having the tool on one's person?)

    It's still possible to get extra moves by inputting movement commands while casting or debuff animations are going on. For example, I just kited a monster by using an Arcane Wand and telling my character to walk one tile away at the same time. I also managed to, on a different turn, as my character started walking to a tile, tell my character to use the wand -- she paused, cast, and then finished her move. In both cases, I got two turns of actions over the monster's one, allowing me to always stay one square away from it.
    EDIT: ...maybe. I just tried to replicate it against a group of monsters with a different wand and it didn't work. It may depend on the animations involved.

    As others have noted (and I noted in the beta), artifacts are still being generated that have the old Wand Affinity stat on them. That is, they have a +1 with the icon that is now being used for Wandcrafting, but equipping the item doesn't increase Wandcrafting (for obvious reasons).
  3. lccorp2

    lccorp2 Member

    All heals over time are being resisted extremely often, making items and skills like potion of lively regeneration, thaumatheurgic tap, coral wand, fairywodger, night cap and so forth highly unreliable.
    Neviskio likes this.
  4. shaf

    shaf Member

    Lutefisk BUGs
    1. If Lutefisk are in your Inventory Bar they can no longer be placed on a Lutefisk Altar.
    2. Sacrificed 100 Lutefisk to an altar and go no reward

    Update: Finally got a reward after 300 Lutefisk had been sacrificed. It appears the Piety Sacrifice Requirements have changed since 1.04.
  5. Copycat Zero

    Copycat Zero Member

    Been around for a while, but, in somewhat the same vein as the possible "spell animation gets you time to move" exploit/bug, there seems to be a slight "stutter" when your character transitions from using the mouse for other actions in combination with the keyboard to using the mouse to move. I can't describe it well enough, but, after whatever it is you need to do to trigger it (move around with your keyboard some and then attack a monster, usually), when you go to move with your mouse, no matter how far away you click you'll only move one square initially. This one square of movement doesn't expend a turn. I've had this happen with monsters around, and the monsters will just stand there while I move. It's not as exploitable as the spell animation thing, but it's still odd behavior.
    [EDIT] ...aaaaaaaaaaaand no sooner do I report it than I can't reproduce it, even though it's been happening so often in the past... again...
    [EDIT 2] Ah! There, it just did it. I started a new game, keyboard-walked down to near the vending machines, checked my character sheet to confirm that I didn't have enough Trap Sense to be safely walking around with the keyboard, and tried to mouse-move over to one of the machines. Even though I clicked two spaces away, I only moved one space. Then I mouse-walked over to a door, kicked it open, killed a diggle, and when I tried to mouse-walk again, I again only moved one space.

    I've noticed that the "what does being fair have to do with it" rooms no longer spawn traps on the path. Before, there would be, like, 2-3 traps leading to the little center peninsula. Now, the only guaranteed trap seems to be the one in front of the chalk scrawl, but you can walk to the peninsula without trouble. Not sure if that was an intended change or not...?

    It was reported in a slightly different form earlier, but I just killed a diggle that was two squares away from me when the spell hit. The bloodsplatter is still two squares away, but the corpse is one square away. That is, the dead diggle moved a square closer to me before it fell over dead. (Also, long-since confirming the note that monsters will sometimes take a non-damaging swing at you before they fall over dead.)
    [EDIT] As I walked away from the diggle's corpse, it got the "I've noticed your presence" exclamation point over it... (oh, and moving away from it also had me do the mouse-move bug again)
  6. shaf

    shaf Member

    Character Paperdoll Item Descriptions Bug
    Version 1.08 Windows Build
    1. Open Character Sheet using Mouse of C
    2. Mouse over to any populated slot, Item Description will be for the Item directly above. ie. Belt shows Armor Info.

    It appears to be a UI issue where the mouse pointer isn't focused on the exact location, If i point at the lower right hand corner of the Inventory Block the Information is correct but If i point in the Centre of the Block then the Item above is listed, If I point to the Left of the Block , Left Inv. Item info. appears.

    I'm using the standard UI and a Screenmode of 1920 x 1080.

    This behavior didn't occur in Win. Version 1.06.