Windows Vista/7 64-bit 1.0.8 Bug reports, will edit frequently

Discussion in 'Bugs' started by Neviskio, Dec 12, 2011.

  1. Neviskio

    Neviskio Member

    I decided to post a new one to avoid confusion with older versions.bugs I found out up to now, will edit fairly frequently in the next 30-to-50 hrs.Bugs marked critical are source of crashes or Bad Things(tm),

    STEAM RELATED(ACHIEVEMENTS):In the short list under the "play" button you can still see the deadshot achievement, also you can actually get the crash-related one but it won't obviously show in the list.Playing for both teams seems to not be awarded, unknown why(others are working fine it seems, not sure for every one of them for obvious reasons)
    CRITICAL:Boss monsters can spawn inside walls, hitting them or in any way interacting with them can cause Bad Things to happen(had crashes and unloadable save games, happened 2 times, got a screenshot to show).The boss appears to be spawned in a wall behind a water canal so i guess it does spawn on the water and gets pushed on the wall maybe? Ask for screenshot if needed.
    CRITICAL:Randomly crashes while interacting with vending machines with burglary, so far happened to me once only and right at the first vending machine, can't reproduce constantly.reloading fixes the machine that crashes you, so you can actually steal without crashing that way.
    CRITICAL:The crafting ui doesn't reset to the start of the list, so if you have a craft with a lot of recipies you can scroll down a lot and when you change craft you might find yourself hovering in an empty spot, clicking on craft or inputting an item or in any way interacting beyond repositioning on items WILL crash you hardcore.It will crash also if you hit the pg.up or pg.down button no matter what.
    CRITICAL:Using "last skill build button" will make you use deadshot if you had in a previous character, expect terribad effects(crash mostly but also wrong skills going misplaced and all the bad stuff...Couldn't try more than a couple times but always had random bad things happen)
    1)All the icons on the female character for debuffs and such are using the male version, known bug or not a bug?
    2)Mousewheel in the crafting menu doesn't work anymore
    3)Not sure it's a bug, will post screens in case: I stumbled upon some 100% not enterable rooms, it's intended to have locked rooms by "gates"(the metal bars, surrounded by lava and the usual acid trap gargoyle) or not? Also I found small alcoves that are not enterable a LOT of them, intended?
    4)Not sure if a bug but surely would improve the game A LOT: no tooltips on crafted items, also if you click on them you instantly craft them without notice.
    5)Inventory menu still shows that you have more items than what indeed you have: if you need 3 platinum ingots for an item and got only 1 it will show 3 ok "signs", while really you have only one...
    6)Items in a drink dispenser don't say anymore how much they regen, so you actually don't know what you're buying, also no flavor text is shown.
    7f)FIXED, reinstalling fixed my autoloot, not sure why it didn't work before but now does.
    8)Items can still spawn under "landmarks" (i.e. mellowy shrine, monolith etc) so you can't interact with them EDIT:Up to now in 1.0.8 in all the games I did(10+) i ALWAYS had something under a quest-related landmark, it really needs fixing, it's basically sure you'll stumble upon that and you will rage about that "healing item under the monolith"
    9)Opening at lvl 3 in no time to grind mode a door that brought to a lutefisk statue started the monster zoo event wasn't that room a monster zoo, and there was only a single mob, trying to find where the zoo actually is will update with more info later.Zoos might trigger wrongly
    10)Ninja vanish seems bugged, when i use it against unfriendly ai mostly but any mob works being in melee range while casting makes the monster keep attacking you, I think it doesn't work at all invisibility to be honest.
    11)You can actually place items in inventory 1 row to the right outside of the box, like in a previous bug report screenshot(can't find it right now but it's the same bug)
    12)REPORTED NOT A BUG,Some monsters have strange behaviors: I had a zoo where all the octo mobs where chilling around and didn't come for me, they only casted missiles and all stood in their angle, needles to say I couldn't get near without getting missile-bombed-killed, which is kinda strange since they used to come after you.Generally some monsters ai seems buggy and they won't actually come after you.Edit: I've been noticed it's intentional, still super-awkward I'd say...

    More coming(hopefully not =P)

    edit: I plan to host all my screenshots but not sure where since they are 1920x1080 and a lot...and i suck at paint <.<
  2. Velorien

    Velorien Member

    The Equipment Maintenance tutorial now gives inaccurate information since the Bad Weapon Penalty has been removed.

    The Wands tutorial is also now obsolete.

    The Crafting tutorial is just plain broken as far as I can tell, and trying to craft in it crashes the game.

    Items that are supposed to give bonuses to what is now Wandcrafting do not do so.

    It is no longer possible to free up pedestal slots in Brax's shop by moving his items onto the ground, as he now stays in the doorway. This means the only way to free up a slot is to buy something. If you found this out by putting something on the floor and selling an item to the pedestal in its place, *you now have to buy something to leave*.

    The Promethean Magic skill Infernal Torus now does significant DoT to the player when used due to the different behaviour of spell mine effects. This is surely not intentional.
  3. Musaab

    Musaab Member

    Resolution 1920x1080...large UI...try mousing over your equipment. Example: Headpiece and Chestpiece. Mousing over both reveals stats for Headpiece...mousing over empty square below chest reveals stats for chest.
  4. Aldin

    Aldin Member

    Magical Training appears to have a placeholder description. It says something like "(insert irreverent Potter quote here)".

    Quick slot #6 doesn't work that well. Items dragged onto it re-appear in your inventory.
  5. Neviskio

    Neviskio Member

    Added some critical gamebreaking bugs and how to reproduce, if a dev has questions I have plenty of screens and better explanations, I can reproduce most of these 100% for now.
  6. kino5

    kino5 Member

    Don't know if it's a bug or intended, but now when I try to get lutefisk from the horadric cube, it goes right to my inventory, instead of remain "picked", as before.

    Also, when I try to craft an item without space in the inventory, it goes right to the floor before checking if there's enough space after removing the needed materials. I did it before applying the patch, and if there was an empty space after removing the materials, the new crafted item filled that space.

    Looking forward finding new bugs, if that helps improving the quality of this awesome game :)
    Neviskio likes this.
  7. Koffein

    Koffein Member

    bugs i found within 5 minutes 1.0.8

    - key binding "up" suddenly changes from w to 7 (already happend in the 1.0.7 humble bundle version)
    - "anvil of krong"-enchantment does not change stats (screenshot attached)

    Attached Files:

  8. bhomer2

    bhomer2 Member

    every time the game crashes, it changes my "up" binding from "w" to "7".
  9. Aldin

    Aldin Member

    The second skill in the Berserker skill tree increases one of your stats by 5, but it's unclear as to which stat because its icon does not correspond to any of the icons used on the character/paperdoll screen. Same stat is increased by One Sparkling Glove.

    Attached Files:

  10. Daynab

    Daynab Community Moderator Staff Member

    That's magic reflect. As for why it's not anywhere I do not know.
  11. Null

    Null Will Mod for Digglebucks

    Just copy-paste from my thread

    • Haemetic Phylactery might be a starting item if you have Alchemy
    • I had a quest item which appeared as a wizard's sleeve. When I attempted to pick it up it changed to a blue lutefisk icon, keeping the same name.
    • Drowning in Lava still uses that nice blue water drowning animation. Also: First. (maybe not but I've beaten at least 1 in 1000 players)
    • Throwing doesn't show damage in the log

      Three related bugs
    • Monsters can sometimes move or attack after their death.
    • You can still walk onto monsters if you move while they're moving.
    • Monsters may hit you while you're moving off of a tile. I just died because an AI hit me going up the stairs in such a way that's not possible. They don't have extendable arms and can't move them forward, then turn right, then up the stairs to attack. (That was more the description of the impossible attack than anything else)
  12. Josh

    Josh Member

    Great to see the patch up. Love the new content. I am a bit disappointed to see all these unfixed bugs though. Anyway, here's some more stuff:

    1. Steam overlay still doesn't work.
    2. There is no z-order management of UI elements. For instance: If the crafting window is behind the character window it is not possible to close the character window by clicking on the X because the click event is sent to the crafting window instead. Also tooltip z-ordering is a bit of a mess in some windows.
    3. Lack of consistency in the UI. Currently there are at least six different windows in the game: Menu, Character, Inventory, Skills (or "sKills"... still haven't figured out why), Quests and Crafting. Every window behaves differently. Menu, Character, Skills and Quests are not movable; Inventory is movable by grasping the window at the top; and Crafting is movable by grasping the window in a limited region at the top. Neither is there an indication as to whether a window is movable or not, nor does there seem to be much of a reason why some windows are static (Why is the Character window not moveable?). Then there are the buttons which open the windows (except for the Crafting window). If you first click on Menu the Menu window appears and then on Character the Menu window disappears. Try it the other way round: First Character, then Menu and both windows remain open. Clicking these buttons in different orders produces all kinds of different results and can be quite confusing.

    I hope the devs take the time to fix this fundamental stuff instead of focussing solely on new content.
  13. Daynab

    Daynab Community Moderator Staff Member

    I just want to say rest assured all your bugs are being filed internally even if we don't answer each thread (there's been a lot today, boy).
  14. Wootah

    Wootah Member

    That is dedication. and the best part is, it is still totally worth playing. I am playing/using the skills/abilities that don't cause crashes.
  15. Velorien

    Velorien Member

    This man/woman/other speaks wisdom. Rare is the game that I would keep playing even when faced with so many bugs. Yet here I am, willingly dying horribly over and over even before the hotfix.

    That said, and I realise this is a common complaint, if you have a comprehensive database of known bugs, I would really appreciate it if you focused on fixing those before investing time and creative energy in designing new content. New content invariably comes with new bugs (this patch is a triumphant example), and the old ones are entirely numerous and troublesome enough on their own.
  16. Neviskio

    Neviskio Member

    Edited a few more things in, keep checking <.<
  17. Neviskio

    Neviskio Member

    Added a new critical game crashing bug, check it out, related to boss spawn for inconsequentia quest
  18. ChaoGuy2006

    ChaoGuy2006 Member

    Hey, found a bug with item stacking on the ground, at least with Diggle Eggs. (should I make this it's own thread?)

    I found another "pile" of diggle eggs (not stacked by number, but about 4 or 5 laying on top of another). I couldn't be bother to pick them up one by one so I picked up and dropped them (to get the whole stack). It doubled each time. I got 64 Diggle Eggs.
    Should have tried for the achivement, but I've got a ton of ommlettes now. Havn't tested it fully. Will try again with the next diggle nest I come across.

    EDIT: This bug does not effect other things (didn't work on an iron ingot pile I found/made)
  19. dnabre

    dnabre Member

    Windows 7 64-bit/Steam Minor UI Bug in Crafting Menu

    Scroll wheel no longer works for navigating the crafting lists, minor but might be related to the craft menu crash issue.
  20. lccorp2

    lccorp2 Member

    I believe this was included in the patch notes: caster mobs now have "chicken" AI and require you to close in or use ranged to deal with them.