1.0.7 on Ubuntu 11.10 major instabililty

Discussion in 'Bugs' started by dpiekny, Nov 29, 2011.

  1. Loren

    Loren Member

    Dredmor-amd64: /home/nvining/dredmor/monster.cpp:400: Monster::Monster(monDBEntry*): Assertion `(entry->level - curLevel->number < 4) || entry->name == "Brax"' failed.
    Same dump as others from gdb after I got caught stealing by Brax and ran out of the room. Dread collectors being summoned?
  2. smoak

    smoak Member

  3. filedil

    filedil Member

    I haven't encountered any random bugs, but I found this thread while looking for a solution to a crash which turned out to be the case sensitivity thing. It seems obvious, but I'd like to point out that HIB packages should be updated with these two patches as soon as possible, cause for now they aren't. That makes the game unplayable and this thread wasn't exactly very easy to find.
  4. DerRidda

    DerRidda Member

    Even after hotfix is applied the game still crashes when using an item on a shrine.
    It fixed the freeze when standing ion the psychokinetic shove radius though.
  5. For me it crashes (sometimes) when opening a door

    i love the game.. and i hate this bug...
  6. filedil

    filedil Member

    Well, guess I spoke too soon. After last message I started having random crashes even while walking, on both original binaries and patched ones. Gdb points to: 0x000000000051ed41 in DirectorTick() (), no other information.
  7. frosgate

    frosgate Member

    Hey everyone,
    Just picked up this game from The Humble Indie Bundle (like so many others), and am running into the same problems as everyone else. Currently grabbing and applying the two patches mentioned in this thread. Wanted to take a moment to give a shout out to Nicholas for being so responsive to us as a community. It's a rare treat to actual get to work with Devs when it comes to troubleshooting application glitches. And, the game is awesome, as well.
  8. Krushak

    Krushak Member

    Ok so most of the crashes were fixed bye the case sensitivity issue... but my game kept crashing even with hotfix binaries. (Memory Errors) I then ran it as su with --debug-flag which seems to fix stuff :) havent had a crash since hours
  9. ColdSpider

    ColdSpider Member

    Well the patch definitely helped me a lot, I managed to get through the entire first floor no problem, but right after I got to the second it crashed, I loaded up my game again and I got a segmentation fault after a few minutes, I wasn't really doing anything notable it just happened randomly. I'm running x86, btw.
  10. frosgate

    frosgate Member

    After applying the humble patch, and applying the filename case patch, I haven't had a single problem. Played for WAY too many hours this afternoon, without a single crash. I will say that I have not tried doing any of the summoning that others have mentioned causing crashes; I'm just been playing swords and armor.

    For anyone reading this, the filename case patch IS NECESSARY.

  11. I can confirm what frosgate says. nicholas patch + filename pacth = Stable game.

    Thanks :D
  12. Twig

    Twig Member

    Same here. Really enjoying the game. Thanks.
  13. tues

    tues Member

    Wyrmling summoning is still broken:
    Dredmor-amd64: /home/nvining/dredmor/monster.cpp:400: Monster::Monster(monDBEntry*): Assertion `(entry->level - curLevel->number < 4) || entry->name == "Brax"' failed.
    I like the game, but I can't understand why it's written so poorly. At least the patches mentioned in this thread fixed random crashing, so it's playable.
  14. truekaiser

    truekaiser Member

    the game won't even start, it segfaults upon load even 'with' all your fixes so far. maybe you should try running the game on a vm with linux installed or some spare hardware before release?
  15. Loren

    Loren Member

    Start the game using the included script (i.e. ./Dredmor ) and not the binaries themselves. That should get the game starting for you.
  16. Dimitri

    Dimitri Member

    The patch in the other thread solves the segfaults when opening doors and other cases, but:

    I am experiencing the same problem on debian, 64-bit, patched version.

    The full backtrace as reported by GDB is:
    Program received signal SIGSEGV, Segmentation fault.
    0x000000000051ed41 in DirectorTick() ()
    (gdb) bt
    #0  0x000000000051ed41 in DirectorTick() ()
    #1  0x0000000000410f7e in GameTick() ()
    #2  0x00000000004fedf1 in ParsePlayerInput() ()
    #3  0x000000000049231f in Mainloop() ()
    #4  0x0000000000493ad8 in main ()
  17. Dave

    Dave Member

    So, dear people from the future: this is what we've figured out so far.

    The 1.0.7 release in the humble bundle has several bugs that cause seemingly random crashes. Most occur when summoning certain monsters or changing levels, but other bugs also occur less frequently in other situations.

    There are two separate fixes which, combined, reduce the probability of crashes by a lot. The developers are also working on tracking down the remaining issues. Instructions to patch your Dredmor release with these two fixes are below.

    At this point, there isn't much value in posting more stack traces if they've been reported already, and no value in verbally abusing the developers on this thread. Seriously, that's just not cool, and also not a very good way to motivate them into hunting for bugs. If you know how to get stack traces and core dumps, and you find a crash whose stack trace doesn't appear in this thread, then by all means report it to give more data to the devs.

    To patch your 1.0.7 with the two fixes: instructions are in this thread, but for your convenience I've assembled the patches into a single archive. To patch, download http://natulte.net/dredmor-patched.tar.gz (it's just a combination of the fixed binaries and the fixed monDB) and unpack it with the command `sudo tar Pxvf path/to/dredmor-patched.tar.gz`. This will overwrite three files in your installed copy of Dredmor, and leave a copy of the original 1.0.7 files with .old suffixes. After that, run the game as you usually do.
  18. ZiNk

    ZiNk Member

    Segfaults happening randomly during gameplay on ubuntu 11.10, amd64, both patched and unpatched versions. Do I have to start a new game for the patches to work?
    Anyways, good luck to devs with hunting the bugs and big hearty thanks for bringing this game to linux users.
  19. Dimitri

    Dimitri Member

    Besides the patches, I have been running the game with the --debug-flag argument. This seems to have solved the issues for me.

    EDIT: Not needed, I think.
  20. Dave

    Dave Member

    I have no idea if existing savegames are affected. They shouldn't be for the monster summoning crashes (those were just filename issues), but for the rest, without the source code, your guess is as good as mine.