Windows 7 64 Bit: Cannot go up the stairs

Discussion in 'Bugs' started by Frelus, Aug 3, 2012.

  1. Auntyjack

    Auntyjack Member

    I've also got stair issues - needed to go back to level 1 to use the only shop so far. No stairs on level 2 go up anymore. If I load the autosave, I can't go back downstairs either, but if I load the save I made, I can go back down.
    The crashed when I first went downstairs from level 2 to 3, then I loaded from an autosave and continued.
    I tried out the hotfix, but lost all access to my subscribed mods (I'm using the Steam version of Dredmor). Had to revalidate and redownload to get mods back.
    Tried to attach my saves, but both the autosave folder and my current character folder are >3MB each after compression and wouldn't upload.
    Both the autosave and current save are missing all level.dat files above level 2.
  2. Having the same problem. DoD has been crashing on me semi-regularly (after around 8 - 9 hrs of play ). While in a wizardland, the game crashed. Reloaded from autosave, and was able to successfully complete the wizardland and others. When I came out, I was unable to move down from DL1. I had been to level 2 already. The save & autosave ( my autosaves have not been clearing properly either - semi-luckily :-D ) are included.

    Edit: To expain, whenever I attempt to go down stairs, it makes the sound effect and the animation, but it simply brings me back to the same floor (DL1). I have attempted to go down multiple stairways on the level, going into the pocket dimension and coming out. Going to a wizardland ... etc. I do understand / I saw that the save data for DL2 does not exist. I hope that these files help with debugging.

    Attached Files:

  3. heroicturtle

    heroicturtle Member

    Apart from one time where I needed to use the autosave (after saving and quitting in the regular dungeon), the run I have here didn't bug out at any time when I went into mysterious portals.

    Mind you I never ventured into any wizard addresses through the pocket dimension.

    What seemed to happen for me was that I found Dredmor, retreated to the floor above, went down a different staircase then break a statue - levelling me up. Once I broke the statue, the game crashed to the desktop.

    Then after booting the game up, I am now stuck on floor 14 unable to go up or down any staircases.

    EDIT: Tried travelling to Diggle Hell, got out alive, still couldn't ascend/descend staircases in the regular dungeon.

    I saw that this bug has something to do with missing dungeon floors so I was wondering:

    Is there a way to artificially insert floors into my game so that my character may have a go at beating up Dredmor?

    Attached Files:

  4. jackferd

    jackferd Member

    My variant of the bug seems even stranger. When I try to go up the stairs from Level 2, the game either crashes OR it takes me to the upper level with my stats and items that I had (I believe) when I first went down the stairs to Level 2.
  5. Daynab

    Daynab Community Moderator Staff Member

    I am told this issue is internally fixed and will be part of hotfix 10.