Windows 7 64 Bit: Cannot go up the stairs

Discussion in 'Bugs' started by Frelus, Aug 3, 2012.

  1. Frelus

    Frelus Member

    Hi guys,
    I wanted to go up the stairs for a staff I needed for crafting, but cannot go from level 3 to level 2.
    from level 5 to 4 to 3 worked.
    I tried 2 stairs already.
    The save is without mods and attached.
     

    Attached Files:

    • Amun.zip
      File size:
      278.1 KB
      Views:
      89
  2. Frelus

    Frelus Member

    Also, trying to go to the Wizardlands on DL 3 crashed my game.
     
  3. Frelus

    Frelus Member

    I cannot leave DL3 anymore, in any way.
    Dammit.
     
  4. Daynab

    Daynab Community Moderator Staff Member

    Finally a save for this issue, thank you!
     
  5. Nicholas

    Nicholas Technology Director Staff Member

    The reason that you can't go up the stairs is because the save game data for that level (level 2) is... just not there.

    Did you go through a Mysterious Portal, and did you do any Wizardlands?
     
  6. Frelus

    Frelus Member

    I went through a wizardland on DL 5 just before ascending. Remembering that because I found a Frutiful Staff recipe in the wiizardland, and needed a plain staff for crafting it.
    Also, as I said, I can neither leave the floor by stairs nor by PD at all, anymore.
    New save, because I do not know if that issue exists in the previous save, too, in this save.
     

    Attached Files:

  7. swanee

    swanee Member

    Me too. I am in level 1, can't go to level 2, or to pocket dim. (game crashes) . I previously used pocket dim between all levels, and vice versa. Didn't go to any other "levels" hinter whatchamacalits.
     
  8. Nicholas

    Nicholas Technology Director Staff Member

    Did you guys load from autosaves at any point and then save over your main game afterwards? Were these permadeath or non-permadeath?

    I can sort of see what's happening, but it's quite hard to track down.
     
  9. Frelus

    Frelus Member

    My example is non-PD, I think I loaded an autosave inbetween.
     
  10. Lightdud

    Lightdud Member

    I'm having the same problem now. I can re-load the hardsave and go up, but when I try to go down or stay on the level too far it crashes again.

    Here's my save as well.
     

    Attached Files:

  11. Kablooie

    Kablooie Member

    Augh!

    I had just found & crafted the Fruitful Staff (in the PD), and complete system crash. *sounds of a forehead hitting a desk repeatedly*

    After the crash, rebooted, got a lil' Steam piccie, did I want to upload today's save to the cloud (versus yesterday's save). Of course todays!

    Here's to hoping that bookcase holds the same recipe . . . . so far haven't found it again.


    DL 4. Don't have CotW yet, alas. I did climb one stairs to hit Brax's . I crashed in the PD, tho' (as stated above).

    EDIT: NooOoooOo! A Clockwork Launcher! Oh, you cruel beach, RNG!
     
  12. Nicholas

    Nicholas Technology Director Staff Member

    After some investigation: at present, I can do this using the autosave just in a vanilla fashion. Ryan's on it, and I'll have a swing at it tomorrow as well if need be.
     
  13. Galdrak

    Galdrak Member

    I am having the same issue with the addition that attempting to access the pocket dimension crashes the game to desktop. I have regular windows XP. Here is my save file.
     

    Attached Files:

  14. Frelus

    Frelus Member

    I do not know if that is related, but every new character I started had a mysterious portal in the starting room (the ones that take you to DL0)
     
  15. rydash

    rydash Member

    This was left in for testing purposes, and was not removed from the hotfix release. To encourage testing that the related bugs are fixed.
     
  16. Galdrak

    Galdrak Member

    I am going to try the hotfixes, as another thread seemed to indicate that would fix the issue.
     
  17. Petrograd

    Petrograd Member

    I'm having the same issue. I'm at level 3 currently. When I load the normal save I can go up to 1 and 2 and come back down. When I load the autosave, I'm entirely trapped on level 3.

    I've definately gone to the pocket dimension and done four Wizardlands. I think I did them all entering from levels 2 and 3, though. I don't remember if I used the pocket dimension on 4.

    Also I don't remmeber if I have permadeath on or not. I know I'm on easy difficulty.
     

    Attached Files:

  18. Fwiffo

    Fwiffo Member

    Any updates on this? I am having a similar problem.

    Cannot go down the stairs to the next DL from my savegame. I can go up, only tried 1 level.

    Playing with permadeath. I did have a crashed game, in which I then had to reload from an autosave, at one point (that autosave still exists, though I haven't tried re-using it). Also,I had been down to the next level of the dungeon at some previous point in the game.
     
  19. Daynab

    Daynab Community Moderator Staff Member

    You can try using the "-debug-flag" parameter and then pressing "p" in game to go down, otherwise keep your save until we have a stable hotfix for this issue.
     
  20. goombapatrol

    goombapatrol Member

    i'm not sure why, but over the last day i've ended up with 3 folders for the same save (titled 2easy.dredmorsave, 2easy_1.dredmorsave, and 2easy_2.dredmorsave) and 2 out of 3 of them are all having this very issue. upon opening up the folders, i noticed that in the faulty saves level0-3.dat are all missing :rolleyes:

    here's one of the buggy saves.
     

    Attached Files: