1.0 Unable to place modules

Discussion in 'Bugs' started by dtolman, Oct 29, 2016.

  1. dtolman

    dtolman Member

    I've run into an odd problem - several times now I've clicked on a ceramics workshop related module, gone to place it - and it doesn't show the overlay of the selected item (kiln, plinth, whatever).

    If I select any module after that, it brings up the module screen, but clicking on modules doesn't bring up the item on the screen for placement.

    Saving, exiting the game and reloading the save fixes the problem - for a while at least.
    This happened once to me on beta 55a as well.

    Attached Files:

    Exile likes this.
  2. Nicholas

    Nicholas Technology Director Staff Member


    a) is it always ceramics?
    b) what is your video card?
    c) can you send me a screenshot?
    Exile likes this.
  3. dtolman

    dtolman Member

    1) I've only noticed it after trying to place modules in my ceramics workshop.
    2) GTX 750 Ti
    3) I'll try and see what I can do, its not readily reproducible (I go in and it works for 30 minutes, then it happens. Or after 5 minutes sometimes).
    Exile likes this.
  4. dtolman

    dtolman Member

    Happened again - was placing Wooden Plynth when it occurred in an Overseer's residence. I alt-tabbed out for a minute to start up some video capture software (thanks Webex Meeting!), and it was working again when I went back in.
    Exile likes this.
  5. Trygve

    Trygve Member

    This is an old error actually. I've had it happen in my games since I began playing 6 weeks ago.

    What seems to happen is that the construction assignment gets interrupted for some reason, after the boxed item has been put on the floor in the middle of the ghost footprint of the object. After which work on these items aren't resumed, I've sometimes waited for an entire in-game week, and nothing has happened. I've tried to pause every other assignment than the construction assignments, from the assignment window, and while it shows up as an assignment, no one gets assigned to it.

    This has happened with a variety of worktables, weapon lockers, decorative items, kilns, desks, etc.

    I'm aware that items which have their access points completely blocked won't get installed, and the instances I've described aren't like that at all.

    In some cases I've tried to fix the problem by selling the boxed item, but in most cases the traders won't have them. I'm not even sure I can do that any more, with the trading system having been overhauled. The only fix I haven't tried yet, is demolishing the affected building, because when this error occur, I usually load an autosaved game and start over.

    PS. I think it's more likely to happen if I've paused the construction assignment in the assignment window. Constructions I've paused and unpaused, seems more likely to produce "locked" unbuilt objects. I haven't actively tried to reproduce this error, but this seems to be the leading cause of it.
    Last edited: Oct 31, 2016
    Exile likes this.