The Current Bugs Thread!

Discussion in 'Bugs' started by rydash, Aug 1, 2012.

  1. SkyMuffin

    SkyMuffin Member

    Minor bug: If you go into the Pocket Dimension while you are in a store, it gives you Pocket Dimension and dungeon music simultaneously.
  2. rydash

    rydash Member

    It's okay! And, well, that's bizarre - I'll put it on the list with a confirmation mark.
  3. Alistaire

    Alistaire Member

    If you go into the store during a monster zoo the music changes to store music and when you go out again it becomes normal music, without removing the monster zoo counter etc.
  4. Daynab

    Daynab Community Moderator Staff Member

    Oh, sorry, windows only I believe. The hotfix will be pushed to Steam and other places when official and finished.
  5. Aegho

    Aegho Member

    Deleting my save folder fixed it with test2 for me yesterday, installed 3 and 4 today, and it broke saving again.
    So I deleted again. Tested it. Got a working save. Then I moved over my mod folder and steam_workshop folder, enabled all my mods, and tested once again... and it was broken again.

    So it's either modding or the files in that folder existing that is the problem.

    EDIT: Removing the mod folder fixes it. I would hazard a guess that it's the whole "save mods into savefile" feature that is causing the problem!

    More EDIT: I moved a single mod (my own hermetic gadgetry) back, and activated it in the launcher, created a char that used it and could save. So the problem might be with specific mods, or with having too many...

    Even more EDIT: Added a whole bunch more mods... and broke saves again. It's definitely mod related.
  6. LionsDen

    LionsDen Member

    Ok, I'm not sure if this was supposed to be fixed or not but lucky find from the perception skill tree will still show and occasionally give me nothing.
  7. LionsDen

    LionsDen Member

    Now for the second bug I have seen.

    When starting a new character and choosing my skills the fist skill chosens picture will disappear but the skill is still there. To get this to happen, I choose two skills and then mouse over the second chosen skill on the bar. The first skills picture will disappear but it will still be there. It will return if I choose a third skill. Not sure what's causing this but I have had it happen at least twice.
  8. Daynab

    Daynab Community Moderator Staff Member

    Thanks for the research, this is useful.
  9. Aegho

    Aegho Member

    Been turning mods on and off for a bit... it looks more like it has to do with weight of mods than specific ones. So either a size problem, or a too many chefs problem(multiple sources of adding to the same thing).

    EDIT: Deleting is not necessary, turning the mods off in the launcher is sufficient. I've got all the mods back, and when I only activated my hermetic gadgetry it let me save again. However running just a fairly "bare bones" of mods (hermetic gadgetry, interior dredmorating, more dred, crafter's helper, needful things and my library teaser) still refuses to save, but disabling any one of them and keeping the rest seems to not fix it either.
  10. Daynab

    Daynab Community Moderator Staff Member

    Okay, that's very interesting. I wonder if everybody who had this issue was using mods though.
    I doubt it considering most were international players, some of which who can't use mods due to the old non-english filepath thing.
  11. DavidB1111

    DavidB1111 Member

    Hey, so if I add these hotfixes, what exactly do I have to do? If I can't carry over my save, which has never been hit by any inventory eating bug, I'll probably wait.
  12. Daynab

    Daynab Community Moderator Staff Member

    If you haven't had any inventory eating bugs, only install hotfix 3 (for the crashes and such). Just overwrite the current files with it.

    That said, you lose achievement tracking, workshop mods and save syncing for now with it.
  13. DavidB1111

    DavidB1111 Member

    That's fine. I haven't even been using the steam version for awhile. My computer is a pile of crap, so Steam seems to aggravate Dredmor for some reason, making it run slower.
  14. shaken

    shaken Member

    I've been playing with this version, and I've noticed some very strange things:

    1) Once, I stepped on a Satanic Displacement Glyph and it didn't port me anywhere, or it ported me to the same square. It played the porting sound.

    2) On every game that I start, I have the same starting room layout, with one mysterious portal. Items can differ. The layout can be seen here: StartRoomPortal.png

    3) I have tried one Wizardland, Binarpbagorng, which was confirmed to have 2 Artifact Rings (see post I did not receive the confirmed loot. What I received can be seen in the top row of my inventory (the robe to the left is not a named one) here: BinarpbagorngResult.png
    When I exited this Wizardland through the portal, I ended up in my Pocket Dimension, but when I exited that, the game started not responding. I closed the game, started it back up, and loaded a save that I created when I took this picture. When I exited through the portal this time, it played the Pocket Dimension music, but the screen went black. When I tried to move, the game immediately closed, it did not start not responding. I've attached the save file.

    EDIT: Someone suggested that having mods enabled may alter the Wizardlands loot, so I tried the same Wizardland mentioned above again by deleting the keys dat file. I made sure I had no mods enabled, but still ended up with the same set of Robes (the exact set, one regular robe, one with +1 Health Regen).

    Attached Files:

  15. DavidB1111

    DavidB1111 Member

    To be honest, I don't know if always getting the same loot is guaranteed or not. If it is supposed to be, it needs fixing then. Because it doesn't work. I've never gotten the same loot as others before.
  16. shaken

    shaken Member

  17. Aegho

    Aegho Member

    Somewhat embarassing to me... the inability to save, might for me be linked to the crafter's helper mod.
  18. Death

    Death Member

    Minor Bug: if you shift-click to drop the lutefisk cube while the lutefisk crafting window is open, the cube drops and the window stays there, allowing you to still convert things to lutefisk.
  19. Did you go into the Pocket Dimension or Wizardlands between getting the item and finding the shrine? That somehow/sometimes 'resets' the metadata on the item and makes the game think it's not the quest item the shrine is looking for. I think this is a known bug.
  20. Borodin

    Borodin Member

    Yes, I did. Thanks for pointing that out.

    Here's another bug--presumably known:

    Went through a large zoo on level 5, and got as reward a necklace rated at 4 stars--with only 1 on blocking for what it does. Something similar happened on level 3: got a ring rated at 3 stars, and only had 1 protection from asphyxiation. Both items were worth what you'd expect from their rating at the merchant, not according to what they actually did. I'm not complaining about the random factor in items received, but the ratings bearing no resemblance in these instances to the actual buff.