The Current Bugs Thread!

Discussion in 'Bugs' started by rydash, Aug 1, 2012.

  1. Gary Carves

    Gary Carves Member

    I had already tried uninstalling/reinstalling DoD, and I just updated my mouse drivers. It's a new (to me) mouse -- Microsoft Wireless Mobile Mouse 4000. It's still doing that. :(

    My Logitech mouse is now giving me the same problems. When I press CTRL to find the cursor, it says it's in the center of the screen even though I move my mouse around like crazy, and occasionally I simultaneously see the cursor moving (for split seconds) and also see the
    OmniaNigrum likes this.
  2. OmniaNigrum

    OmniaNigrum Member

    Is this happening in any other games? And have you tried running in a window mode instead of full screen? I had a similar problem in another game years ago that was fixed by not running it in full screen.
    Exile, Kazeto and Gary Carves like this.
  3. Gary Carves

    Gary Carves Member

    It's happening only on DoD, but I tried windowed mode. It works!

    Someone give that man a cookie!

    Attached Files:

    OmniaNigrum and Kazeto like this.
  4. destijl

    destijl Member

    I think I've encountered a modding bug: setting my mod's skillName to "discipleofcookie" prevented archetype levels from upgrading properly, but changing the skillName to "zodthemovie" fixed the issue. Not sure if it's an issue with name length or characters used, but it's definitely a problem of sorts. I've attached two mod zips if anyone wants to examine the differences themselves.

    Attached Files:

    OmniaNigrum and Kazeto like this.
  5. Vampyre

    Vampyre Member

    Alright I've made a mod and put it up on Steam Workshop. I've just realized this bug, the game will not complete a save when I have the mod activated on the launcher. Saves don't seem to be affected from hen I play without the mod. Could there be something wrong my files? I have all the XML validated and all, I really don't know what could be the cause. I haven't used any other mods so I have no clue if it's something wrong in-game or my mod in specific.
    OmniaNigrum likes this.
  6. OmniaNigrum

    OmniaNigrum Member

    This one?

    If so, you cannot have zips inside zips. Just zip the directory with the files in the subdirectories.

    For example:
    /Example Mod/items/Example Image.png
    /Example Mod/mod/mod.xml
    /Example Mod/mod/craftDB.xml
    /Example Mod/mod/itemDB.xml
    ...and so on.

    So you do not make an containing the images for your items. You just have it all as plain files in the respective subdirectories and zip the whole thing. In my example above you would zip /Example Mod/ and all files and subdirectories along with their files.
    Exile and Kazeto like this.
  7. Vampyre

    Vampyre Member

    I know that much. I already solved that issue a while back. Whatever I am encountering it is not due to that problem I used to have.
    OmniaNigrum likes this.
  8. OmniaNigrum

    OmniaNigrum Member

    Alright, please make a thread for your mod and post it so we can see if we can find a problem.
    Exile, Kazeto and Vampyre like this.
  9. Gary Carves

    Gary Carves Member

    Hmm. Now that I play the game not-full-screen, I cannot see the skill bar, etc. Any ideas on how to make full screen work?
    OmniaNigrum likes this.
  10. rydash

    rydash Member

    This is a neat one. Llcorp2 identified this once before, with skillNames that began with 'A" for some reason. So more reports of this are useful, although I unfortunately don't have a solution for ya right now. :/
    OmniaNigrum and Kazeto like this.
  11. OmniaNigrum

    OmniaNigrum Member

    Just make sure it is smaller that your screen and it should work fine. Remember that the "Windows bar" takes some room, just like the borders of the window itself.

    For example, running at 1920 x 1080 on a monitor of the same resolution will always cut off part of the game to fit. Just use the next size down and it should work fine.
    Exile, Talow and Kazeto like this.
  12. ateaktree

    ateaktree Member

    Does the 'vanishing stat' bug on OS X still exist? I have a game where I appear to have much less armor absorption and melee power than I should from my gear and buffs on 1.1.4 on OS X.
    OmniaNigrum likes this.
  13. rydash

    rydash Member

    I'd say it's pretty likely that that problem is still occurring. Not that I know what could be provided to help quash this particular bug, but, uh...

    that's not good. :/
    OmniaNigrum and Kazeto like this.
  14. Baarogue

    Baarogue Member

    I don't see it listed in the summary posts so here goes: Occasionally the Pyramid Scheme buff stops generating Zorkmids before expiring. I haven't been able to figure out what causes it. It's frequent enough to be irritating but not consistent enough that I can nail down a trigger. It even happened once when I was just walking down a corridor and not interacting with anything.

    I'm not sure if it'll help, but my skill picks at the time were Polearms, Astrology, Ley Walker, Assassination, Smithing, Bankster, and Egyptian Magic.
    OmniaNigrum likes this.
  15. Phantomite

    Phantomite Member

    Please fix the Toxic cannister. It makes my game crash often, especially if you throw it in a monster zoo. It's very annoying.
    OmniaNigrum likes this.
  16. 7Soul

    7Soul Member

    Fix custom sounds in mods! (I know this will probably never be fixed T_T)
    Alistaire and OmniaNigrum like this.
  17. RunoxTheFox

    RunoxTheFox Member

    Well... I didn't see this in the known bugs or anything, so I'll post it here. I don't know if this is the place to post it, but I got a graphical bug/glitch that literally just happened to me today when I started up Dredmor. It's a black bar that takes up a good amount of space on the top of the screen. I have no clue how it got there, and it looked fine an hour ago when I was playing! I don't think it has anything to do with my CPU specs, so I'll hold those unless needed. It's weird, because the mini-map is still overlapping it. The text for damage and whatnot still shows up in the black box area too, it just seems to be blocking off the actual gameplay, not the UI. Also, I read around and saw it was a problem with resolution, but this is not the case, as I never have changed my resolution past what it was the first time I started up Dredmor, and it only started happening an hour ago... but if it helps, I play in 1440x900, windowed.

    Any ideas on what it could be, guys?? D: Picture in the spoiler so it wouldn't take up half the page. Thanks in advance!

    Last edited: Jan 20, 2014
  18. OmniaNigrum

    OmniaNigrum Member

    Does your vision range extent beyond that area? If not then that is why it is black. It is the border of your vision.
    Exile and Kazeto like this.
  19. Loerwyn

    Loerwyn Member

    ON, did you read the description of the problem? That is *not* an edge of the range issue. It looks like something has caused the top, I dunno, 10% of the game area to turn black whilst the UI renders correctly.

    Have you tried turning windowed off, running full screen, and then trying windowed again? Or even alt+tab out of the game and back in?
    OmniaNigrum and Kazeto like this.
  20. OmniaNigrum

    OmniaNigrum Member

    I did read it. I just came to a different conclusion about what could cause it. I could be wrong too. I will wait to hear from RunoxTheFox.
    Exile and Kazeto like this.