The Current Bugs Thread!

Discussion in 'Bugs' started by rydash, Aug 1, 2012.

  1. rydash

    rydash Member

    XML seems to indicate percent="50" for the Diggle Nog Effect. Not sure if that's new, but that's probably the reason why. :p
  2. Kazeto

    Kazeto Member

    It's not new, I can assure you of that.
  3. SkyMuffin

    SkyMuffin Member

    ah, i was not aware that it was only a chance to morph. thanks!
  4. Zalminen

    Zalminen Member

    Small typo: Monofiliment Sword should probably be Monofilament Sword, unless the odd spelling is intentional or a reference to something I'm not aware of.
  5. The Achievement "Doctor Strangelove" didn't fire for me when I used the bomb granted by the last skill in the Communist Tree. Unsure if there are other required conditions for the achievement to trigger, but might be a bug.
  6. yog-sothoth

    yog-sothoth Member

    Hi all, I read the first page and some posts, I can be wrong but I didn't see my bug.
    I play to the game with the 3 DLC on steam (no hotfix, no other mods), windows 7 64 bits.

    I had a trouble with a character with my hit points, each time the game autosaved, i was loosing an amount of hit points.
    This amount grew up with my levels. I finished the game and killed Dredmor (hurray).

    I checked game files with steam and it says that all is OK, but now with a new character i have the same bug again.
    It seems that it doesn't occur on low levels, now i have 101 hit points and since that i m loosing 1 hit point eacht time the game autosaved my game.
    It's just the beginning my last character started like that, and the amount of hit points i'm loosing will grew up with my levels.

    Thank you for your help.
  7. Yog, that sounds familiar. There was/is a bug where after an autosave, all HP/MP bonuses granted from primary stat boosts would be "reset." So, if you had 20 bonus HP from :burliness: items, you would have to regen them every autosave.

    Does that sound like your issue? If it is, at least the Devs are aware of the issue and have it on the list for fixing.
  8. yog-sothoth

    yog-sothoth Member

    Yes The Apprentice, it's exactly my bug. It wasn't so annoying with my vampire/fleshsmiting but it will be harder with my new one.
    Thank you for your answer and I'm glad that the devs know about that.
  9. MaddMaxx

    MaddMaxx Member

    Yeah i have a bug where the game doesn't appear in my steam library. i bought the game and played it. even unlock some achieves.
    I stopped playing for a bit and now the game is gone. I still have it installed but steam says i don't own the game. i tried talking to steam but they keep giving me the same run around.
  10. rydash

    rydash Member

    Thaaaaaat's different. Not really sure how to approach this one.
  11. OmniaNigrum

    OmniaNigrum Member

    Sadly this is a Steam side issue only. If you can show any sort of clear proof to the devs at Gaslamp, I am willing to bet they can help you out even if Steam is only being bitchy about it. And provided they confirm you own the game, I can make a link that will be private and only for you that contains the game and expansions you own updated every time there is a patch. (I am not sure they would or even *Can* approve of this, but the point is that I do not think they will leave you hanging.)

    Check your e-mails and find the invoice(s) for your copy of the game. Do not send it to me. Send it to Daynab/Nicholas. Either of them should be able to help you get what you paid for. I am volunteering to help until they get their side of the store working properly.
    Exile likes this.
  12. Daynab

    Daynab Community Moderator Staff Member

    I have no idea what might be going on there, but I suggest you make a backup of the game folder just in case. You can play it without steam regardless.
  13. j3st3r

    j3st3r Member

    This must have been mentioned sometime before:

    If you use an effect that can move immovable objects (e.g. Psychokinetic Shove) to a Satanic Displacement Glyph, it'll work, but when you use the counterpart glyph, it'll teleport you to the original spot (now void of the glyph)

    Edit: Just noticed that similar things happen with traps; I moved an Inconspicuous Pressure Plate using Psychokinetic Shove to a different location and the bolt thrower on the wall also moved, even though it was well beyond my spells reach.
  14. SkyMuffin

    SkyMuffin Member

    Issue with steam overlay: about 50% of the time, when i open up the overlay and then return to the game, my game will be totally unresponsive. Animations still work but all keyboard and mouse input does nothing. I can fix this by reopening the overlay and closing it a couple of times.

    (all expansions, latest version, windows 7 64bit, steam)
  15. DavidB1111

    DavidB1111 Member

    Yes, Jester, that's a well known bug, and probably very very low on the list of bugs they're going to fix.
  16. Loerwyn

    Loerwyn Member

    I had a workaround for this somewhere. Lemme dig it out.

    Aha. Try this next time it happens.
  17. SkyMuffin

    SkyMuffin Member

    I am pretty sure the "High Cholesterol" achievement is broken. I was grinding with werediggle to get eggs and ate 50 or so, but now it's two hours later and it still says I've only eaten 1 on steam. meanwhile, the omlette achievement worked flawlessly and I got it immediately upon completing the goal.

    I stand corrected. It's properly updated now. Guess Steam is just fickle about updating achievement progress.
    OmniaNigrum likes this.
  18. Archos

    Archos Member

    Well, not exactly a bug, but my game seems to be lagging a bit after I spend some time playing, since last update. Dunno what exactly is causing it, but it seems to happen after 3, 4 floors. It's not some hard lag, just a staggering... but it's kinda annoying. It lags on menus too, specially on starting menus (noticeable by mouse cursor staggering).

    Maybe too much objects on memory, or a video problem? Game starts spending about 150mb from RAM, but after a few minutes it's on 500~600. I even saw it on almost 1gb one day.

    I'm running it on windows 7 64bits, about 4gb ram 1333, i7 Q720 1.6ghz and AMD radeon HD5650 (it's a notebook), via steam. Display resolution is 1920x1080 (native resolution), smooth scalling and fullscreen options are set. Also, -opengl is set on launching option. Reducing to 1080x720 made it better.

    Dunno if this is expected or not and if my system is not enough, but just reporting, anyway :) If there's nothing wrong at all, i'll get used to play on a lower resolution.
    OmniaNigrum likes this.
  19. SkyMuffin

    SkyMuffin Member

    I had this problem yesterday, after playing for two or three hours straight haha. My memory usage has been known to get up to 1,500 or even more at times (highest i've seen is 1,850), but it runs well even with that much. Anyway, I had this stuttering lag for a minute or two, and then it seemed to disappear and everything ran smoothly after. Very strange.

    Edit: Also, I checked my memory after this stuttering and it was at 600.

    (here's my laptop if you need specs: Steam, Windows 7 64bit, steam overlay on.
    Archos and OmniaNigrum like this.
  20. darius404

    darius404 Member

    I had some stuttering like this yesterday, where it almost seems like very small jumps of lag, one right after another? Like everything on the screen was just fidgeting for a second or two? But it was during a different Steam game, Cthulhu Saves the World.