The Current Bugs Thread!

Discussion in 'Bugs' started by rydash, Aug 1, 2012.

  1. I'm noticing, with a mod, that "taxa" tags aren't seeming to work on triggers. Which may be me misinterpretting things (or a problem with my mod; though I've double checked things and don't see any obvious reason why it would trigger on any taxa???), but if this is a bug it definitely effects core skills as well.
  2. Kror

    Kror Member

    So it is intended? Because it still doesn't have that. How do you know it is intended? :O
  3. rydash

    rydash Member

    Because I am a dumb and thought it was granting it - only to now realize I had a piece of equipment granting 1 Acidic Resistance at the same time.

  4. LionsDen

    LionsDen Member

    Here is a bug I don't think has been reported. I opened a monster zoo and proceeded to kill all of the monsters. When I was done, it said there were 10 monsters left and there were no other blue areas on the map. I did not use anything that had knockback and searched the entire surrounding area and found monsters and killed them but none affected the counter in any way. The only thing that I can figure that happened is that I used the spell Polymorphic Injunction against the batties to create more powerful creatures to kill for experience points. Also, I was playing vegan and wanted to be able to hit them in melee if I wished. I was on Dungeon Level 2 with Windows XP on the Steam version of the game. I was not using the hotfixes and the only mod I had running was my Needful Things mod. The only thing I can figure is that Polymorphic Injunction doesn't make the resulting creature part of the zoo anymore so when it is killed, the count isn't decremented. Be careful of using this spell in zoos until a fix is out.
  5. Daynab

    Daynab Community Moderator Staff Member

    Are you using the latest Hotfix, LionsDen? thought that was fixed.
  6. DavidB1111

    DavidB1111 Member

    I think he's not using any hotfixes, Daynab.
  7. LionsDen

    LionsDen Member

    No, I wasn't using the hotfixes. I hadn't heard of this problem but if it's already fixed in the patch coming out, then that is great. :)
  8. Racer Delux

    Racer Delux Member

    Has the portal glitch been fixed yet? It is crossed off the front page, but I have run into the issue trying to go through exit portal, crash to desktop, skipping any "this program has stopped" dialog.
  9. SkyMuffin

    SkyMuffin Member

    The patch is still impending as of now. Based on their twitter it sounds like they are still working out some issues.

    If you use the hotfix on pg 1, however, the portal issue is definitely fixed. I've tried it myself.
  10. rydash

    rydash Member

    Ohhhhhh man. Look how clean that list is now. Look at it.

    Anyway, I still need the green checkmark things confirmed or denied. I'll do what I can, but again, the modding/XML specific ones are out of my league.

    A legacy list will be preserved in the Bug Sources document, in case you want to go see what was wrong with 1.1.1, I guess.

    Finally, the hotfix_final_v5 executable will be on the final post of the three, just in case there would be some non-Steam PC folk who still need it.
  11. echoMateria

    echoMateria Member

    Steam update broke my save, restoring the hotfix helped me continue. If anyone else encounters the same problem now you know what to do.
  12. New version of lucky pick doesn't work on treasure chests. (The text only mentions doors though? So maybe its intended, although if so it takes away half the point of the skill...)
  13. lccorp2

    lccorp2 Member

    Will confirm that certain mods are still crashing the publisher after the validation step.
  14. DavidB1111

    DavidB1111 Member

    Oye. How do they mess that up? :(
    That can't be intended.
    Not only does that break the point of the skill, doors costing health to break down isn't as bad as losing an item forever in a chest.
    Seriously, that's just mean if it's not a bug.
  15. lccorp2

    lccorp2 Member

    Seemingly random crashing when generating a dungeon level.

    Crash dump here:

    Attached Files:

  16. Clupus

    Clupus Member

    Steam workshop does not work in this patch. Even after reinstalling and wiping steam workshop folder.
  17. SkyMuffin

    SkyMuffin Member

    Vampire lifesteal is not working on ravens in 1.1.12.
    okay i could be wrong. testing again a few times to make sure
  18. Musaab

    Musaab Member

    I found a major bug. With the Mists of the Corsair ability from the Piracy tree, when you activate it, the description for the Mists of the Corsair in the top left (the active effects area) is missing the first 'T' of the description for the word "The..." in the "The Mists of the Corsair serve to hide all manner of piratical activity..."
  19. Jacq

    Jacq Member

    I don't normally play Vegan, so I'm not sure if this is mostly intended behaviour or a bug.

    My befriended diggle is stupid. He has two diggles on two sides of him and a Batty 2 squares away (across some water) and he doesn't attack anything. He was also standing on the same space as a 1st floor Raven (pretty sure that's a bug) and neither of them could move. I had to attack the raven (and incur vegan penalties) before he could move again.
  20. Demented Mind

    Demented Mind Member

    Can anyone explain to me what is a hotfix? I think I need to do a hotfix. I believe that steam client updates has caused me issues. All of my current burglary skills disappeared. I tried re-loading saves, but it won't. When I leveled, I was hoping the entire bar of burglary skills appeared, but after putting a point in burglary, I only get the latest burglary skill, while all else remains gone. So strange.

    Can anyone explain about hotfix, I need to do it.