Windows XP Steam Workshop makes the mod launcher hang

Discussion in 'Bugs' started by banjo2E, Jun 6, 2012.

  1. banjo2E

    banjo2E Member

    I copied all of my old mods to another directory on my system, and subscribed to the Steam Workshop versions of everything I had installed.

    Unfortunately, whenever I launch the game, it hangs. By which I mean, I open the mod loader, the game informs me that it's checking my subscription status (or, more rarely, downloading my subscriptions, if I let it sit there long enough) and then proceeds to take up all of my CPU time without doing very much of anything.

    ...Why exactly would a download cause that much resource usage?

    Edit: It seems there's some sort of CPU problem with either my system or the game in general, if not both. I'm getting massively stuttering audio, getting worse over time, and before I quit the game my fans were spinning at maximum (loud, oh-snap-we're-overheating) speed for over ten seconds.

    Since literally everyone who isn't me uses multiple cores these days, mind checking to make sure there isn't anything that's trying to force dual-core processing patterns?
  2. Daynab

    Daynab Community Moderator Staff Member

    What are your system specs?
  3. banjo2E

    banjo2E Member

    Hope dxdiag's good enough.

    Attached Files:

  4. banjo2E

    banjo2E Member

    Gonna bump this real quick.

    I've done some testing, and even when I'm unsubscribed from the Steam workshop entirely, and have no mods installed, the launcher still consumes an average of 60% CPU just sitting there. I'm honestly afraid to attempt to find out if the game itself will fare any better than this, especially considering that the launcher and the game are the same process.
  5. Daynab

    Daynab Community Moderator Staff Member

    Oh, apologies. I must've lost this thread somewhere. Your specs are a bit on the low end and if my calculations are correct it seems like your cpu usage is similar to mine.

    Still not sure what causes this freeze though. Have you tried unsubscribing to everything, running the game with -nukesteamcloud once, then try to subscribe back one at a time?
  6. banjo2E

    banjo2E Member

    ...there's a command for killing the cloud?

    gaslamp, you are hero.

    I'm gonna try re-running with all the mods I have installed; I downloaded them from the forums so I don't have to do any cloud stuff, the only one on the cloud that I'm missing is a lockpick-crafting mod. And the cloud seems to be really bad with multiple mods; I was subscribed to a bunch of stuff and it took upwards of five minutes last time I ran with all of the subscriptions checked before it even moved off the "checking subscriptions" step.

    It wasn't a total freeze, it was more like just really really bad lag in general. We're talking bad enough for the sound to be stuttering while I was just standing around. I was still able to access the menus and everything, and quit normally and such. I distinctly remember not having that much lag the last time I played, however. Which, to be fair, was like right after the sound engine patch came out.

    It's possible that this is in part due to my modsplosion tendencies. I've got like, ten mods installed right now.
  7. banjo2E

    banjo2E Member

    Well, the results (whilst running mods) are in: I get high stutter at odd times (like, making my fifth trip across a room that I've already fully explored odd) and the sound is horribly unstable. But, otherwise, the game's playable.

    I just wish I knew why this was happening. Apart from, y'know, being a single-core user in this day and age.
  8. FaxCelestis

    FaxCelestis Will Mod for Digglebucks

    Sounds like it's jittering when deciding to spawn new monsters.
  9. banjo2E

    banjo2E Member

    Nah, I've done more checking, and it seems as though avoiding the Steam workshop for everything that's published elsewhere actually does fix most things. The sound problems seem to be caused by....I'm not sure, but I've noticed both this game and Youtube videos getting crazy, TV-static-esque sound distortions seemingly at random, so I think maybe it's actually my sound card starting to die, or something. The random lag? I'm pretty sure at this point that I was talking about autosaves. :V