Stack of Rings Equippable

Discussion in 'Bugs' started by Loerwyn, Apr 6, 2012.

  1. Loerwyn

    Loerwyn Member

    Found this out by accident.

    If you have a stack of rings (e.g. Copper Rings), you can equip the stack, but you only get the benefit of one. However, the stack indicator (i.e. # of items in the stack) does not display in the equipment screen.
  2. QuickForYa

    QuickForYa Member

    not just that but also if you make new wands of the same type those too become stackable hate this bug.
  3. HowlingLotus

    HowlingLotus Member

    When I was going for the I Didn't Ask For This achievement the other day my axes stacked together after I crafted them and hit sort. Never could get them to unstack even when equipping.
  4. banjo2E

    banjo2E Member

    Hold down alt when clicking on stacked items to lift them apart from each other.
  5. HowlingLotus

    HowlingLotus Member

    I know that and I tried. What I'm saying is it wouldn't physically let me. At first after I crafted them they were separated. Once my inventory got full and I hit Sort they stacked. I tried multiple times to separate in inventory, by equipping, dropping and picking back up; but to no avail. I haven't crafted two of any other weapons at the same time so I don't know if this is a crafting bug or just my game acting funny as it does not do this with picked up items (I can have 10 of those new bows and staffs and they don't stack when I hit Sort).
  6. Lorrelian

    Lorrelian Member

    I've had this happen a few times with axes and swords (never tried it with armor.) I was usually able to separate them by alt-clicking, though. But yeah, crafting and stacking is kind of wonky. I try not to craft duplicates of items I already have in inventory. It's not game breaking, just a little annoying. I think if you put the item on the floor then pick it up, this behavior will stop.
  7. Daynab

    Daynab Community Moderator Staff Member

    We really gotta get this fixed.