So... my game just got ruined.

Discussion in 'Dungeons of Dredmor General' started by Volkamar, Aug 14, 2012.

  1. Volkamar

    Volkamar Member

    This is not how I would have liked my first post to turn out, but, such is life I guess.

    Ok, so I fell for that "Save Game" glitch of whatever the hell it was. Basically I had just started going through Floor 8, I had some really great equipment, Full Clockwork Armour with an Emerald Sword and Artifact Godewijn and some twin Relfective Shields with over 20 Voltiac Resistance Each, and had nearly every recipe in the game (no joke I really did, I found a ton of Bookcases for some reason). I had leveled up and got the Ancient Kronian Ritual, so I did what anyone would do, and go back up the floors and renew each Anvil for my awesome Ring I had got in one of the Wizardlands. I went up to Floor 4, nothing unusual so far, used the only anvil that was there again and went to go up to Floor 3. Now going up the Stairs, apparently, did nothing. It just teleported back to Floor 4 again. At first I thought "Huh... maybe something got wedged in the Doorway or something." and tried another stairway, again, nothing. So I Saved and Quit, restarted Dredmor, and reloaded my save and tried again, nada. So I thought, ah smeg it, and decided to just carry on.

    But when I went to Floor 5, something was amiss, half the floor had not been explored when I knew for a fact that I had overturned every last nook and cranny of that place. I checked my gear, and my heart sank... all the equipment and artifacts I had gotten were gone. In it's place were all the medicore gear I had before I had gotten the necessary tools to make my Clockwork Armour and the Recipes for them. My Ring I had been sending through Krong has been reverted back to it's original stats. I no longer had either of my Mirror Shields OR my Magnetronic Set. My level had been reduced to when I was starting Floor 5. I literally just quit the game at the moment and I'm now dreading ever touching it again in case I get messed about like that again. It was a run where, had I not had the bug occur, I could of had Dredmor easily. I had enough Bolts that I could just go around with my Dual Reflect Shield and Rail Launcher and just destroyed everything in combination with my Rogue Scientist and Clockwork Knight abilities. Not to mention now all the Wizardlands I visited I now cannot go back into... 20+ Hours of hard work, careful planning, and effort... gone, not to a battle with Dredmor or a tough boss, but a stupid glitch.

    So my question is three fold...

    1) I ask in vain most likely, but Is there a way to restore a previous Save after loading it?
    2) What do I now? At this point the idea of playing again makes me stomach turn, especially when I had one of those "One in a Million" runs where everything was going pretty much as perfect as they could do. Is there anyway I can get myself out of this rut and maybe get to a point where I can start playing again? Or does this kind of thing pretty much spell the end for someone when it comes to playing Dredmor?
    3) Do Wizardlands ever reset after using them? Is there a way to do so at all, either within the game or outside of it? I'd hate to end up with my next character be so severely handicapped because all the Wizardlands I know of and had been recommended by other players and friends who also play.

    BONUS QUESTION: I was using Dual Wielding, Archeology, Smiting, Tinkering, Alchemy, Clockwork Knight, and Rogue Scientist. Archeology was what allowed me to get as much experience as I did in the end, however, Dual Wielding is something I wasn't overly sure on. Sure it allowed me to pretty much clobber everything in my path, but toward the middle of the game, I was finding myself using the Crossbow more often once I had crafted it. Is it still work going for just to get through the early game? Or is there another ability that might be more worth my while out there?

    Thanks to anyone who spares a moment of their time to read and reply to this.
  2. onesandzeroes

    onesandzeroes Member

    As much as it sucks, things are always a bit shaky after a major patch/content update. Your best option might be to take a break for a couple of weeks until the devs have had a chance to fix some of the bugs, then come back with a different build.
  3. Daynab

    Daynab Community Moderator Staff Member

  4. DuckAndCower

    DuckAndCower Member

    You can reset your wizardlands by deleting some file, but I can't remember which one. It's mentioned once or twice in the CotW forum.