Linux 32-bit Saved games broken

Discussion in 'Bugs' started by Eddward, Jan 2, 2012.

  1. Eddward

    Eddward Member

    I don't know if this is just Linux, but there was an update available on Desura today. I installed it and now when I try to load any existing saved game I get a segfault. It starts loading the games and displays a bunch of "creating a Splat" type messages and then just dies.

    I was able to play through all of the tutorials without a problem. The version that was on Desura yesterday worked.

    Let me know what kind of info to gather. I'm fine running straces, debuggers and whatnot.

    I created a new game, saved immediately and was able to reload it. I hope the update didn't just break all my old games.
  2. cyb3rkn19ht

    cyb3rkn19ht Member

    I have a similar problem.

    I can't load a save on Floor 2. Also one save over wrote another one.

    When I try to load the floor 2 save I get a seg fault.

    I had two saves Killer and Killer2, I was playing with skill builds. Killer2 over wrote Killer.

    I am playing Dredmor 1.0.9 with Desura on Ubuntu 11.10. I tried to find a log but was unable to locate any.

    Here is a gdb backtrace and disassemble of the seg fault.

    (gdb) bt
    #0  0x080af9d3 in Level::Load(_IO_FILE*) ()
    #1  0x080c2f02 in LoadGame(char const*) ()
    #2  0x080f0342 in PlayGameWithLoadFilename(std::string) ()
    #3  0x080f2cff in main ()
    (gdb) disassemble 0x080af9d1,+40
    Dump of assembler code from 0x80af9d1 to 0x80af9f9:
      0x080af9d1 <_ZN5Level4LoadEP8_IO_FILE+913>:    pop    %esi
      0x080af9d2 <_ZN5Level4LoadEP8_IO_FILE+914>:    inc    %esp
    => 0x080af9d3 <_ZN5Level4LoadEP8_IO_FILE+915>:    mov    0x48(%edx),%eax
      0x080af9d6 <_ZN5Level4LoadEP8_IO_FILE+918>:    imul  0x40(%esi),%ebx
      0x080af9da <_ZN5Level4LoadEP8_IO_FILE+922>:    mov    %eax,0x48(%esi)
      0x080af9dd <_ZN5Level4LoadEP8_IO_FILE+925>:    imul  $0xb,%ebx,%eax
      0x080af9e0 <_ZN5Level4LoadEP8_IO_FILE+928>:    lea    0x4(,%eax,4),%eax
      0x080af9e7 <_ZN5Level4LoadEP8_IO_FILE+935>:    mov    %eax,(%esp)
      0x080af9ea <_ZN5Level4LoadEP8_IO_FILE+938>:    call  0x804bfdc <_Znaj@plt>
      0x080af9ef <_ZN5Level4LoadEP8_IO_FILE+943>:    lea    0x4(%eax),%edi
      0x080af9f2 <_ZN5Level4LoadEP8_IO_FILE+946>:    xor    %edx,%edx
      0x080af9f4 <_ZN5Level4LoadEP8_IO_FILE+948>:    mov    %ebx,(%eax)
      0x080af9f6 <_ZN5Level4LoadEP8_IO_FILE+950>:    mov    %edi,%eax
      0x080af9f8 <_ZN5Level4LoadEP8_IO_FILE+952>:    cmp    %edx,%ebx
    End of assembler dump.
  3. Lefty

    Lefty Member

    Having the same problem. Hate my first post after signing on to be a complaint as I love the game, especially as I only found out the bug after signing up. But I figure the sooner it gets fixed, the better for all. comes up with this at the end when running by terminal
    /home/david/Games/desura/common/dungeons-of-dredmor/ line 21: 24089 Segmentation fault LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$LIB_PATH $BIN_PATH $ARGS $@

    Might be an idea for people to back up their save folders temporarily.

    Loving the game despite the technical hitches. Hope you can get RotDG on Desura soon when the game is more stable again so I can tell you to shut up and take my money.

    Edit: I am deleting a bit of what I wrote earlier - with all the confusion and messing around while trying to work out what was going on, I think I may have confused one save for another, and tested on my backup game and not the updated without realising (too many tabs open) so some of what I reported was not reliable. General loadsave.dat messing up in essance.
  4. Horst JENS

    Horst JENS Member

    same problem here... using Dungeons of Dredmor on Ubuntu 11.10, i can not load a savegame from 2nd floor (1.0.9 patch) ... game crashes with segfault

    save game from first floor can load and play fine
  5. Eddward

    Eddward Member

    I see now that there is a 64bit version of this bug. One of these threads should probably be closed out and the other just marked generic Linux.

    ...Actually, digging through some blog entries, I see this is a known problem with saves generated by 1.0.8 for all platforms and there's a (try at your own risk) test fix out for Windows and matching fixes in the pipe for the rest. Cool.
  6. Lefty

    Lefty Member

    @Eddward, the bug you are referring to was sorted with the 1.0.9B patch, this is a reappearance.
    The desura changelog for Jan 2 only says: Update to 1.0.9. Somebody said it was the same file as the sept 23 one, so its possible the was a a bit of a SNAFU with desura. Not sure myself the best way to find out, so ill leave for others to check.

    Probably should merge the threads though as you said.
  7. Darksoul71

    Darksoul71 Member

    @Lefty: Indeed, the patch I applied yesterday to DoD via Desura was labeled as version 1.09. So either the version is incorrect or someone uploaded the wrong version. I think this issue with 1.08 savegames applies both to Lin32 and Lin64. I attached a "corrupt" 1.08 Linux save game to one of my posts in the other thread which makes my Desura version of DoD go crash-boom-bang ! :eek:

    The Windows version on the other hand loads it perfectly. Well, I am still unsure if the Gaslamp people left us Linux guys alone in the freezing rain (esp. since they only mention MacOS and Win updates in the latest blog entry) or if the working Linux patch is still stuck in the pipeline somewhere between Gaslamp and Desura. Both variants are not pleasing to Linux folks, wouldn't one agree ? :D
  8. Lefty

    Lefty Member

    Fix just hit Desura. Not been able to test 64 bit version,but 32 bit version seems ok so far.
    Changelog said something about permissions on Desura, but it disappeared the second time I veiwed it so can't copy.
    Showing version 1.0.9.BR2 now.

    Seems like SNAFU with desura as I said, whether this is because of desua's slightly buggy client, desuras staff, or gaslamps grappling with its developers tools doesn't matter, the bump in the road has been straightened out, just the mountains up ahead to worry about.

    What you said about being left out to dry Darksoul, I agree that it would be nice if they would acknowledge Linux problems more in the blogs so we know they are working on the problem. Never got the impression that was being ignored though, just slightly lower priority than getting windows and Mac working, which you can understand when you consider the user base of steam vs desua. Still would have been one of top priorities getting linux working. But whats one more days waiting - in a bigger studio the wait would have been longer.

    Personally I prefer a quick turnaround of hotfixes and occasional hiccups than long waits. But then like a lot of DoD addicts here, I can't wait for my fix too long (and always keep a stash *cough* backup handy) :)
  9. Benanov

    Benanov Member

    HIB version seems to have this too. 1.0.7 was so bad I couldn't progress past the second floor (guaranteed segfault somewhere in the 3rd floor load process, but not always in the same place).
  10. Eddward

    Eddward Member

    I just pulled today's update on Desura and my saved games work again. I'm happy. Thanks!

    Although I wish posts were a little clearer about fixes also being in the pipe for Linux, I assumed they were anyway. I know Desura for Linux still has some issues and Gas Lamp are a smaller vendor. Plus we were coming off the holiday. I guess I'm just not that upset.

    For me, I guess the only thing I could complain about is that the page for Dungeons of Dredmor has links to twitter, facebook, the blog and other stuff, but not the forums. I didn't know there was a forum for a while.
  11. Darksoul71

    Darksoul71 Member

    Well, the folks from Gas Lamp seem to be real enthusiasts for me and I guess no one really is upset if they spent a few days with their beloved ones. It is more that I wish they do better testing next time instead of hushing out a rapid-fire series of patches. I rather wait for two, three weeks for a patch than having just a patch-party as before Christmas :)

    Hopefully they communicate Linux patches better the next time and do not only talk about Windows and MacOS although I understand that we are only a small part of the DoD community compared to the later OS.

    Edit: Oh yeah, and it would be nice if there is a more centralized communication. No matter if they use Twitter, a blog, Facebook, whatever. All those channels should show the same informations.
  12. Horst JENS

    Horst JENS Member

    i have the feeling that customoers of the humble introversion bundle (Linux) are worse off than Desura Linux customers. How do i (as a humble introversion bundle customer) get notified about new linux patches ? as for now i check the humble introversion bundle website each week and compare the zip file version.
  13. Daynab

    Daynab Community Moderator Staff Member

    From what I understand it's not trivial to update a HIB version but they usually did it at the same time or some days after Desura. But I don't think there's any way to get notified beyond following the blog.
  14. I'm seeing this bug in the 64-bit version of 1.0.9 from the HIB loading a saved game from level 1 (attached).

    Attached Files:

  15. Kazeto

    Kazeto Member

    I might be mistaken, but I think it's possible to get a Desura code for DoD from Humble Bundle.
    I actually got a Steam code the same way, to be able to buy the DLC.
  16. Horst JENS

    Horst JENS Member

    yes, i have a desura key for DoD now (i was not aware of that before). At the moment i try to figure out how to enter desura key on the desura website so that desura understand that i own the game already.

    Solved: there was an instruction link on the humble bundle website
  17. Bob Thibodau

    Bob Thibodau Member

    Desura won't install for me, so that's not an option. When will the Humble version be updated? I can't see what the holdup is.