Rod Charge Bug?

Discussion in 'Bugs' started by Lordxorn, Jul 26, 2011.

  1. Lordxorn

    Lordxorn Member

    I searched these forums, however when I use the Rod Charge skill on a wand, how do I go back to using wands? The Rod Charge skill stays put.
  2. Can't you simply right-click a wand?
  3. J-Factor

    J-Factor Member

    A lot of the right-click mechanics are kinda screwy right now.

    In this case you would have to change to a different skill and then right click the wand. Ideally when skills are on cooldown they should no longer affect right click (which would allow you to recharge and immediately equip a wand).
  4. Incendax

    Incendax Member

    J-Factor is absolutely correct. The problem is that the Rod Charge skill keeps trying to use Rod Charge on the wand even though it is on Cooldown. Hence you have to swap to a skill or item that cannot be targeted by Rod Charge to then right click the newly charged Wand.
  5. Lordxorn

    Lordxorn Member

    @ChocoWaffle- please read a question before you go an make a reply that is redundant, "The Rod Charge skill stays put."

    Too bad, because that is the only skill I have at the moment.

    See if they let me in the Beta, I would have caught this. =P
  6. Embolus

    Embolus Member

    You don't have to right-click another skill, you could right-click say a bolt or a thrown weapon or whatever. Anything else that lends itself to right-clicking and is not a Wand.

    I'm not certain but I think you can de-select a skill by right-clicking it again or right-click the "chosen skill" box.
  7. Lordxorn

    Lordxorn Member

    @Embolus Thanks will give it try with other than wand, I have tried the de-select skill thing on the skill bar and no luck. Hoping a Dev chimes in here.

    Update*-Ok the work around is to equip a throwing weapon, then the wand to be able to un-equip the Rod Charge skill.

    If you do not have any throwing weapons or bolts, you can remove Rod Charge by saving, and reloading the game altogether. Simply saving and quitting to the main menu does not work, even though the Skill equipped box is empty, the Rod Charge skill is still there, and right clicking a wand will not equip the wand.
  8. Ratha

    Ratha Member

    Wands cannot be equipped while the rod charge skill is the active skill. It must be switched away from in order to re-equip a wand. Its skill use is in conflict with the right click to equip mechanic. So far i have not seen a proper suggestion for a solution to the problem, so i will venture my own:

    Solution: Rod charge either deactivates after being cast, clearing the current skill equipped, or, right clicking an item while wand charge is on cooldown equips the wand. Either would be an improvement.
  9. Seramus

    Seramus Member

    These forums are very helpful. The same question got answered no less than 3 times!
  10. Countmore

    Countmore Member

    Does placing the wand on your item bar and pressing shift-number work to replace Wand Recharge? I don't have any wands on my characters to test this out at the moment.

    EDIT: I just tested it out, and shift+number works in switching your active skill to the wand. I've not tried it out with Wand Recharge active though.
  11. Sorry Lordxorn, I did read your question and I thought you couldn't get Rod Charge off the spell button any other way. I only used wand lore once and I didn't find that problem, but maybe because I kept swapping other spells and not wands.
  12. Lordxorn

    Lordxorn Member

    @Seramus Thanks for the tip, could you please point me to the threads that answered this issue? I couldn't find any, as I have indicated that I did search "Rod Charge".
  13. Ratha

    Ratha Member

    @Lordxorn - If you have -any- other skills besides rod charge, click on them to equip one, and then right click on the wand you want to equip. If you dont have any other skills. Putting the wand you want to equip into the belt, and use shift+hotkey to select it.