Possible 1.0.5 bugs/glitches

Discussion in 'Bugs' started by Termy, Sep 6, 2011.

  1. Termy

    Termy Member

    I've noticed a few minor bugs and glitches with 1.0.5. These have all come from new games. Anybody else getting them?

    * Alt-click does not split stacks of toolkits (ingot grinder, tinkerer's tools, &c.) Works with everything else.

    * I do not seem to be getting any recognition towards "The Critic" achievement.

    * Sleeping monsters can still dodge my ranged attacks at least, without waking up. I believe this was supposed to be fixed with this build.

    * Is haywire supposed to apply to falling boulders, blades, &c? Or are these holdovers from the old haywire issues?

    * Under some conditions, the quests screen won't close by clicking on the x. Open the quests screen, click on the scroll down arrow. For me, clicking on the close icon no longer closes it. Esc still works.

    * Is narcosomatic induction supposed to be blocked by furniture? This may be intentional, but given that it's a psionic skill it doesn't seem quite right. I never actually noticed this with previous versions, probably because I wasn't paying intention.

    None of these are particularly game-breaking, although it still irritates me having a stack of tinkerer's tools. Maybe toolkits should be made non-stackable?
  2. Haldurson

    Haldurson Member

    I found one oddity -- I was around the corner, and right at the corner was a drink vending machine that was being ranged attacked from the other hallway by an electroblobby. It looked strange because at first I didn't see what was attacking it.

    It probably tried to buy something, and didn't get the correct change.
  3. Nicholas

    Nicholas Technology Director Staff Member

    ... I can honestly say I have no idea why an Electroblobby would be attacking a vending machine, unless it was in the way of you?

    A mystery...
  4. Haldurson

    Haldurson Member

    The electroblobby was around the corner, so the machine was not between it and me. But after I wrote the above I came up with another theory -- sometimes when a trap is triggered, it can damage a different square than where the trap is. Maybe the critter was rolling over some trap a couple of times, which made it look like the machine was being attacked(???)

    I don't really know. I'll keep my eye out in case it happens again.
  5. stoo

    stoo Member

    The problem is toolkits are containers. I'd change it so that you can only carry one of each type of toolkit.

    i.e. if you have an ingot grinder and pick another one up, you still only have one ingot grinder.

    Would solve all the problems.
  6. Psiweapon

    Psiweapon Member

    The horadric lutefisk cube allows for some nasty duping of items... IDK if it was like that in 1.03... I'm posting my exploits in another thread.
  7. Marak

    Marak Member

    Here's a minor one:

    Vampires do not get the new "You need to dreeenk blaht" verbal message when at half health. I've had monster beating on me for most of floor now, going under 50% health and then healing up to just over half health, over and over and over. Nothing. No verbal warning of any sort - not even the old "Eat FOOD to regain Health!" or "Your Health is LOW!"

    The only thing you get now is the old "Your health is Critical! / Your life force is running out!" message at 25% health.

    It makes me sad. I wanted moar Announcer Guy, not less. :(
  8. Nicholas

    Nicholas Technology Director Staff Member

    The reason vampires do not get the Dreenk Blaht message at 50% health is because there is an oscillation problem. You end up in a situation where, if you get it every time, the announcer will simply scream BLAHT ! BLAHT! at you every time you hit a monster. Which is... kind of amusing, actually.

    I'll look into adjusting this somehow. At present, the Blaht message triggers at 33% health, I think? But only if you've gotten there from about 50.
  9. Marak

    Marak Member

    Hrm, more testing is required! To the Bat Save!

    Na na na na na na na na na na!
  10. IanExMachina

    IanExMachina Member

    >the announcer will simply scream BLAHT ! BLAHT! at you every time you hit a monster. Which is... kind of amusing, actually.

    Should have left that in :D
  11. eyhung

    eyhung Member

    Here are the bugs I've noticed with 105:

    The potion of lively regeneration appears like a thumbnail instead of a full-sized potion when it's on the ground.

    The monster zoo award isn't given if the monster zoo bug (killing monsters in zoo doesn't decrement counter) appears. The bug appears when I don't kill them right away but close the door and go elsewhere. (In fact, a trap in the zoo was killing the monsters slowly, it went down from 100 to 96, then stopped.)

    WASD doesn't allow players to commit HEROIC VANDALISM. Seems like a no-brainer to allow it. (It also doesn't allow opening chests but that could be intentional).

    I found an eely on level 1, maybe it was a hardcoded room setup, or an OOD spawn, but it was surprising.

    Monster magic spells are not showing up in the "status message" bar. I would really like to know those Octos are hitting me for 6-7 damage a pop and which type of damage they are using.

    Still getting to a state where I kill stuff faster than the scrolling status message bar and it keeps scrolling for minutes. Maybe allow the user to turn off scrolling status and add a scroll-back bar?

    on Elvishly Easy, I have kronged at least 7 items and gotten 0 curses. Maybe I'm a lucky SOB, or maybe there are fewer curses on Easy?

    Minimap extra features work but special features like monolith/eyeball shrine are not noted. (Maybe this is intentional.)

    Not sure resistances are working quite right, I equipped a ring with 3 slashing resistance and the damage I took from Pumpkinns went UP.

    A way to improve the crafting interface is check the items in the crafting kit and then only show recipes that use those items. If the crafting kit is empty, then do the current behavior (show all). Also, if there's a recipe already selected, have a button to clear the recipe -- this can be done by selecting an invalid recipe (tinker recipe for an alchemist kit) but it's much slower.

    The tutorials don't work quite right when the character auto-pickups the item. You have to click on the item to trigger the next event. I was also unable to reach the end of the crossbow tutorial.
  12. Malignant

    Malignant Member

    I had a Throwing weapon Vending Machine stuck inside Monolith...
    could not activate the machine but monolith worked for quests
    if this would have been other way around it could prevent from completing quests.
  13. mr.ioes

    mr.ioes Member

    Some (new?) buffs from various consumables don't have real icons, but rather show some potion in the top left.

    Smaller levels are generated now? My lvl 1 + 2 were really small in comparison IIRC.

    €: just happened: if you press space and immidiatly one of WASD, you can walk into enemies ;)
    €2: kk hard to reproduce ^^
  14. DavidB1111

    DavidB1111 Member

    OKay, what the hell. My vampire is leeching one life from enemies now. I thought it was fixed to work better.
    Please tell me why with 6 magic power, my vamp only leeches one life, because now vamps are unplayable. I'm doing 10 damage a hit...

    Also, apparently, the exploit of sorts of Alt F4 to go to the main menu is fixed. :(
    I can no longer use it at least.
    I'm not too sad. But still, a bit surpring that it saves where you are, and not where you saved the game. :) Save the game, pick up items and stuff, Alt F4, and the game will restore the save correctly, but place you where you are now, with all your items that you picked up in your inventory.
  15. IanExMachina

    IanExMachina Member

    My Vamp was draining more than one HP, on my warrior and I hardly had any Magic power (due to armour).

    I'm not sure of the mechanics though.
  16. Darkmere

    Darkmere Member

    My warrior just died on floor 7 because I ate a deep omelet, clicked the digest button, and had an icy golem wander up and kill me. It took him some 20 turns but I couldn't move or cancel digest. Is there a way around this, is this a bug, or are you supposed to try and hide in a corner to digest?
  17. mr.ioes

    mr.ioes Member

    I just gave a lutefisk statue 131 lutefisk without receiving an item. Either the wiki is wrong (http://www.dredmorwiki.com/wiki/Lutefisk_Statue) or it's a bug. At least my backbag doesn't smell anymore.
  18. Vykk Draygo

    Vykk Draygo Member

    I just put a steel breastplate, and three steel ingots into the anvil, and got out a rough steel sword. I didn't lose the breastplate, or the extra ingot, but I <i>really</i> don't want that sword.

    Now I'm afraid to try to make the full plate again, if I find the ingots for it. I was going to make Serpentine. I was excited, since I lucked out and found the breastplate on the floor. xD
  19. J-Factor

    J-Factor Member

    You need a Steel Cuirass, not a Steel Breastplate.
  20. Ratha

    Ratha Member

    @Termy - Alt-Click does not split tool stacks has been noted on the bugsheet.

    The quest screen close button is about 1/2 a square to the right of the "X" If you click on the right side of it, or the empty space it should close. If that describes your problem better, its already been noted on the bugsheet.

    @mrioes - Lutefisk behavior was changed for 1.0.5. I dont know the exact details offhand but im guessing thats correct since you now get 1 lutefisk per item in a stack.