Option to Speed up Minion combat Animation

Discussion in 'Suggestions' started by Wootah, Dec 6, 2011.

  1. Wootah

    Wootah Member

    Currently, due to turned based combat, having a minion out really reduces the pace of a game in large fights. If I cast a little slime from my fungal arts, he gets surrounded. Which is what I want. But then for combat, every attack against the minion and every attack he makes makes the game feel like it takes for ever. Often times I will cast him at the edge of my vision and walk away because the game plays so much faster when I can't see the combat.

    I can't even imagine having multiple minions at once in combat (maybe that isn't even possible). But a feature that would either speed up or completely remove all combat animations from/against the minion would be nice.
  2. TheJadedMieu

    TheJadedMieu Member

    Press the + key to speed up all animations, including those of your minion.
  3. Daynab

    Daynab Community Moderator Staff Member

    By some mistake the above command only works if you're in debug mode in the current version (start the game with -debug-flag append, either by making a shortcut with it after the path, or by steam launch options.)
  4. Feynt

    Feynt Member

    At the present summoning anything else seems to unsummon previous pets, as long as they're nearby. I've used the Fungal Arts slime summon once in one room, teleported to another across the dungeon via a tile, and summoned again. This gave me two slimes (1.06 and .07). I don't see anything wrong with this, and in fact I'd love a conjuration line which does nothing but summon throngs of disposable creatures with a tank in there for good measure.

    Hmmm.... Mods....
  5. Wootah

    Wootah Member

    Thanks Daynab, I couldn't get it to work in 1.07

    er... coming back. how exactly would I do that in windows. I tried creating a shortcut with '-debug' in the path to the executable, it started up fine, but I still couldn't speed it up and couldn't see any indication it was in debug.
  6. Daynab

    Daynab Community Moderator Staff Member

    In the shortcut you would see Target:
    "C:\Program Files (x86)\Steam\steamapps\common\dungeons of dredmor\Dungeons of Dredmor.exe" -debug-flag

    Obviously replace the path to something else if it's not installed there.
  7. Wootah

    Wootah Member

    Thank you Daynab, that worked.