[old] Master Community Beta Buglist [old]

Discussion in 'Bugs' started by Eikre, Nov 30, 2011.

  1. Eikre

    Eikre Member

    MOST RECENT VERSION: 1.0.8/Realm of the Diggle Gods live.
    Beta access is by individual admission. Email contact@gaslampgames to volunteer. If you wanna discuss this or anything else in real-time, come join irc://irc.quakenet.org/gaslampgames.

    At the time of this writing, there's a 1.0.8 Beta topic in General that the devs made, an IRC channel, a topic on Something Awful, and probably a bunch of other things I don't even know about where people have been putting up their bugs, and I dig that. The devs are cool, they read everything, Daynab files whatever he sees reported in their internal bug-tracker, it's all good. We can't see said bug-tracker, though, so we do redundant reports or try to reproduce phenomenon that are old news. Lacks dignity.

    I'm gonna keep a list going in this OP of every bug germane to whatever the most recent version of the game is at the time, and maybe put strikethroughs in whatever gets fixed so we can have closure. I don't know. Anyone with moderator privileges can edit this too, I think, so if they want to leave notes calling me a moron when I fail to appreciate their clearly intentional idiosyncrasies, that would also be cool. I'm really only concerned with bugs and behavior that obviously defies the developer intention, so the more heady discussion about how otherwise functional things should work probably remains in the General Discussion topics.


    ~Exiting one version of the game and starting another one remaps the "Up" key from W to 7. Just ignore this. They don't know why it happens but it seriously is not that big of a concern.
    ~Saving and reloading will erase all of your known recipes for the n-Dimensional Lathe. And if you have no recipes for a tool and try to open it up in the crafting interface, it will crash your game. Don't do that.

    Some bugs with skills are generalized errors in spell effects. Take a look at the next session to see if your specific problem is already accounted for.
    Skill level numbers are as they're written in XML, and therefore starts counting at level 0:

    Unarmed: Contributes damage to ranged attacks. With crossbows it will contribute all of its piercing and aetherial damage, with throwing it will contribute everything. This was fixed at some point but it's back now.

    Ley Lines: Level 4 [Invisible Geometries] Can be used to teleport onto monsters and other occupied spaces.
    -It also fails to ever trigger its associated debuff effect, "Invisible Geometries Drain." I think it's because of bad markup because what's there doesn't exactly follow the schematic layed by, say, Deathly Hex. It's been changed once already but still doesn't work. See if you can get it to function right on your own [lines 717-728 of core spellsDB].

    Wand Lore: The Wand Affinity stat that Wand Lore gives now is a crafting stat now. You can still get magic items with the old stat, which is functionally useless and does not impact the character sheet.

    Fungal Arts: All the confusing clouds for this skills work more like Psychic healing crystals than poison clouds. When something walks over an affected square, they exhaust the effect on that square only; nothing else which retreads in that space will be affected for the remainder of the cloud's duration.

    Big Game Hunter: Level 2 [Release the Hounds] is on a one-turn timer. This is held to be pretty broken and looks like something leftover from the beta.

    Piracy: Has weird code [Line 246 of expansion skillsDB] which looks sort of like a loadout tag but isn't really marked up properly for that at all. Are we supposed to start with four lockpicks (we don't), or is this something else entirely?
    ~Level o [Plundering] is supposed to make enemies drop gold. Doesn't work.
    ~Level 1 [Swashbuckling], contrary to its description, does not actually let you counter all the attacks. It doesn't even max out the counter stat. The description should probably just be changed.
    ChocolateWaffle, Godwin and Essence like this.
  2. Eikre

    Eikre Member

    Spells and Items

    -Polymorphing closes all your open interfaces, except for that of the lutefisk cube (and hypothetically other crafting tools, if they still had their own windows). For some reason.
    -If you spend a level up in diggleform or whatever and get a new skill, it will appear to have vanished in your human skillbar. It's fine, though, just set it manually.
    -When you're polymorphed into a flying creature, you can pass over water features, but not traps; they'll activate just as if you had walked over them in human form. Batties get a nice sneak buff so you might notice this less than with modded morphs.

    ~You might notice :reflection: as a new stat included on certain equipment like One Sparkling Glove and the berserker's Ancestral Tattoos. It's going to be a new magic-reflection stat. Seems to be unfinished.
    ~Friendly regeneration spells, like Minor Regen from the coral wand, are subject to resistance.

    ~Horodric cubes and n-Dimentional Lathes are valued at 0 zorkmids.
    ~Axe of Dinglenit is valued at 0 zorkmids.
    ~Cat Ears use the Helm of Threapwood's saucepan graphic.
    ~Gloriously Regal Belt uses the Bullet Belt's description.
    ~The Denim Jacket and Denim Jacket with Rhinestones use reversed graphics.
    ~Rough Blade Traps have a lower zorkmid value than Crude Blade Traps, despite being superior items. Perhaps their values have been accidentally switched.
    ~The Asgardian Stormhammer uses a placeholder description.


    ~Water monsters can appear on land due to special circumstances. Mostly just zoos, but the new Displacement effect on Blink Dust and Love Will Teleport Us Apart can do it too.


    ~Wall launchers and gargoyles projectiles are blocked in a strange manner by the environment; if you stand behind an obstacle to the left and have one launched at you, as for failing a trap, it will always be blocked by said obstacle. If you stand behind one to the right, it won't.
    ~The Mysterious Portal can cause crashes on save/reload.
    -Also, the exit portal in the mysterious dimension will actually take you to a new mysterious dimension instead of exiting back to the normal dungeon.


    A lot of the mod stuff requires more testing! Try this shit out.

    ~The modloader straight up doesn't work if the directory it reads from includes any exotic characters. This can happen if, for example, your windows username is spelled with accented or foreign characters.
    ~TextDB doesn't seem compatible with mods at all. This is terrible, guys. This is where you go to mod if you want rooms to spawn with giant statues of cocks in them.
    ~TemplateDB is also incompatible, apparently? Haven't tried it myself yet.
    ~SkillsDB: Skills will not add secondary stats. Taking the last level of a modded-in skill will crash your game.


    ~Turn issues are still around, but at least you can't just double-click to make free moves. You can cause all sorts of turn abuse by overloading the input; try tapping double-space and clicking to move at the same time, for instance.
    ~In the inventory, on the right-hand side of each row, there's a single-pixel column in which you can express the first inventory space of the succeeding row. It's not an extra space or anything, it's just weird.
    ~Lots of steam achievements are broken. Seems most of the new ones, along with anything involving a counter: Eating omelettes or eggs, mixing potions, repairing wands, heroic vandalism...
    ~Tutorials still need work, but at least they don't outfit you with too little mana to cast the spell they've given you now.
    -The skills you get in the tutorial are whatever you'd get by hitting "last" at skill selection. So if you just played a vampire and then you do the food tutorial for some reason, you'll be stuck.
    ~Unlike everything else on the Options menu, "Disable click-to-move" does not remain on after closing and relaunching the game.
    ChocolateWaffle and Essence like this.
  3. Eikre

    Eikre Member

    Dear prospective bug-finders:

    There's a debug mode! You need to set the game to run with the "-debug-flag" affix. To do this in steam, right-click on the game's entry in your library, select Properties -> Set Launch Options, and then write "-debug-flag". To set it on a windows shortcut outside of steam, right-click on the shortcut, select Properties -> Shortcut, and then add it to the end of the "Target:" field.

    Mods need more testing! To activate a mod, navigate to \Documents\Gaslamp Games\Dungeons of Dredmore and create a directory called "mods". Drop any mods you want to use into there and next time you start the game config screen you'll find them under the "mods" button.
  4. Eikre

    Eikre Member

    Saving an extra post here. The character limit is sort of stifling.

    Tell me if I'm missing anything.
  5. Essence

    Essence Will Mod for Digglebucks

    I can tell you from modding them about that "fear" really does send monsters running away from you in a straight line for a bit, though it seems that they get to resist it every turn (because my "4 turn fear" proc frequently ends in 2 or 3 turns). Fear also automatically ends if the monster is attacked, I believe. "Pacify" sets the monster's AI to "hasn't noticed you and is wandering aimlessly", which is great if you have high Sneakiness and basically worthless otherwise. "Confused" also seems to work similarly to "Fear" except that the monsters can arbitrarily move diagonally if they begin their turn diagonal from you.

    There's also some issues wherein reloading a saved game will cause an item you're wearing to Polymorph you. Removing the item will remove the Polymorph, putting it back on will Polymorph you into a different monster. In all cases, all associated Polymorh-related hassles and bugs apply. Lesson: take off all of your equipment before you save the game!
  6. Null

    Null Will Mod for Digglebucks

    Let's knock out a ton of your bugs as intended behaviors or errors.

    Just saying, Thaumaturgic Conflux isn't deprecated. And it's not supposed to proc on cooldown skills. Only spells (ie abilities that cost mana) can proc it. For comparison silence only affects skills that cost mana, not cooldown skills.

    Invisible Geometries does proc it, it just seems to me that manaDrain doesn't work. I've not once seen my mana being drained by anything that should.

    Emomancy's bugs
    Love will Teleport also rather consistently moves water monsters to land.
    Chemical Explosion will obviously be a spell and not a cooldown ability
    Sigil of Whatever's paralyze additionally lasts forever.

    Diggle Plague's 0 mana cost is probably not intended for the release. I wish abilities without cooldowns or costs wouldn't show 0 mana though.

    Green Harvest does damage to plants, but the temporary fruit that drops has a percent chance for each, and thus might not drop it every time it procs.

    I'm not quite sure about the piracy loot tag. I know that there was one time the first chest I opened, in the starting room had four lockpicks.

    Leveled skills while in polymorphed forms don't dissapear, they just leave your bar and you have to add them. Then everything is okay.

    Confused actually is also different than fear in that when monsters move back, they don't take up a turn to move, it just disallows them from moving. Thus they can for instance move away but then cast a spell in the same turn.

    I can dig up all my bugs from the thread and post them here in a bit.
  7. Nicholas

    Nicholas Technology Director Staff Member

    Okay. I sent a beta off to Valve last night; my technical contact seems to do things around 1 o'clock these days, hopefully, so it should hopefully be up at some point this afternoon. Hope and pray.

    The following is a list of changes:

    - Fixed all the animation issues with Weredigglin'.
    - Removed Thaumaturgic conflux debug code
    - Fixed Green Harvest
    - Turned on Big Game Hunter; fixed Hunting Diggles
    - Added support for kill buffs; added that to Green Harvest + Butchery
    - Added Cleavus, the Axe of Meatpaste
    - Fixed (hopefully) the bugs with Love Will Teleport Us Apart, and General Emomancing
    - Stuff now has better timing values and may actually show up in the right places
    - Fixed the clicking-to-skip-a-turn issue! Migod, the end is nigh.
    - Fixed: most of the other polymorphing bugs (skills being locked out, etc.)
    - Fixed: various things affecting the Linux and OS X builds, which only showed up when people started playing the Linux and OS X builds.
    - Fixed: broken tutorials. (1.0.7 bug)
    - Fixed: Fever of the Flagellant just randomly crashing the game.
    - Fixed: Same for "No, You Are The Demons"
    - Fixed: going through a mysterious portal while a Werediggle crashing the game
    - Fixed: same with ascending, descending stairs
    - Fixed: The disappearing skills bug. I think.
    - Fixed: Deadshot appearing when you choose a random build.
    - Fixed: hopefully, the blasting nonsense.
    Exile and Essence like this.
  8. Nicholas

    Nicholas Technology Director Staff Member

    I think I changed some more stuff, but I don't remember what.

    EDIT: Oh, now, I remember. The procs for weapons work - so Rockburst, etc. on the Axekeytar and effects on the tomes.
    Exile likes this.
  9. Essence

    Essence Will Mod for Digglebucks

    Yay meatpaste! Any KoL reference makes me happy.

    Also, you did fix the beta-and-modded-skills-giving-no-archetype-levels bug, also, yes please?
  10. GrossorMD

    GrossorMD Member

    Is there a changelog with the planned stuff for 1.08 ?
  11. Eikre

    Eikre Member

    Not really a centralized one, no. If you ask in the general discussion topic I bet someone would give you a primer. Basically, core gets a bunch of backend support with regards to what you can put in the XML, and the short skills are redone to have more levels (wand lore also becomes a crafting skill instead). The expansion has all the content that the XML backend is there to support, plus more dungeon in the form of 5 extra floors and Mysterious Portals.

    @Null: Are you ever on the IRC channel? I rolled a lot of what you've posted her and otherwise into the list but I wanna hash out your contentions; some of them don't make sense to me, and others I can't get to work.

  12. Null

    Null Will Mod for Digglebucks

    Oh yes, dots being resisted either is a bug or has bugs it seems. What I mean is something like this, you're low on health and about to die, you cast a coral wand and see a big resist over your head and quickly die because you don't get healed at all.

    That was just something that happened now.

    And no I haven't been on the irc but shall be more.

    Also this is not a bug, but transylvation gives health regen... it also seems so far to be insanely op with 50 dodge, just saying.

    And doors are facing the wrong way for me occasionally.

    It's possible to move onto a monster if you just move quickly enough.
    Permanent mines casted on a monster trigger twice at once.

    The beam target type still fires through walls even though the tiles don't show.
    Buffs have an offset of 1 on their timer, they start one higher (even infinite duration buffs show one) and end one turn after the icon ends.
    Sigil of Whatever's paralyze lasts forever. So does the sigil.
    Related to the above is that Ennui stacks infinitely.
    Love will Teleport us Apart has not min cost (intentional?)
    Dampening Field of Angst doesn't seem to cause its effect.
    Chicken monsters flee even when they don't detect you.
    Stairs can generate in any room even in the artifact rooms of "The Pit" and the lever room.
    When monsters have multiple statuses appended to their description (eg fear and root) then when one is gone they both will be.
    Love will Teleport us Apart can teleport enemies under the player. Targeting them while they are under the player will cause the player to be displaced as well.
    Also, second level of blood magic still gives stolen spirit (and I assume third gives soul) rather than third and fifth it should be.
    Displace besides moving things under the caster can also teleport water monsters onto land (and potentially only onto land).

    These are probably old:
    When the walls are like this: the X in this is uses the wrong tile (with the corner on the right side instead of the left). This at least happened to me in the frozen tileset. This happens as well flipped horizontally.

    This here is not part of the core game but is obviously a bug nonetheless
    <spell name="Eye of the Storm" downtime="8" type="self" icon="skills/spells/eye_of_the_storm32.png" >
    <requirements mp="30" magPowerBonus="0.10" mincost="15"/>
    <description text="summons a powerful whirlwind" monsterText="summons a powerful whirlwind"/>
    <buff useTimer="1" time="8" self="1" allowstacking="0" icon="skills/spells/eye_of_the_storm64.png" smallicon="skills/spells/eye_of_the_storm32.png">
    <halo name="sprites/sfx/energyring/energyring" first="2" num="3" framerate="50" centerEffect="1"/>
    <effect type="trigger" amount="0" spell="Eye of the Storm Effect"/>
    <spell name="Eye of the Storm Effect" type="template" templateID="13">
    <description text="strikes with a raging storm" monsterText="strikes you with a raging storm"/>
    <!-- <effect type="damage" asphyxiative="2" asphyxiativeF="0.15" blasting="3" blastingF="0.35" hyperboreanF="0.10" /> -->
    <!-- <effect type="trigger" percent="10" spell="Eye of the Storm Lightning"/> -->
    Trying to cast that causes me to attack my left side, followed by attacking down , followed by up, then right. And that happens all in one turn, before applying the buff.
  13. Nicholas

    Nicholas Technology Director Staff Member

    Beta is now out....
    Exile likes this.
  14. Copycat Zero

    Copycat Zero Member

    Something I had thought was fixed during the 1.0.7 part of the beta, but using Froda's Jump Discontinuity (and possibly other things that require the "snap" animation) is back to using the male animation on a female character.

    Confirming that the ground object issue is fixed (at least the bones), but pointing out that stepping into their square causes them to appear on TOP of your sprite for a moment before going back into the background layer. I believe this is an issue that's been in the game for a while, but...

    Another issue that predates beta, but being at exactly enough XP to level doesn't cause you to level. My character is at 125/125 XP right now, and still level 1. Once I do anything to gain XP, she'll level normally.

    Still getting lag spikes when breaking down doors. In both cases, it was one of the old rooms, but there was one of the new monsters on the other side of the door. [EDIT] Just opened a door without breaking it, into an old room with new monsters, and there wasn't a lag spike. [EDIT 2] Happened again: Broken door, new monster, lag spike. There seems to be a connection between the three.

    The cloud created by summoning the slime in Fungal Arts isn't playing by spell mine rules. I can stand in the cloud and not take any damage, but moving in the cloud was dealing me a small amount of damage. However, this may be also because not every square of movement within the cloud is causing me damage -- only some of them were (and it wasn't quite as predictable as "every other square"). The latter issue may predate the beta.
  15. Null

    Null Will Mod for Digglebucks

    And using it on a male character results in a female animation.

    Exp is not a bug

    Toxic Spore cloud is not permanent, ie each tile only triggers once. The fact that only some tiles triggered meant they already activated. Maybe the glints don't go away or something.
  16. Copycat Zero

    Copycat Zero Member

    Is it part of the "work in progress" bit of the beta that Slicks don't leave behind visible corpses? Killed one and there was just a blood stain, but I could still interact with it for the purpose of planting a spore. [EDIT] Oh, wait, no, nevermind, there it is. It's just really hard to see.

    Speaking of "work in progress", but I'm assuming the descriptions on, for example, the new Crossbows skills aren't finalized? There are a couple capitalization/punctuation errors otherwise. And I'm guessing Fight in the Shade isn't ready yet? I used it and it appeared to only cause 1 Piercing Damage to the target and that was it.

    I have no idea why, but equipping both a melee weapon (an artifact Crude Stone Axe, in this case) and a tome (a Little Black Book, in this case) and then making a melee attack caused the game to crash. Unfortunately, it was a "this program has stopped working" Windows-style crash, rather than a hard crash, and Dredmor didn't generate a crash log.
    [EDIT] Or not? I just started a new game, found a Little Black Book in the first room, equipped it along with my Wooden Sword, and melee'd just fine. No idea what caused that crash, then...
    [EDIT 2] That artifact Small Crossbow mentioned below: Just tried to kill an Enraged Diggle with it and the Little Black Book equipped. Game crashed when I would have landed the killing bolt.
    [EDIT 3] Because, apparently, I'm a masochist, I intentionally grabbed a Little Black Book and an artifact weapon in my next run and used them together to kill something. Game crashed. There seems to be a definite thing here.
    [EDIT 4] Artifact Cracked Orb in hand and nothing else equipped, I switched to werediggle form to kill a Slick. Game crashed. The bug isn't tied to the Little Black Book, it's tied to artifact weapons in general?
    [EDIT 5] I didn't even HAVE a weapon equipped this time. I picked up an artifact ring and Krong'd my Astrologer's Cap. The game crashed the very next monster I fought. I have no idea anymore...
    [EDIT 6] I started a new game with no proc-based or weapon-enchant starter skills at all: Mace/Dual Wield/Artful Dodger/Master of Arms/Perception/Burglary/Rogue Archaeology. I've leveled twice, taking Knightly Leap and It Belongs in a Museum. I made a save before a Krong anvil and tried twice, once enchanting my fedora and once enchanting a melee weapon. In both cases, I was able to kill the next monster without the game crashing. I'm now going to attempt to find an artifact off the ground and kill something while wearing it or I'm going to level once more and pick one of the procs, whichever comes first.
    - [SUBEDIT] Picking up an artifact Aluminum Pipe off the ground and bashing the very next enemy with it crashed the game. I had also gotten Dwarven Handshake in the interim. I'll load my save and not pick Handshake and see if it does it again.
    - [SUBEDIT 2] Loaded my save, Krong'd the Razor Sword I was carrying (since the other time I Krong'd was my Wooden Club), and the game crashed when I killed the very next monster. I've attached the various files (save, config, etc.) connected with this run.

    Found an artifact Small Crossbow that appears to be trying to add +1 to the old Wand Affinity attribute.

    Is it intentional that Wizarding Associate was knocked down from +12 Mana/+2 Magic Power to just +4 Mana?

    Mentioned it in the main beta thread, but is it also intentional that being in werediggle form denies you the passive stat bonuses from your other skills? Whatever else got fixed with being a werediggle, that's still in.
    [EDIT] Also, skills learned while in werediggle form aren't added to your werediggle bar if they aren't a werediggle ability, but they also don't automatically appear in your human bar (but can be added manually). However, the reverse works: Gaining a diggle-specific skill while in human form automatically adds it to your diggle bar, but not your human bar.

    Was playing Elvishly Eay, Permadeath, No Time for Grinding. Died, started a new game, and the options were set at Dwarvish Moderation, no Permadeath, regular game. I had thought one of the earlier patches set things to remember your choices from game to game? (Related to that, I'm still getting the intro screens on subsequent restarts, even though I thought that was changed, too.)

    This isn't universally true: Artful Dodger and Assassination still only have three skills each, unless the skill expansions are coming later.

    May not be a bug, but it's something that would be nice if they'd change.

    Yeah, the graphic was still there. They might want to look into that, since it's mildly confusing (no pun intended).

    Attached Files:

  17. Copycat Zero

    Copycat Zero Member

    (Starting a new post because it's been almost a week since the last one.)

    This has been around since forever, but is it really intended that, if you have Dual Wield and a weapon skill (say, Macery), the passive damage bonuses from the weapon skill get added twice if you're wielding two of the same weapon (equip two maces, get +4 Crushing from Macery's first skill instead of +2)? I can see this being intended as a way to make Dual Wield/one weapon skill be competative with Dual Wield/two weapon skills, but Dual Wield/two weapon skills does already has the cost of having to spend an extra skill-slot in exchange for the extra passives.

    Another preexisting issue, but set-pieces like wall sconces can be clicked on. Doing so does nothing except waste your turn. Obviously, if you accidentally do it while there's an enemy adjacent, you get smacked.

    Mentioned this in passing on the IRC channel when I was picking up the fixed .exe, but monster corpses are ending up under dirt patches instead of on top of them. Similarly, the ground object that is the four glowing red bars (I'm assuming it's supposed to be a grate over lava, or something) will appear on top of items (like lutefisk), rather than below them. I imagine that other ground objects will have similar behavior as those two.
    [EDIT] In the artifact room on Floor 3 (the one where the artifact platform is surrounded on three sides by a moat), the stand that that artifact is on appears on top of the artifact -- in other words, the stand appears empty but for the glinting of the artifact.

    Whereas I was initially mistaken about the Slick corpse, I can, with more confidence, say that the Mummy appear to be not leaving behind a visible corpse when it dies (you can still mouse over the spot where it died and the tooltip will pop up). Is this intended? Also, its attack animation is a bit on the slow side...
    [EDIT] There's no corpse for the Living Statues, either, so I'm going to assume that corpse art for certain monsters hasn't been finished yet.

    Wights, like their potato counterparts, appear to be flying but are still bound by ground-based rules.

    Existing thing made more apparent by the new "Coward" AI type, but, when monsters are fleeing/cowardly/peaceful/not noticing you, it tends to look kind of weird when they move backward (that is, they move in a direction without changing their sprite to face that direction, making it look like they are backing up). So, you get Coward monsters that are trying to kill you... by walking backwards into you.

    Got down to Floor 4, and all of a sudden the barrels/vases/etc. are now using their intact sprite for their broken state (i.e., break a vase, see it crumble, and then immediate have it appear whole again but able to be moved through and with the "It's broken" tooltip). I had minimized the game prior to seeing it happen the first time, but (a) I've been minimizing the game frequently this entire time, and (b) all of the breakables I'm encountering are doing it.
    [EDIT] Leaving the floor and coming back does nothing (and it's doing it on Floor 5, too). I can't test if saving, quitting, and reloading will work, because I'm using the fixed .exe that crashes when you try to reload saves.

    Another "issue in live that comes to mind because I've encountered it in the beta", but, I've had instances where, when you pull a level and get the "Oh no, traps have activated!" message, no traps actually activate. In certain instances I've attributed it to the room being too narrow and thus the traps actually activating in areas inside nearby walls, but in the most recent case there was plenty of room for the traps to have spawned and none did. Is this a bug or just a RNG thing?

    The new crossbow bolt types don't appear to be sorting into the same area of the inventory as the old bolt types.

    Others have reported getting indications on their minimaps for the presence of quest monsters (for example, in the main beta thread), but I have yet to see a single one, even when the quest monster is in my line of sight.

    The attack animation for Eye Lasers doesn't actually strike down in the space of the target, but rather one or two squares below it.

    Apparently, thaumite swarms don't play by the new spell mine rules, as standing in a square after they drop off you the first time doesn't cause you to regain the debuff -- or, if it does (because I still had the animation on me and the swarm disappeared), they don't cause damage and vanish completely when the swarm ends.

    Conversely, Knightly Leap (and, likely, other teleport moves), can teleport the player on top of enemies.

    To be clear (assuming you're talking about the beta client), the achievements were never un-broken in the first place. They work fine on live, but the fix from 1.0.5(?) was never applied to the beta version(s).

    I'm assuming, based on the "Debugging the broken achievements. (Finally.)" Twitter post that was made a couple minutes ago, that it'll be fixed in the next beta update. I wonder if we'll see some new expansion-based achievements (or new achievements, period) in the process...?

    [EDIT] However, I just discovered that the new skills in old trees (like Perception) break the achievements for those trees, so maybe that's what was being referred to in the post.
  18. Copycat Zero

    Copycat Zero Member

    The Helm of Threepwood is doing the old "Krong an item and get 'blessed' with no enchantment on it at all and the name doesn't change" thing.
    [EDIT] Kronging it again did give me an enchantment that time (name still didn't change).

    It's possible for the icon for a Mellow Shrine to get hidden behind one for a Satanic Displacement Glyph on the minimap, even at maximum zoom. Would it be possible to set a priority whereby things like shrines always appear on top of other icons? (Or, perhaps, reduce the size of the glyph icon?)

    So... yeah... went up a flight of stairs in werediggle form. Form ran out a few turns later, but my skillset didn't revert back to my human one. I now have the ability to cast The Mighty Augur as a human.
    [EDIT] Every time I use The Mighty Augur, the texture details on the walls and floors (cracks, ivy, etc.) changes. I've also discovered that Chalk Scrawls are impassible terrain (and are not destroyed when you destroy the wall they're on).
    [EDIT 2] Same with Gargoyle Trap heads. And, apparently, those half-sized walls people have reported finding are the building blocks of a lot of other walls/pillars in the game, because tearing down things that appear larger will reveal one of these half-walls behind it.
    [EDIT 3] In fact, basically everything that's "attached" to walls will float there by itself, impassible, when you destroy the wall. Oh, and if you destroy the walls in Brax's shop, the shop music will break and the music will change with every block you destroy in the shop. Leaving the boundaries of the shop area and re-entering them will cause the shop music to play as normal.
    [EDIT 4] You can re-add your human skills to your bar and use them as normal. This includes Werediggle Form, which will give you your werediggle bar as usual. Reverting to human form at this point continues to leave the werediggle abilities on your human bar (but wipes the human abilities off again -- sometimes). Changing floors, either in human form or werediggle form, doesn't revert the bug.
    [EDIT 5] Tried leveling up while in diggle form. Didn't revert the change. On the plus side, I can now finally confirm that the Digging Ray bug I reported (on a friend's behalf) from a few patches ago has been fixed, as I mined out about half of Floor 1's blocks (including the entire perimeter).
    [EDIT 6] Leveled up in human form, too. Nope.

    A number of things about the new crafting interface seem to be broken: The "X" to close it doesn't work (have to close it by right-clicking the tools), there are black boxes on the left where I assume the various forms of crafting tools are supposed to be, regardless of which tool you use to open the interface it just shows the Ingot Press one (or else it just shows the first one you open), the center of the interface isn't clickable (trying to do so just moves your character), etc.
  19. Genuine

    Genuine Member

    Just suffered from a crash to desktop on Floor 12 while fighting a large group of Nether Cubes in a monster zoo. I would have sent in the .dmp file, but it appears to have created a completely empty file for some reason. Also, there were no monsters besides the Nether Cubes, which I'm not sure is intentional, a bug, or everything else simply hasn't been implemented yet.

    Other things I've noticed that I don't think I've seen listed yet:

    - Exp values for new and old monsters look like they need to be re-calibrated. Older monsters (gold golems, etc) give way more experience per kill than the new ones of comparable level.

    - Items in the Crafty Crafts dispensers are often massively overpriced (Elven Ingot Grinder), free (Horadric Lutefisk Cube), or put into large unbreakable stacks (intentional?)

    - Had a character start with 4 Horadric Lutefisk cubes once. Can't remember what the build was.

    - Recursive Curse DoT doesn't always seem to activate. Re-casting doesn't help. May be related to the monsters resisting it the first time it's cast, which once it's cast prevents the DoT from being applied even though it's not currently effective (though I thought I saw this happen a number of times when it wasn't resisted also).

    - Enemy cowardice seems a little wonky. I get that the weaker enemies are supposed to stay back (casters and the like), but they seem to be prevented from often times even using their spells at all and simply try to flee constantly. This is especially apparent in monster zoos.

    There was probably a lot of other stuff, but I can't remember what it is right now...
  20. Eikre

    Eikre Member

    Okay, I stopped keeping the list as current as it could have been for a little there because the bug-fixing was moving just as fast as the bug-finding, which was good, but, I mean, this was supposed to be a public benefit thing. Sorry.

    Anyway, we can all give it a break for a little. The beta is pretty much wrapped for now. I'll retool after release.