No keys. Ever

Discussion in 'Conquest of the Wizardlands' started by Mal Haak, Sep 9, 2012.

  1. Mal Haak

    Mal Haak Member

    So I have Conquest of the Wizardlands.
    I purchased everything on steam.
    I am using the linux binaries that are included with the Steam version.

    I have made it to floor 4-5 for the last four new games and have not found any keys. I totally explore the entire floor.

    What am I doing wrong? Or have I found a bug?
  2. j3st3r

    j3st3r Member

    I assume with keys you mean lockpicks?

    I've always found some lockpicks on every floor, but I tend to save them during the first ones; use them only on chests, but kick your way through the doors.

    I know it can be a pain to constantly drop your stack of lockpicks to the ground before kicking the door in, but you get used to it. Also using one of the quick slots to store your lockpicks makes it faster to do this (no need to go through your inventory to find them)

    Also burglary skill tree hlps you save a ton of found lockpicks.

    If you mean those magical graffitis, then you're just having a bad luck; I've only noticed couple floors without any graffitis.

    You could always use graffitis that other players have found. There's one thread almost next to yours that lets you know propably all of them :p
  3. Mashirafen

    Mashirafen Member

    I think he means the wizard keys that let you enter the pocket dimension.

    Unless you've had incredibly bad RNG luck and it's kept spawning them in some hidden room or some inaccessible area, it's probably a bug.
    Mal Haak likes this.
  4. Mal Haak

    Mal Haak Member

    Yep. It's looking like that. I also got a segfault starting a new game.
    I deleted all my 'saved settings' and saved games and stuff... that made some of the extra content start working (I saw new room segments and stuff I'd never seen before) but 5 new games later (played until I died, usually around level 5-6) and not a single set of Wizard keys have been located. I'm not sure if there is something else I am missing (like having killed Dredmor or something) or it's a bug. Anybody got any ideas how to test for this
  5. Mashirafen

    Mashirafen Member

    If you're playing on Steam, you might want to try verifying the integrity of the game cache if you're having/have had those kinds of problems. It's under Properties > Local Files if you right click on it in your library.
    Mal Haak likes this.
  6. Daynab

    Daynab Community Moderator Staff Member

    That's strange. They should spawn on every floor until you pick them up.
    Mal Haak likes this.
  7. Mal Haak

    Mal Haak Member

    I did one better. I uninstalled and re-installed. I also deleted all my saves and other data generated by the game. First time I went to start a new game it segfaulted. Second time it worked, I did see some different room segements that I had never seen, but still no luck with the keys.
    Yeah, I thought so. Hence my posting here. I'm hoping that one of the dev's might take notice and lend a hand. Or tell me some 'super secret squirrel' way of enabling some kind of debug mode to see if I'm right or just crap at dungeoneering.

    EDIT:left out a whole word :D
  8. Null

    Null Will Mod for Digglebucks

    Temporary hax to get a key:
    Go into your data to your roomdb.xml,
    add this line at the end of the starting room

    <element type="wizardkey" x="4" y="12"/>
    make sure it comes before the </room>

    To enable debug mode you just put -debug-flag in the arguments, but that doesn't help you find a key.
    OmniaNigrum and Kazeto like this.
  9. Mal Haak

    Mal Haak Member

    You sure, on save load it shows it spawning all the elements to the floor your on. So like monsters and weapons and such... would it not also show "spawing wizard keys"

    Which is what I think this is in the most recent load, "creating a MagicBoxKey"
    This is on my third re-install and only after going into debug mode and hitting L then saving and loading
  10. Mal Haak

    Mal Haak Member

    Annnnd, no keys. Something is definitely fishy.
  11. Daynab

    Daynab Community Moderator Staff Member

    Try reinstalling?
  12. j3st3r

    j3st3r Member

    He's tried that.

    I also suggest that you verify the integrity of the games cache. I had to reinstall the game two times and both times the game didn't install some of the dlc's for some reason. Only thing that fixed this to me was checking the integrity of the games cache.
  13. You do realize that the key in question appears to be a small tablet and not a literal key, right? It just seems to bear double-checking.

    (Why yes, I used to work tech support. Why do you ask?)