Monstrous Megapack (monsters/items/rooms) 1.2.2 released

Discussion in 'Mod Releases' started by bluehinter, Mar 3, 2013.

  1. bluehinter

    bluehinter Member

    06-16-2014 UPDATE: New version 1.2.1 is now available
    (the file name is the same, so you can overwrite the existing zip file if you already have it)
    This version has also been released on Steam, and adds the Hall of Monty, Shock Mazes, Diggle Temple, plus a few more miscellaneous surprises.

    Another weekend, another special room based off a classic sequencing puzzle.

    The room contains 7 custombreakable objects (Skull, Moon, Mountain, Stars, Egg, Sun, Waves) which must be hit in the correct order to open up a secret passageway. The 5 inscriptions at the top of the room provide enough information to figure the order out logically, using the following clues:

    1. Before all things, there were the stars.
    2. As death follows life, so must the moon follow the sun
    3. Before the land came the sea, life itself came after thee.
    4. Death comes to all in the end.
    5. It is said without the moon, there could be no sea.

    Essentially what's happening from a mechanical perspective is that each correct "hit" advances an invisible customblocker slider one space to the right. Ever time you hit a button, it checks to see if the slider is in the correct position. If it is, it advances it one space to the right. If not, it sends it back "home," forcing the player to start over again.

    <script repeat="-1">
    <condition condition_type="event" event_type="hit" id="Sun Break"/>
    <condition condition_type="at" at="1" id="Slider"/>
    <action on="success" action_type="ticker" text="You hear a soft click..."/>
    <action on="success" action_type="move" id="Slider" at="2"/>
    <action on="success" action_type="spell" casts="Temple Right"/>
    <script repeat="-1">
    <condition condition_type="event" event_type="hit" id="Sun Break"/>
    <condition condition_type="at" x="3" y="2" id="Slider"/>
    <action on="success" action_type="ticker" text="You hear a loud grating noise..."/>
    <action on="success" action_type="move" id="Slider" x="3" y="2"/>
    <action on="success" action_type="spell" casts="Temple Wrong"/>

    The only down side is that I wasn't able to use not="1" for my incorrect choices, because moving the slider to the right automatically triggered the incorrect response. In the end, I had to create six scripts for each position.

    Removing the wall reveals a room filled with zorkmids the potential for 3 randomized artifacts, and the Diggle Ark. You're free to grab the loot, but if you touch the Ark (or damage it with a fireball or other explosion) Divine Retribution will be visited upon you, which is a fun triggerfromlist template spell that calls down random lightning bolts targeting you or each of the eight squares surrounding you for several turns.
    Last edited: Jun 16, 2014
    Vitellozzo, TJSlipperman and Daynab like this.
  2. Daynab

    Daynab Community Moderator Staff Member

    I'm really impressed with the awesome stuff you keep coming up with!
    Vitellozzo likes this.
  3. Vitellozzo

    Vitellozzo Member

    The Ark! The Ark! We finally found it!

    I told it before: the boy has amazing skills!
  4. Kaidelong

    Kaidelong Member

    Dadmor's left attack sprite XML is missing, apparently. Don't invoke dadmor if you don't want your game to crash.
  5. bluehinter

    bluehinter Member

    Sonofa... I have no idea how the hell that happened. I play-tested the hell out of the mod, but I get the same error myself when I play the version on Steam. I think it's just a capitalization error, and an easy fix, but as to how it got changed between test versions, I have no clue (unless it only causes a crash for people running the Steam version).

    I'll fix that post haste, and it looks like you guys are going to get another update with a couple of new rooms later this weekend.
    Before I release 1.2.2, can anybody tell me if there's a way to scale the amount of gold loot in a room? Somebody mentioned something about using ZorkmidsF but I can't find a solid reference point.

    The only new room I've completed since the last version is the Dredmorian Bank, which will appear on a couple of different levels and has a vault with a 3-digit combination lock. The vault mechanics work fine, but I'd like to be able to increase the size of the zorkmid piles contained inside (After all, it looks a little bare, especially on the lower levels).

    Does anyone have any suggestions? I'm currently having the treasure spawn as a result of a script to prevent potential teleport-looting:

    <action on="success" action_type="create" create_type="loot" type="zorkmids" x="3" y="2" />

    Edit: As usual, I kept adding to the room until it's now waaaaay more complicated than before. The number tiles now cycle all the way from 0 to 9 (rather than 1 through 6 like I started with) and I've come up with 5 separate room variants, each with it's own queue of monsters and unique combination lock puzzle.

    The first two variants have a 3-digit combination, and the last three have a 4-digit combo. Since the room design is essentially the same, I might add a few other variants if I can think up any more clever number puzzles.

    The 5 combo clues I have so far are:

    1) [3 digit combo] A small scrap of paper on the ground which appears to read 'LIE'

    2) [3 digit combo] It's only the largest palindromic prime you can enter. Duh!

    3) [4 digit combo] Security inside the vault has been doubled, just like the new combination.

    4) [4 digit combo] From now on, the vault combination will be changed every day. Day 1 - 8753, Day 2 - 3875, Day 3 - 5387 (the rest of the note has been torn off)

    5) [4 digit combo] All four digits are different, each digit is smaller than the last, and it's divisible by 519.

    I've tried to make sure
    each puzzle can be solved with a piece of paper or at least a reasonable bit of common sense. For example, #2 is pretty easy even if you don't know your prime numbers. Just knowing that it's a large palindromic 3 digit number should only take a few minutes even if you're guessing.

    EDIT: Just added a sixth and final variant for the clockwork level, with a bit of a surprise for anyone who's robbed any of the previous banks. Speaking of surprises, I've also taken a cue from the Hall of Monty and added a failsafe that flambes anyone trying to bypass the vault security through means of teleportation or digging (this also means you can't accidentally get stuck in the vault if you drank an instability potion or used some other means of one-way travel to get there)
    Last edited: Jul 20, 2014
    Vitellozzo likes this.
  6. Vitellozzo

    Vitellozzo Member

    Keep rocking it like the motherdredmor. :upvote:
  7. bluehinter

    bluehinter Member

    Sweet! Thanks to Bohandas, I now have the zorkmid loot problem sorted.
    1.2.2 can go out whenever, but I'll probably release it later this weekend, since I've moved on to a few other rooms.

    I just added a fifth Wizard Pub (actually a Wizard comedy club, with an extremely annoying "comedian" named Carrot Tip who heckles you if stand anywhere near the stage) and three different "Barrel Forts" (because the dungeon doesn't have enough couch cushions)

  8. Kyrris

    Kyrris Member

    Hi, @bluehinter. I really love what you add in flavor to the game, but I'm having terrible trouble with corrupted saves. Every time I try to reload an old one, I'm told that Monstrous Megapack couldn't be loaded, at which point DoD crashes. I've no idea why I'm the only one, apparently, to report this problem, but it doesn't happen when I don't load MM.

    I'm running with all three expansions, naturally, since I can create new games with MM included just fine. It's only the savegame corruption that keeps me from running this mod. If there's a crashlog file somewhere that I could pastebin for you, I'd be happy to. Otherwise, any advice?

    (If it's relevant, I'm using the Steam Workshop to plug in the mod.)
  9. Vitellozzo

    Vitellozzo Member

    Mmmh, try using always the direct download of this forums instead of steam workshop, since usually it works bad if it works at all.
    And, by the way, are you using other mods with this in that corrupted save game?
  10. Kyrris

    Kyrris Member

    Of course. Couple dozen. But removing MM eliminates the problem, whereas randomly going through the rest of the list to test if a specific other mod or combination (What's 25C5, again?) is creating some sort of save-corrupting conflict with only this mod takes hours. If there's no easier solution forthcoming, I'll put in the labor, but perhaps blue knows that something else specifically causes conflicts.

    79 other mods. So you understand why I am loathe to go aggressively digging through that list at an average turn-around of five minutes for every mod combination tested. And I should stress that it is not a corrupted save that I am experiencing; it is the corruption of any save made with MM installed. More specifically, it is the corruption of such saves when the program is fully exited. I can Save&Quit then immediately reload the save without problems. If I fully Exit DoD and restart the game, the image of the corrupted save consistently shows one skill icon and six black squares, and that save cannot be loaded. The same 79 mods without MM installed do not cause this problem.

    @bluehinter - If you even suspect that it's a type of other mod causing the conflict—room adders, phonemes, dialogues, skills, items, recipes, you name it and I have at least one—that would help to narrow the search for the problem. It isn't Steam; direct download experiences identical issues.
    Last edited: Jul 19, 2014
    Vitellozzo likes this.
  11. bluehinter

    bluehinter Member

    Sorry Kyrris, I have no idea. I've tried loading multiple save games myself (even ones that were created using older versions of the mod) and I can't duplicate the error. Admittedly, I don't have 79 mods loaded, though I'm not sure why MM and only MM would be the catalyst. It's strange that it would show a graphical glitch for the skills icons, since that's the one bit I haven't included with this mod.
  12. bluehinter

    bluehinter Member

    07-20-2014 UPDATE: New version 1.2.2 is now available
    (the file name is the same, so you can overwrite the existing zip file if you already have it)
    This version has also been released on Steam, and fixes the Dredmor family crash, and adds bank vaults, barrel forts, and the wizard comedy club.
    Vitellozzo likes this.
  13. Vitellozzo

    Vitellozzo Member

    I must admit, even I use lots of mods, and in the last months I've come through a series of corrupted save games. I don't expect MM being directly the problem here, since I can recall playing with it since the very first versions of it... but since I always updated the mod every time a version got out, I sincerly cannot recall when it started corrupting my games.
    The game says something to you when you try to load the corrupted saved games, Kyrris?
  14. Noma

    Noma Member

    Just ran into the Dredmorian Bank on level 5. Big fan. Decided to code up a python script to solve it (attached) versus googling it.

    It reminded me of these problems over at ProjectEuler... if you were looking for new challenge questions, definitely worth a look :)

    Edit: Game crashed unexpectedly late last night on level 6 as I tried to kill a jumpity gnome (I think that was their name; purple guys). Used a Recursive curse on him and crashed to desktop. The only other mod I'm using is 'Death by 1000 Taunts'. It's possible the gnome was attempting to use a bad taunt and their mod caused it; not sure. Are there any log files that get generated that I can take a look at to confirm?

    Attached Files:

    Last edited: Aug 10, 2014
    bluehinter likes this.
  15. Bohandas

    Bohandas Member

    As described here this sounds like part of a more general glitch that occurs doe to the way Dungeons of Dredmor stores savegames:

    Each save includes a copy of every mod that that particular game uses, so that mods can be changed or added or removed from the game as a whole without preventing the save from loading. Unfortuantely a saved game's internal copy of one or more of its associated mods will sometimes become corrupted, preventing the save from being able to load. If you look in the folder for that particular save and find a file or folder with a filesize of zero and the name of the unloadable mod then this is your problem. It can usually be corrected by pasting in an uncorrupted copy of the same file from a different savegame.
    bluehinter likes this.
  16. bluehinter

    bluehinter Member

    I haven't had much free time lately, but with a few days of vacation coming up, I'm thinking of adding a new monster to the mix called 'The Abstract.' My first thought was for an actual Picasso themed abstract with a sort of spinny-wheel arm thing, but then I realized I had no clue how I was going to draw the thing from the other 4 sides. The finished product also looks a bit too cartoony for my tastes. It might just be the extra thick lines, but it doesn't quite seem to match the style of artwork I've come to associate with the game.

    Now I'm thinking of going with a slightly more alien extra-dimensional lava lamp approach, with a sort of twisty distorting vase thing for a body and a bunch of hovering eyeballs up top. I'm not quite sure how it will "attack." Maybe I'll make it shake and turn a slightly darker hue while shooting its eyeballs out at you.

    After that, I may work on a few skills, since I haven't done any of those in a while. I'll probably adapt Nudist, even though there isn't a way to actively enforce the "no wearing clothes" policy. I can still have a power set that lowers :armor_asorb: and :block: when you activate it, and causes a flesh-colored pixellated halo effect to occur over the player as an animation, so it looks like something rude has just happened.

    High Roller won't be as much fun without slot machines, but having a power set based on luck could still be pretty fun, and I can base the probability of the choosefromlist on actual dice rolls.
    Vitellozzo likes this.
  17. Alistaire

    Alistaire Member

    Add a second shade to it and remove the black outline, then you've got the DoD monster style.
  18. Vitellozzo

    Vitellozzo Member

    Goops tend to autodie from their own sticky mucus, becoming less than a danger for my monk.
  19. Vitellozzo

    Vitellozzo Member

    A Crimson Goop just told me "Die, silly shaped thing".
    I felt bad.
  20. birb

    birb Member

    So I recognize that this topic and Dredmor is general is a pretty old game by this point, but I got back into it recently and have been working around with quite a few mods, and I have to say this Megapack is unquestionably one of my favorites. The amount of things you put in here, not to mention how very well they fit into the game in both practical and meta terms, is phenomenal. No other mod does this sort of thing, or at least doesn't do it nearly as well.

    However, in the interest of asking a question I've been wrestling with on my latest playthrough, I want to know if it's possible to remove only the monsters from the mod and still have it be functional. I'm not terribly good with coding or anything, and I don't want to screw something up and spend unnecessary hours trying to unbotch something when someone else could direct me to a proper answer much quicker and more easily. It's not that I don't like the monsters (well, some of them maybe...) but my big gripe is that all but one of them seem to have very... over-the-top animations for everything, and for several reasons they fluster me. A lot.

    I constantly fret that my game is freezing up when, say, I encounter a Monster Zoo and during the ensuing brouhaha the monsters' turn is prolonged to about fifteen seconds (and this is pretty much every turn until some of the monsters die or lose interest in me for a bit) and my guy's sprite gets stuck in a very odd animation because it's waiting for three fragiggling Toupees to complete their animations for a spell. The Roamers tend to be the worst offenders in this category though, since every single attack they have is basically equivalent in frame-length to a spell, and even their 'melee' attack takes several more frames than any other monster's. This may sound like a bit of a petty complaint, but trust me when I say it's actually caused my game to go a tits up a few times. I love the entirety of the rest of this mod though, which is why I'd rather know how to simply remove the monsters instead of deleting the whole thing, because I'd really like to keep the items and sweet-ass special rooms you've modded in.

    Again, I understand that since this game and even this thread and mod are pretty old that I'm liable to not even get an answer, but I'm putting this in here hoping all the same.
    tl;dr: Can someone please tell me if/how I may remove the monsters and just the monsters from this mod without screwing it up so I can keep the rest of it working?