Windows 8 64-bit Missing GUI elements [possible scaling issue with QHD+ display?]

Discussion in 'Bugs' started by potokslow, Sep 7, 2014.

  1. potokslow

    potokslow Member


    I have recently installed Dungeons of Dredmor on a new Windows 8.1 x64 system and I'm experiencing following issues:
    • When "fullscreen?" setting is unchecked, the game will launch in fullscreen mode (or at least occupy whole screen without showing window borders) in resolutions 1600x900 and above;
    • When checked and set to native resolution (3200x1800), the game screen is not displayed correctly - i.e. some of it is missing (see screenshot 1 - missing game name/logo) switching out and back into the game via ALT+TAB breaks the display (see screenshot 2) and hangs the game (can't exit using ALT+F4, needs to be killed via task manager), behavior is the same with "smooth scaling?" ON/OFF;
    • When in full screen and set to native resolution (3200x1800), some GUI elements are not visible - e.g. the confirmation buttons, character info, etc. (see screenshots 3 and 4);
    • When in full screen and set to next available resolution (2048x1536), or some of the lower ones, screen seems to be displayed more correctly, but mouse cursor becomes erratic (i.e. does not always move in proper direction - e.g. move mouse left, cursor may go right or in other direction);
    • The highest resolution where the whole window is visible on screen in windowed mode is 1280x800 (in higher resolutions parts of the window are outside of display);
    • When using 1280x800 in fulscreen mode, game seems to be displayed correctly, but it switches back to Windows desktop;
    Screenshot 1:

    Screenshot 2:

    Screenshot 3:

    Screenshot 4:

    Game is running via Steam, most recent version installed, video drivers recently updated.

    Relevant system specs:
    OS: Windows 8.1 x64
    Graphics: Intel Iris Pro Graphics 5200 / NVIDIA GeForce GTX 870M
    Native resolution: 3200x1800

    To summarize the situation - the game is playable, but not on default settings.
    I can use as it is, but I thought this was worth documenting in case someone got similar issue.

    Please let me know in case you have any suggestions, or need more details.

    Thank you and best regards
  2. Skorrn

    Skorrn Member

    I'm just going to bump this with my similar issue because I couldn't figure out how to start the game.

    That's all I see and it won't let me go any further. I've tried the enter key, checking for driver updates, reinstalling, verifying the game cache's integrity, clicking where the buttons should be; but I haven't had any luck as of yet.

    The last time I played, I needed this to continue:

    I'm running Windows 8.1 x64 also if that has anything to do with it.
    GPUs: Intel HD Graphics 4600/Nvidia GeForce GT 740M
    Native Res: 1920x1080

    Thank you for your support,
  3. potokslow

    potokslow Member

    That's exactly what's happening for me if I run in full screen mode.
    The way it worked for me was to run the game in windowed mode in resolution 1280x800 or lower - i.e. unchecking the 'fullscreen?' and setting the resolution manually in the launcher.
  4. Skorrn

    Skorrn Member

    Worked. I wish I could play fullscreen though
  5. Daynab

    Daynab Community Moderator Staff Member

    Do either of you have high DPI scaling enabled for text in windows? (like text-size zooming)
  6. potokslow

    potokslow Member

    Yes, scaling is enabled and configured as per system defaults (in my case, size slider in position 4 of 5).
    Otherwise the native resolution is impossible to work with.
  7. Daynab

    Daynab Community Moderator Staff Member

    Ok, go into the properties of clockwork empire.exe, under compatibility tab disable "display scaling on high DPI settings", it should fix your issue.
  8. potokslow

    potokslow Member

    Disabling mentioned setting allows the game to run properly while displaying all content, but the navigation gets a bit troublesome due to everything getting small.
    It's easier to leave the scaling on and play with reduced resolution in windowed mode.