Windows Vista/7 64-bit Making Steel, no go.

Discussion in 'Bugs' started by PurpleFox, Dec 20, 2011.

  1. PurpleFox

    PurpleFox Member

    I do not know if it was addressed, but there is no "Steel ingot" recipe. I have read it was due to the update. There are other things too, like "Venomous Infusion" is highlighted, but doesn't go into the skill bar for use, cannot use.

    My saved game is before the update I believe, before the new expansion of the Diggles.

    If there is a fix Please tell me, or suggest something other then "start a new game," if I'm looking at starting a new game I might just drop the game entirely (or for a very long time) and get a refund for the expansion.

    26 hours in, 5th dungeon level, lvl 17
    ::sad face::
     
  2. J-Factor

    J-Factor Member

    For the Steel recipe issue, try swapping your craftDB.xml with this one: http://j-factor.com/files/craftDB.xml

    You can find your craftDB.xml in '../steamapps/common/dungeons of dredmor/game/'. Backup your existing one just in case.

    No guarantee that it'll work but it's worth a shot.
     
  3. PurpleFox

    PurpleFox Member

    How do I obtain that file as a download?

    As it is, I do not know what to do with the infomation.
     
  4. Daynab

    Daynab Community Moderator Staff Member

    Right click - save page as....
     
  5. PurpleFox

    PurpleFox Member

    Oh yes. Thanks for the xml file J, and thanks to Daynab for the how to.

    So does this fix anything else in recipes I should know of?
     
  6. J-Factor

    J-Factor Member

    I'm assuming it worked then?

    All it does is reorder the recipes. When 1.08 was released all the new wand recipes were moved to the top of the 'recipe list'. This screwed up the old save files because they depend on the recipes staying in the same spot. I just moved the new wand recipes down to the bottom of the list.
     
  7. PurpleFox

    PurpleFox Member

    Well the steel ingot has shown up on your xml, but I think it leaves other things out, so I switch in between.

    Such as... I believe the Full Plate armor is missing in your xml, not too too sure. But definitely, things are in a different order.
     
  8. adler187

    adler187 Member

    I'm having this problem as well with crafting. On my old character everything is all messed up. I tried the xml file from the link and that fixes it for the most part, but everything is still not quite right. See some pics here: http://imageshack.us/g/215/tinkeringpartsupdated.png/ Notice that in the original images, everything is jumbled up, but mostly correct in the updated images, except say diggle nog at the top of the updated ingot press (and although you can't see it, copper plate boots at the bottom of the ingot press list), also clockwork power limb in ingot grinder list, mana torus, falx, nailboard mark II protoype, timberbane, ugly stick, knight's helmet, and maple shield in tinkering parts...

    This wouldn't have been an issue with the old style crafting system, but now that you need the recipe, it is quite annoying. Well, at least I have steel ingot back, but after taking the screenshots I discovered every time I move, I immediately teleport. I think I saw a thread opened for that issue already as well...