Mac and Linux Status Update

Discussion in 'Clockwork Empires General' started by Nicholas, Oct 31, 2014.

  1. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    The game runs incredibly slowly on my year-old iMac. Technically playable I suppose, but I don't think I have the patience for it.
    Colonists just kind of teleport across the screen without animation.
    Clicking and dragging is almost impossible, because there's a several second delay between the click and when the game figures out you've started to drag. So you have to start your drag area well away from what you actually want to select, and then drag really slowly. When eventually the rectangle appears it starts at wherever the mouse was after ~1 second of dragging.
    Moving between any of the command buttons has a long delay before the mouse-over tool-tip figures out where you are and updates.

    Trees aren't displaying, but their shadows are. Saplings (at least of the Aspen variety) display just fine.
    Shadows of Invisible Trees.jpg

    Workbenches and standing desks are invisible. Their ghost-images appear where you've designated them to go, but once construction is completed they vanish and the final image never appears. They still exist, though. The leader of the work crew stood at the invisible desk and wrote things in an invisible ledger using a normal/visible quill. I wasn't quite able to catch it on screenshot.

    I had one sizable square of ground that stayed solid black, even after fog of war was removed by a naturalist presumably walking right through it. (I was looking elsewhere at the time, but he at least passed very close to the corner of the square.)
    Black Square.jpg

    Changing performance settings to Shadows: Low, Terrain: Low, Reflections: Off, Ambient Occlusion: Off had no noticeable impact on speed/lag. Neither did changing it to High/High/On/On. There didn't seem to be much of a noticeable visual difference between any of these settings, either, but I didn't play long enough in most setting combos to get to the shoreline where presumably reflection on/off would matter.

    Technical specs:
    27-inch, Late 2013
    Processor 3.2 GHz Intel Core i5
    Memory 8 GB 1600 MHz DDR3 (2x 4GB slots installed of 4 possible)
    Graphics NVIDIA GeForce GT 755M 1024 MB
    Software OS X 10.9.5 (13F34) Mavericks (I'd be happy to upgrade to Yosemite if you think that might help)
  2. Euel Ball

    Euel Ball Member

    Still no trees, and the "left click and drag" selecting box is as clumsy as a drunken solider...
    Exile likes this.
  3. Nicholas

    Nicholas Technology Director Staff Member

    It looks like I have a handful of stuff to fix then. Hmm.

    When you say the click-drag box is clumsy, is the issue that the frame rate makes it unmanageable, or...?
    Exile likes this.
  4. Euel Ball

    Euel Ball Member

    O.K., I click to select an area, it takes several seconds to register. I drag it, and it selects only the last quarter of the area I select, and it only lets me select an area one or two times before the area selection thingie just doesn't work anymore...
    Exile likes this.
  5. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    What Euel Ball is describing matches my experience with the drag and click as well. The game takes nearly 2 full seconds to figure out that you are clicking and dragging, and then when it does so it starts the box not where you first clicked, but whereever the mouse is at the second when it acknowledges it. For me, I can get it to select almost the entire area I want, but it's not easy. I have to hold down the button, move my cursor the first 2 to 4 pixels and wait for the game to catch up with me before moving the mouse any further. It will draw the box from the place where I paused, not the place where I clicked.

    Everything is painfully slow, and I end up giving up on the game entirely after a couple minutes of trying to play.

    As reported earlier, changing my configuration settings doesn't have a noticeable effect on the frame rate or lag at all. Disabling full screen and setting it in a window (plus simultaneously setting all configs to lowest options) did kind of seem to make it run a tiny bit faster today, but still too slow to be worth playing. Animations were still really jumpy, but people didn't teleport quite as far per step.

    Trees are invisible. Saplings and tree stumps are not. The invisible trees still cast shadows.

    Some surface nodes are invisible, but rhyolite boulders are not.

    I tried to put a door on the northwest edge of my floorplan for a carpenters shop. The door icon stubbornly refused to turn to face the wall correctly. After waiting about 10 seconds, I clicked to place it anyway, and it just vanished.

    On the main menu, when I click the "credits" button, the game crashes.
    Euel Ball likes this.
  6. Danl

    Danl Member

    No problems with responsiveness or clicking/dragging here. There are a good number of other things that don't render - some food items I can't remember exactly which, metal sheets, most of the workshop modules, other stuff. One really annoying one is the military rally beacon - once set I can't cancel it so the dudes just walk around in circles until I rally them somewhere else or something like tiredness or hunger intervenes. The game can be relied on to suddenly crash after 15-20 mins or so. Fortunately save/load works very well!
    Macbook retina i7 2.3, GT 750M 2Gb
  7. DerkyTurkey

    DerkyTurkey Member

    Is there any word on how the Linux support is coming along?
  8. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    Steam downloaded a new build to my Mac today.

    The good news: Trees are no longer invisible. I saw aspens and pines, and none of the modules in my workshop were invisible either.

    The bad news: Everything is running even more slowly than it did before, and I found it mostly unplayable on my Mac before this increased lag. So I still didn't get more than a few buildings into the game before giving up in frustration.
  9. Nicholas

    Nicholas Technology Director Staff Member

    The issue with the slowdown seems to be that - on some video cards - we are triggering a mysterious Video Rendering Error. I have it on one of the test Macs in the office now, so that's good; I just need to find time with Micah to get the debugging toolchain set up on this Mac to the point where I can fix it. So we're tracking stuff down.

    Linux support is me and Andrew and Ryan playing tag on a bunch of stupid compiler nonsense, still, forever, while whoever is not dealing with the issues opens their mouth and bees come out. (So... ongoing.)
    Exile, Euel Ball and r_b_bergstrom like this.
  10. Danl

    Danl Member

    r35. Just played through to about day 10 before a crash. Everything seems to be visible now, including the military rally point - yippee. Only issue other than the crash was seeing some colonists walking through walls in order to build ovens. All looking good. Looking forward to building up a real colony rather than not getting beyond the basics.
    Euel Ball likes this.
  11. Nicholas

    Nicholas Technology Director Staff Member

    So I swore a blue streak at the office Mac today, and finally wondered if the issue which Bergstrom and everybody else has experienced was that I was not running Yosemite. Sure enough, I do that, the same EXE goes from 1 FPS to 16.

    So, yeah. Upgrade to Yosemite! (NVIDIA also seems to have released some sort of special drivers today, maybe, that might be helping things.)
    Exile likes this.
  12. Danl

    Danl Member

    Played some out as far as around day 12. Gets quite crash after day 8ish. I think some rendering bugs are common to the pc version - tools appearing as food items seems quite common. Pathfinding bugs resulting in starvation. Moving built doors does weird things to walls. I can't rotate modules with my macbook's trackpad, will have to try that with a mouse and see but that is potentially a mac specific problem (or maybe just me). Stockpiles are very hit and miss whether the filter works. The work crew pane has issues: always opens with the rows half way down the screen - have to grab the vertical slider and move them up. Then it does a lot of dancing up and down making it hard to hit your target. Loving the steady progress.
  13. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    Upgraded to Yosemite, and indeed the game became playable. Animations look smooth and beautiful now.

    Click and drag still selects a smaller area than I tell it to, though. If I try to select a 10x10 area (imaginary units) it will usually not select the first row and column, but selects everything else. Dragging really really slowly solves this, but it's still annoying.

    I'm now getting crashes after about 20 minutes of play, and I haven't got any ideas what's triggering them. But, hey, those first ~20 minutes look great, and that's a huge improvement from where it was on this machine last week. Thanks, Nicholas!
  14. Nicholas

    Nicholas Technology Director Staff Member

    Some bugs are definitely Mac specific; Micah is getting them as well. I'm not sure what's up with the click-and-drag not working - are you referring to the farm drawing, or the other drawing?
    Exile likes this.
  15. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    The "10x10 imaginary units" thing was poor phrasing on my part. Just ignore that statement, as it only makes it more confusing than it needs to be. I'll rephrase:

    I'm referring to just selecting things in general. Like if I want to select a big bunch of trees and give the order to chop them all. Or a big area of mushrooms to forage. Doing so suffers from noticeable lag that results in only selecting maybe 80% of what you intended to select. It's like it takes the game a full second to realize I've been clicking and dragging, and only then does it start to draw the rectangle from where ever my cursor is at that second, not where I started dragging from the second before. It's not hard to work around, but it's often annoying. I don't think it's user error; I'm not dragging super fast, just a normal speed that works in other programs. Probably not a specific bug, so much as just a performance issue. I think.
  16. Mikel

    Mikel Waiting On Paperwork From The Ministry. Forever.

    I played for a bit on a PC tonight... I was terribly disappointed at how much more stable it was than my Mac.
    Exile likes this.
  17. Danl

    Danl Member

    35C - lots of trouble with this one! Very crashy to the extent that its unplayable, haven't successfully saved or loaded a game, have seen the dreaded script errors back too. The military are odd - e.g. whole squad ambles up to a fishy attacker and stands around doing nothing while it beats them up. On the up side, stockpiles seem to do their job better...
  18. Daynab

    Daynab Community Moderator Staff Member

    Rev 35D should now be up, let us know if anything of this is happening there.
  19. Nicholas

    Nicholas Technology Director Staff Member

    Linux build status: uuuuuuuuuuuuuuugh. Well, it builds now on our build machine. Now what is left is a bunch of Steam packaging work, and then we can proceed to testing!
    Exile likes this.
  20. Danl

    Danl Member

    35D much better. Phew.

    Have battled through to day 12ish I think, about 50 colonists. By battling, I mean against the crashes. They come thick and fast by then. Usually pretty random. Crashes during saves are a new thing with 35C/D though.

    Most other bugs I've seen aren't mac specific and are documented by others elsewhere.
    Last edited: Feb 18, 2015