DoD Modding and Mod Installation Guide (Updated 6/5/2012)

Discussion in 'Modding' started by Daynab, Dec 1, 2011.

  1. Kazeto

    Kazeto Member

    Which folder, and what operating system, and why not "mods"?
  2. kino5

    kino5 Member

    Try checking it with a XML validator and writing it step by step, testing that every skill works after writing another one. If you follow this guide and use an already made mod to look how to do things, you should have no problem. Also, if you specify a little more, there are plenty of people around here (including myself) that can help you :)
  3. badboy80

    badboy80 Member

    What? You need to put all your files in a zip file (I think it can be a folder too) in the the Dungeons of Dredmor folder that is in the Gaslamp Games folder in My Documents. That is, if you are on Windows
  4. Daynab

    Daynab Community Moderator Staff Member

    I just updated the OP to have all the new information and guides from the new modding wiki, formatting might be a little strange, let me know if anything's missing.
  5. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    I do not think the recent changes to the OP were entirely good. It no longer explains where you have to put the files, which at least for Mac using Steam, is not intuitive. The page you linked to on the wiki is the page for uploading a mod, not installing one. Newbs coming here to figure out how to get started using their first non-Steam-Workshop mod would face significant hurdles.
  6. Daynab

    Daynab Community Moderator Staff Member

    Oops. I knew I was forgetting things. You're right I need to update the directories. But the info I have under "Installing a mod" is exactly the same info I had before, except it assumes the mods are packaged correctly?
    edit: updated the directories, thanks for the heads up.
  7. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    I started typing up where it should be listed for a Mac, and now suddenly it lists it properly for Mac and Linux. I see an orphaned "folder." that suggests to me you ninja edited while I was typing.

    Looks good now, other than the orphaned "folder."
  8. Daynab

    Daynab Community Moderator Staff Member

    Yup, caught that. Thanks :) Let me know if there's anything else amiss or missing.
  9. Zero Beat

    Zero Beat Member

    Can someone explain how to install?
  10. Glazed

    Glazed Member

    It's right in the first post:

    Or you can subscribe to mods in the Steam Workshop.

    In both cases, you must also make sure the mod is enabled. You do that by launching Dredmor and clicking the Mods button. And then check-marking the mods you want to load.
  11. Wayfinder

    Wayfinder Member

    I created folder "mods" in the correct directory, than put there a mod, but it isn't displayed in Mod Launcher. What shall I do?
    My Windows are in Russian, so "Documents" folder have russian name, can this be a problem?
  12. Wayfinder

    Wayfinder Member

    UPD: Set the English language, but it doesn't work still.

    Also, i tried to download those mods via Steam Workshop. Fail.
  13. Daynab

    Daynab Community Moderator Staff Member

    Unfortunately yes, it's a known issue that usernames with special characters currently cannot load mods.

    It is possible to change that but I don't know if it's something that you want to go through.
  14. Wayfinder

    Wayfinder Member

    I found the problem. My username folder is in Russian. And i cant change it.
  15. Daynab

    Daynab Community Moderator Staff Member

  16. OmniaNigrum

    OmniaNigrum Member

    I found a guide for how to do this on XP years ago. And since XP is the same kernel of 2000, those are covered. Vista and Seven should both use the same method too since they share a kernel. If you are using anything older than XP/2000 then you are probably out of luck though.

    I did a search and found this utility that claims to do this for all current Windows OSes.

    It is free, but I am unsure if it works or not. If you need some help, I would be glad to assist in any way I can. Keep us updated if you need anything or run into any problems.
  17. So, I've got my mod showing up in the mod selector screen, and the abilities I have are mostly working right, but the problem I'm having is importing outside resources, specifically art. I have them in a sprites/skills/whatever folder, and it passes the validator, and the game loads, but the second it needs to display one of the custom images, it crashes. Works fine if I use images that are already in the game, but I can't seem to do it with the mod. Obviously you can do it, since every other modder has, so maybe I don't have the format right? Can a modder who's imported custom art tell me how they have it structured and referenced in their code? Thanks!
  18. Kazeto

    Kazeto Member

    I reckon it's the problem with icons and not with the code, Prince of Foxes. Icons have to be indexed and stuff, and the validator just detects whether they are there at all.
  19. FaxCelestis

    FaxCelestis Will Mod for Digglebucks

    Skill sprites need to be 32x32 (for small) or 64x64 .pngs. RGB/Indexed doesn't matter in this case.

    For items, they must be 32x32 indexed .pngs.

    Monsters follow the same rules as items, but must be 64x64.

    Blockers may be in RGB or indexed, but must have their dimensions in multiples of 8.

    For spell effects, they must be RGB .pngs that have their dimensions in multiples of 8. Their path names must follow the style of spell_name00xx.png, where xx is the frame number, starting with 00 and progressing through 99.

    If you're doing your editing in GIMP, your indexed sprites will crash the game, because GIMP doesn't know how to index .pngs properly. If you're dead set on GIMP (or it's the only thing you have) you can do what I do and do all your drawing in GIMP, index it, then open it in mtPaint, then reindex it by converting to RGB and back to indexed.
    OmniNegro likes this.
  20. Alright, I'll see what I can do. I don't have any art programs other than MSPaint, anyway. Ha ha.