Windows Vista/7 64-bit Display issues: game doesn't fit on screen

Discussion in 'Bugs' started by Miner0, Jan 9, 2013.

  1. Miner0

    Miner0 Member

    So I have a VAIO Win 7 laptop with native resolution 1600 x 900. With any combination of resolution and fullscreen/windowed from the launcher the game window doesn't fit on the screen, even nearly. I have an ATI mobility Radeon HD 5650 that I have the most recent available drivers for. I have not had a similar problem with any other game or application. I've tried fiddling with the screen resolution as well to no avail. Any ideas?

    Here's an example of how it looks in windowed mode 1024 X 786

    ScreenHunter_27 Jan. 09 13.09.jpg
  2. Daynab

    Daynab Community Moderator Staff Member

    This is really weird and we're not sure what's happening. I don't have much to suggest beyond trying a reinstall...

    Maybe one thing, add "-opengl" to the game's launch options and see if it changes anything.
  3. Miner0

    Miner0 Member

    Reinstalling did nothing. The -opengl parameter also fails.
  4. Daynab

    Daynab Community Moderator Staff Member

    Okay can you take a bigger screenshot or explain if what is happening is either the game window somehow not containing the full game or if it's just too big for your screen?
  5. Miner0

    Miner0 Member

    That's the entire screen with those settings. If I move the cursor down to the task bar and let it hover on the game tab, the thumbnail will display the game normally. So whatever that means...

    ScreenHunter_29 Jan. 11 11.21.jpg

    For any other settings it's even worse. This is the same resolution but fullscreen. Note that I can move the cursor below and to the right of the screen in case that's significant.

    ScreenHunter_30 Jan. 11 11.26.jpg

    This last one is in windowed mode at 1280 X 786. Note that I can't even see the window's borders at all!

    ScreenHunter_30 Jan. 11 11.32.jpg
  6. Daynab

    Daynab Community Moderator Staff Member

    This is a dumb question, but are you sure your desktop is actually on 1600 x 900 right now? That's the only explanation I could think of at the moment, we're trying to figure this out though.
  7. Miner0

    Miner0 Member

    It is.
  8. MusingOoze

    MusingOoze Member

    1. Go to the folder where you have Dungeons of dredmor installed
    2. Right click on "Dungeons of Dredmor.exe" and select properties
    3. Click the compatibility tab at the top of the properties window
    4. Put a tick in the 'Disable display scaling on high DPI settings' check box.
    From your images I think your have windows 7 display set at 150% DPI so your windowed windows are 150% bigger and full screen only shows 4/9 of the game screen.

    Good luck! :)
    Daynab likes this.
  9. Miner0

    Miner0 Member

    My gosh! I feel like I should know this much about my OS :)! That was precisely the problem and precisely the solution. Haha. You live and you learn, boys and girls.

    Thanks a lot!
  10. Daynab

    Daynab Community Moderator Staff Member

    Oh wow, that's good to know. Thanks a lot.