Crashing on Exiting Mysterious Portal

Discussion in 'Bugs' started by eltrov, Aug 1, 2012.

  1. eltrov

    eltrov Member

    I had managed to fight my way through a dimension of evil with a ridiculously strong sword only to find that when I try and exit via the Mysterious Portal the dungeon collapses :( I've tried it about ten times now and every time it just closes out the game entirely. Is anyone else having trouble with crashes similar to this?

    I've attached a zip with my save file in it if that's any help.

    Attached Files:

  2. Daynab

    Daynab Community Moderator Staff Member

    Thanks for the save, we'll take a look at it.
  3. Nicholas

    Nicholas Technology Director Staff Member

    A save! FINALLY.

    I'll sort this out tomorrow. Hold onto your save game.
  4. jadkni

    jadkni Member

    I'm experiencing the same thing with a good old Mysterious Portal from RotDG now.

    Such a good one too! Got out with some crazy 10-star gear on floor 2. Or would have gotten out, rather.
  5. diablothe2nd

    diablothe2nd Member

    I'm having the same issue, cannot get out of the portal area after doing a few of them.

    PS I found a hell code, used it, promptly died, and reloaded a save (not playing on hardcore mode). Since then I can no longer exit the portal.

    My save is also attached for you to look at.

    Attached Files:

  6. TamsusStan

    TamsusStan Member

    Hello, I've met the same problem after many(around 10 reloads) tries to step on the exit portal, and every time the dungeon collapses.

    Attached Files:

  7. Myxomatosis

    Myxomatosis Member

    Have the same problem, every time i try to exit the mysterious dimension the game crashes. Here is the save file.

    Attached Files:

  8. Myxomatosis

    Myxomatosis Member

  9. Daynab

    Daynab Community Moderator Staff Member

    Thank you for the saves, everyone.
  10. JordanScarlet

    JordanScarlet Member

    I tried this and still crashed. I think it's the fact of having no where to teleport back to on floor 1 since my portal was on floor 2.
  11. Azdron

    Azdron Member

    Oh no, I followed that advice and got out. But now I cant go downstairs! (past level three) LOL From one doom to the next..... Oh well ><
  12. SkyMuffin

    SkyMuffin Member

    same issue happened to me. also, it mysteriously ate my Autosave :confused:. Here's the manual save.

    try capital P?

    Edit: I tried debug mode and was able to get out of the Mysterious Portal realm by going up one floor to DL 1 (was on 2). However, the game got really weird on me.

    First, it wouldn't let me go down the stairs-- i'd get a slight delay as if loading and then end up on DL 1 again, no matter which staircase I took.

    I tried Capital P to go up a floor, and that didn't work. So I went to the Pocket Dimension and hit lowercase p to go back to DL 1. That worked. I took some stairs to DL 2, but when I got mysterious portal items were gone! The game reverted my equipment back to the items I had before I went into the Mysterious Portal. Lost a Monofilament sword and 15 AA armor :( Guess I'll just start a new game since the save files appear to be messed up.

    Anyway, here are the two save files from those shenanigans.

    Attached Files:

  13. quoth

    quoth Member

    same me!

    Attached Files:

  14. Daynab

    Daynab Community Moderator Staff Member

  15. diablothe2nd

    diablothe2nd Member

    Hotfix didn't work for me, it now immediately crashes to desktop when I try to leave the portal area on the broken save.

    do i need to start a fresh game for it to work?
  16. Daynab

    Daynab Community Moderator Staff Member

  17. diablothe2nd

    diablothe2nd Member

    ok, that one no longer crashes, it just teleports me to the spawn point of the Pocket Dimension even though i'm already in it :p

    the 30 turn cooldown shows, but I dont actually leave the dimension :p

    Attached Files:

  18. dystant

    dystant Member

    Same problem here -- can't leave via the blue mysterious portal. When I try to use the -debug-flag mode to move between floors, everything is fine until I try to move past the floor I was originally on (in this case, floor 3), in which case I get a CTD. The game also deleted my Auto Save, as reported above.

    Other than this, the first issue I've encountered, it's a brilliant game -- thanks to devs and testers for making it what it is.

    Edit: I forgot to add, I can't use the hotfixes because I'm on a Mac. If I have time I'll try to boot into Windows and apply them there, but I'll more likely just start a new character.
  19. Harry Lime

    Harry Lime Member

    Dystant, you said
    Edit: I forgot to add, I can't use the hotfixes because I'm on a Mac. If I have time I'll try to boot into Windows and apply them there, but I'll more likely just start a new character.

    You posted this a few years back and I have been wondering if you are on a Mac how are you running in debug mode? Were you playing DoD on a windows partition or through Crossover? I am clueless how a debug mode is set up on a Mac since there isn't a target to run the -debug-flag from. Do you happen to know a way to do this on the Mac version of DoD not using Steam that is?

  20. r_b_bergstrom

    r_b_bergstrom Will Mod for Digglebucks

    How to use debug mode on a Mac:
    1. Go to your Applications folder, and then your Utilities folder that's inside it.
    2. There's a program there called "Terminal", double-click on it.
    3. In Terminal, use the cd command to direct Terminal to the folder where Dredmor resides. Something along the lines of:
      • "cd /Users/*YOUR*USER*NAME*HERE*/Library/Application\ Support/Steam/SteamApps/common/dungeons\ of\ dredmor/Dungeons\ of\"
      • That cd path will be different if you don't have Steam, but you should be able to figure it out fairly easily based on where the game is located on your drive. Note that "/" and "\" distinctions are very important. "/" indicates the next level of folder. "\" replaces any spaces in the file or folder name.
    4. In Terminal, enter the following command:
      • ./dredmor -debug-flag
    A second or two later Dredmor will launch, in debug mode. It'll look the same as normal, but the special keyboard shortcuts will be available once you've loaded your game.