Windows Vista/7 64-bit CPU usage maxed on one core at all times.

Discussion in 'Bugs' started by OmniaNigrum, Mar 12, 2012.

  1. OmniaNigrum

    OmniaNigrum Member

    I tried searching for threads about this, but the search will not let me find the word "CPU" and I simply cannot think of what else to search for to find this. Here is a thread I made in the suggestions category that says everything I will quote in a moment. I made this thread after I was told that this is not normal.

    Below is the quoted post:
    I run the game in a window with sounds and music muted. And as it is, it keeps my CPU running hot because it is almost if not entirely a single core game. This could use some improvements, but I know that adding multicore support is a pain that usually causes instability as well.

    OpenGL would be nice if it worked properly since it is as the name implies: Open. Once you get everything working well in OpenGL for one OS you need not change anything about the rendering method for any other OS that supports OpenGL to work as well. (In theory at least.)

    I play on a nice quad core gaming system with a beast of a GPU. Yet it seems that every last thing is handled by the CPU at all times. For a roguelike this is odd, if not ridiculous. When a 3.2Ghz system has an average of 92% CPU utilization on a single core, and less than 10% on all the rest it means loads of wasted power and heat that will reduce the lifespan of the system.

    I am running 1.0.10 RC5 on my Phenom II 955 3.2GHz x4 with a Radeon 5850 GPU on Windows 7 x64.

    I have the latest drivers and all the Windows updates yet it still runs as hot as a single threaded Crysis with maxed video settings. This is simply dumb. Am I missing something? Or is it this way for everyone?

    *Edit* I am using the -opengl flag as well as the -debug-flag in the shortcut. I expected that the log running with debug mode would show that the renderer was switched to OpenGL when I added that flag, but it does not. It shows OpenAL either way.

    Is the game primarily using SDL as the renderer?

    I really loved the game known as "Rage" by id software. It was the first commercial shooter to use only OpenGL as the renderer and it forced both ATI/AMD and Nvidia to come clean and finally support OpenGL like they pretended they had all along. (I say pretended because every driver they released supported different extensions and there was no way to be sure that any one version would work or not besides trying it with that version.)
  2. Daynab

    Daynab Community Moderator Staff Member

    Not disputing your finds but I was curious so I tested on my own PC (i7 2600k, 3.4ghz x4, with a geforce GTX460) and with a bunch of stuff open, and it running in windowed mode I only have about 50% of the first thread (i7 has 8) taken.
  3. OmniaNigrum

    OmniaNigrum Member

    As evidence of what I am saying, here is a screenshot with my process list, DoD, and Core Temp all visible. With almost everything else I do, the CPU automatically scales back to 800 MHz rather than staying at 3.2GHz. But with DoD running at all it is locked at that maximum speed.

    Just for those who do not already know, since I am running a quad core, 25% on the task manager means one core is maxed. And it has no means to tell you the total CPU usage at all. I extrapolate that from Core Temp and other tools like Process Lasso.

    I am not really sure this even qualifies as a bug. But it is odd that I seem to have higher CPU utilization than others. Anyone have some suggestions on what to do to diagnose and/or fix this?

    Is there a way to disable animations altogether? That may well achieve the goal I seek without any difficulty.

    Thank you all in advance.

    *Edited to insert the image I said I would insert...*
    *Edited again to insert an image showing correct and more average CPU usage.*
    Crazy CPU utilization 001.jpg
  4. OmniaNigrum

    OmniaNigrum Member

    For comparison, here are tow more. The first is the CPU in a half scaled mode while decoding it's part of an x.264 rip of TLOTR:TTT. As you can see, the CPU is not even breaking a minor sweat with the task.

    The second is the same movie paused and minimized. It scaled back to 800MHz. I cannot fathom why DoD requires so much power to operate.
    Crazy CPU utilization 002.jpg
    Crazy CPU utilization 003.jpg
  5. Daynab

    Daynab Community Moderator Staff Member

    Uh, as per your picture, Dredmor is only taking 4% of your cpu. The 20% at the bottom is the total of ALL the processes' CPU usage, just like the "Physical Memory" is the total of all the RAM used by every process.

    As for me, after an hour of having dredmor (in game) open, it still stays around 8-9% usage.
  6. OmniaNigrum

    OmniaNigrum Member

    I edited the post to show more average CPU usage. It floats around generally between 19-25% usage on the task manager, and since that is a quad core, 25% is 100% of the core. (Windows Seven seems to lack a task manager that can make sense of multicore usage.)

    I guess I must have took the screenshot at the wrong second. And I suppose the title is misleading. It says maxed, but that is not true. It averages near maxed on one core.
  7. Daynab

    Daynab Community Moderator Staff Member

    Ah okay, yeah that's more like it. Strange. As for task manager if you go into the performance tab, each of the graphs stands for one core. Most computers have two logical cores nowadays for each physical cores so you'll probably have 8 graphs.

    I'm gonna try to find a reason for why that's happening.
  8. Daynab

    Daynab Community Moderator Staff Member

    Okay, it looks like -opengl is the culprit. If I run the game without opengl I stick to the 8-9% I told you earlier, if I use -opengl it skyrockets to 18-20% which is pretty much the same as you (since I have a slightly bigger cpu).

    Looks like the solution is to not run with -opengl. It WAS said to be somewhat experimental a while ago by Nicholas.

    edit: yes, this is a SDL game.
  9. OmniaNigrum

    OmniaNigrum Member

    I wish OpenGL was the case for me as well, but it seems to have exactly zero noticeable change for myself. Perhaps the game somehow defaults to OpenGL rendering even if I do not have that specified in the shortcut? Is there a way to specify not to use it? (Just for testing if that was the cause.)

    I really only discovered the -opengl part this morning, yet every version of the game I have run uses about the same CPU time. I tried it because I simply like the idea of OpenGL. I had no expectations that it would change the resources used though.

    If I delete my configuration files entirely, will the game generate them with default settings when run? (I am thinking maybe something from an earlier version persisted through to the current version.)

    Again I thank you for this and any further replies. You are exceptionally helpful. I would shower you with likes if it did anything more useful than flooding you with alerts. :)
    (OmniNegro sends a digital and Platonic kiss to Daynab. AND Speaks in the third person too)
  10. Daynab

    Daynab Community Moderator Staff Member

    Try running through Steam, making sure there's nothing in the launch options (right click the game in the library, properties, launch options). See if it works like that.
  11. OmniaNigrum

    OmniaNigrum Member

    Not t be a jerk, and I understand you cannot remember every detail in every thread, but I do not have Steam at all. I used a disposable Windows install to buy the game.

    I have tried it clean, and I guess the next step is to reinstall it from my backup after deleting every reference to it on my system.

    (Just in case you want the explanation of why I will not use Steam, here it is:

    Thank you for the help anyway.
  12. Daynab

    Daynab Community Moderator Staff Member

    Oh, right. Sorry. Then I don't know, if you run the exe directly instead of a shortcut then it shouldn't stay in -openGL.
  13. Nicholas

    Nicholas Technology Director Staff Member

    We're going to get something with no DRM set up real soon. This was one of the things that Citizen did at the GDC this month.
    OmniNegro likes this.
  14. OmniaNigrum

    OmniaNigrum Member

    Thank you for that Nicholas. And please forward my thanks to Citizen next time you chat. :)

    @Daynab Just for information, Intel has a patent upon some detail of multithreading individual cores. So AMD CPUs cannot do that. Here are two more screenshots. The first is with DoD running, and the second is after closing DoD.. (This time I focus on the Performance tab of the task manager.)
    Crazy CPU utilization 004.jpg
    Crazy CPU utilization 005.jpg

    Understand that I am in no way suggesting that DoD is to blame for this. But something is awry. I guess I will add a request to the impossible things to implement thread for disabling animations and minimizing CPU usage.
  15. Daynab

    Daynab Community Moderator Staff Member

    Interesting, about the patent. I had no idea about that.
  16. OmniaNigrum

    OmniaNigrum Member

    Actually, I may have pulled that out of my ass. I just spent a few hours reading through AMD and Intel CPU related pages on Wikipedia and cannot find any evidence that there is any real advantages to Intel's threading system.
    (I could have sworn that was the reason for single threads per core on the entire Phenom lineup.)